BuildMaster 5.4.1 Has Been Released

We just shipped BuildMaster 5.4.1. It's a maintenance release of BuildMaster 5.4 which means that there is minimal risk to upgrading from an earlier 5.4. However, if you're planning to upgrade from a version prior to 5.4, make sure to read the appropriate upgrade notes.

To install or upgrade, simply download BuildMaster and run the installer.

Here's what we changed between 5.4.0 and 5.4.1:

  • BM-2245 - Include Pipeline Name Auto-complete in Deployment Variables for Release Template
  • BM-2244 - Increase visibility of deployables on SQL script asset list
  • BM-2242 - FIX: Cache UserConfig Values to Aide Viewing of Extremly Large LogFiles
  • BM-2241 - FIX: Deployment Template Variables May Not Be Displayed on all Deployments
  • BM-2240 - FIX: DB update tool can fail on mono with assembly load error
  • BM-2239 - FIX: Error downloading changescripter tool when there is only one DB connection type
  • BM-2238 - FIX: Non-legacy Configuration Variables May Not Get Cloned During Clone Application
  • BM-2237 - FIX: Display Friendly Message When Permission Denied to Access PowerShell Assets Page
  • BM-2236 - FIX: Cannot add legacy scripts to legacy plans in some cases
  • BM-2235 - FIX: Paths on Linux servers are sometimes resolved using Windows directory separators

To learn more about how we distinguish between major, minor, and maintenance releases, make sure to check out KB#1059 - When should I update?