BuildMaster 5.6.3 Has Been Released

We just shipped BuildMaster 5.6.3. It's a maintenance release of BuildMaster 5.6 which means that there is minimal risk to upgrading from an earlier 5.6. However, if you're planning to upgrade from a version prior to 5.6, make sure to read the appropriate upgrade notes.

To install or upgrade, simply download BuildMaster and run the installer.

Here's what we changed between 5.6.2 and 5.6.3:

  • BM-2313 - FIX: Cannot add system-level event listeners when pipeline stage names contain a comma
  • BM-2312 - FIX: Clicking the servers link on the roles page should filter the list of servers by that role and include a dropdown to change the role
  • BM-2311 - FIX: Deployment execution completed event listener does not fire after deployments to pipeline stages that utilize a legacy plan
  • BM-2310 - FIX: SOAP API should generate string types for parameters of YNIndicator type
  • BM-2309 - FIX: Infrastructure Sync Does Not Consider "Active/Inactive" Drift
  • BM-2307 - FIX: Legacy Transfer Files Action to a Server Group may Yield Deployment Errors When Initializing Servers
  • BM-2305 - FIX: MultiDomainActiveDirectory throws COMEXception if a domains in the forest is not accessible
  • BM-2295 - FIX: Operation arguments that accept a map generate a compilation error if one of the values in the map is an empty string

To learn more about how we distinguish between major, minor, and maintenance releases, make sure to check out KB#1059 - When should I update?