ProGet 4.6.3 Has Been Released

We just shipped ProGet 4.6.3. It's a maintenance release of ProGet 4.6 which means that there is minimal risk to upgrading from an earlier 4.6. However, if you're planning to upgrade from a version prior to 4.6, make sure to read the appropriate upgrade notes.

To install or upgrade, simply download ProGet and run the installer.

Here's what we changed between 4.6.2 and 4.6.3:

  • PG-681 - FIX: Spurious authentication errors and web UI exceptions on Linux
  • PG-680 - npm feeds now support basic authentication even if Windows Integrated Authentication is enabled
  • PG-679 - FIX: npm adduser can fail with server error (regression)
  • PG-677 - FIX: URL displayed on the package page for a Universal Feed has an extra slash
  • PG-678 - FIX: Improve error message display for "string is not a valid semantic version" error on uploading a universal package
  • PG-674 - FIX: Package details page with version omitted from URL does not load on Linux

To learn more about how we distinguish between major, minor, and maintenance releases, make sure to check out KB#1059 - When should I update?