ProGet 4.7.2 Has Been Released

We just shipped ProGet 4.7.2. It's a maintenance release of ProGet 4.7 which means that there is minimal risk to upgrading from an earlier 4.7. However, if you're planning to upgrade from a version prior to 4.7, make sure to read the appropriate upgrade notes.

To install or upgrade, simply download ProGet and run the installer.

Here's what we changed between 4.7.1 and 4.7.2:

  • PG-744 - FIX: HTML is incorrectly double-escaped for vulnerability details
  • PG-743 - FIX: Replication failure on linux with Feeds_SetLastSyncDate exception
  • PG-742 - FIX: Invalid object name 'FeedLicenseUrls' When deleting a feed
  • PG-741 - FIX: NuGet searches for multiple targetFrameworks can omit results that should be included
  • PG-740 - FIX: Ruby gem version page does not display correct publish date
  • PG-739 - FIX: Feed-level license rules should require Feeds_ManageFeed to edit and all others should require Admin_ConfigureProGet
  • PG-736 - FIX: Edit license dialog is sized incorrectly
  • PG-737 - FIX: Exception deleting global license definition
  • PG-738 - FIX: License filtering is not applied to npm packages that specify an array of license objects
  • PG-735 - Increase visibility of indicator on package page when a package is blocked

To learn more about how we distinguish between major, minor, and maintenance releases, make sure to check out KB#1059 - When should I update?