Ask A Question

View Question

Not sure whether I mixed something up during install, but I can't find any misconfigurations in IIS. I opted for IIS during install, with a database on a SQL Server 2016 server elsewhere on the network. I have to assume that if I entered in my connection string incorrectly, the installer would have thrown a red flag and prompted me to fix it, right? If not, then let me know. But my question is regarding the web application; I gave it a binding; http://otter.domain:port/, and before I did that, I got an error regarding directory browsing not being enabled for the site, and then when I changed the binding, I get plain ol' "this page cannot be displayed" from internet explorer both locally and remotely. Firefox gives his equivalent of the same message as well. what in the world did I do? Thanks.

Product: Otter
Version: 1.6.2

Hi, While doing some work, I did get the URL to respond; I gave the site a specific IP address to listen on, and then allowed the custom port through, but still getting 403 forbidden when I browse anonymously. The message that shows up on the local server is that directory browsing is not enabled, but nowhere in the instructions does it mention the configuration of either directory browsing or of a default document. Also, under the web site's directory, I don't see any ASP.net related pages, so I'd not know what default document to give it unless I did.

Otter does not issue 403 messages, so it sounds like IIS is misconfigured. Unfortunately, this can be easy to do with machine-level settings and machine.config, and it's hard to say how to fix it.

It's hard to say what specifically to change, but sometimes it's that ASP.NET 4.5 is missing, or not configured on the server. Note this is different than .NET 4.5.

You may want to use the integrated webserver, because it's a little easier to configure.

I don't doubt there is a misconfiguration somewhere. However, I've been an IIS admin for years, so I know I'll figure it out one of these days. What are the default permissions and settings that need to be set on the Otter Web Directory, then? (I installed IIS from a script that I created years ago that configures a server for ASP.net). But the way the site is configured, no ASP.net pages, just DLLs, that is a bit foreign to me, so this must not be an ASP.net web forms, not even seemingly a MVC application? (I would recognize the .cshtml extension from miles away). Not sure what default document should be set to either on the site, because there are none I recognize to be web page files to be served to clients. I like a challenge, so I think there might be a lack of documentation. (I wonder what would happen if I gave the network service account full control of the entire directory)?

The set-up sounds correct; our web applications are indeed ASP.NET applications. However, the folder should just contain a web.config file and some DLLs. All requests are routed to the DLLs via a custom handler configured in the web.config file. In these files, we have embedded resources for things like css and javascript as well.

The only permission needed is to read the WebApp, and Extensions Directory, and full control over the extensrons temp directory.

The directory browse error, it sounds like the custom handler for asp.net is not being hit. Maybe it means ASP.NET isn't configured for the site / app pool?

Actually, the set-up and web technology we use is identical to ProGet; so if you've already got that configured, it should work identically.

I heard from another user who was experiencing exactly the same issue.

The solution they found was to switch otter’s IIS Application Pool to Classic Pipeline (instead of Integrated).

Of course it should work in both, but for whatever reason, it didn't here. So maybe it will help you as well!

Answer Question