Ask A Question

View Question

I am running the latest version of Otter under IIS 10. I receive the following error when trying to view the home page for the first time:
Server Error
403 - Forbidden: Access is denied.
You do not have permission to view this directory or page using the credentials that you supplied.
I have tried running the Otter ApPool under both classic and integrated mode, I've explicitly provided the Network Service account with full control on the "bin" directory, and I still receive this error. What am I missing? What other information could I provide to get this straightend out? I really don't want to use the builtin web server; IIS support is there for a reason.

Product: Otter
Version: 1.7.1

The most common scenario for this is that ASP.NET 4.5 is not installed/enabled on IIS, which is causing our application code not to be executed at all.

Note that it must be ASP.NET 4.5, which is a separate role/feature than .NET.

Note also that you may only have .NET 4.6 available as a feature; that's also OK, since it replaces .NET 4.5.

I'll definitely take a close look at the version of .net. I know that the app pool is using the right framework version, but I honestly can't remember which one is installed under programs and features. I'll keep you updated.

Not sure whether or not I'll ever figure out what the heck that was that caused that issue, but setting up the IIS sites manually and installing first with the basic built-in web server seemed to do it. It works just fine now; just need to get HTTPS set up on the internal URL and finally get things rolling.

Answer Question