New Reply

We have NGINX in front of our ProGet installation with SSL offloading.
So the traffic to the NGINX proxy is on HTTPS and the traffic between the proxy and the ProGet server is on HTTP.

This is causing issues with the URL's in the Installation Instruction section for package details.
For NuGet feeds, the URL's are on HTTP, without port: http://***.be/nuget/feedname/
For Docker feeds, the URL's are without HTTP scheme, on port 80: docker pull ***.be:80/feedname/

How are these URL's constructed? The strange thing is, when browsing to ProGet on the web server locally, the URL's are HTTPS and 443.

Is there a solution for this? The documentation says "ProGet was built to be compatible with any load-balancing platform, whether software-based (such as HAProxy, NLP, or nginx) " https://inedo.com/support/documentation/proget/installation/load-balancing-and-automatic-failover

Should we configure a Web Proxy in the Advanced Settings to solve this?

Product: ProGet
Version: 4.7.6

I solved this by configuring the URL including port number in the Advanced Settings at "Web.BaseUrl"

Answer Details

Preview:

Post Reply