Support Q & A Home

Ask A Question

Anyone can ask or answer a question here, but our support engineers actively monitor your questions; we typically answer within a day or two.

Filter
Viewing Page 59 of 92 (20 questions out of 1826)
6
replies

I'm trying to enable symbol and source server via ProGet.
I'm getting half the way I think.

I can get Visual Studio to request and download the PDB files but source setpping is not working for me.

In side the PDB files served from ProGet I can find the following block:

SRCSRV: ini ------------------------------------------------
VERSION=2
INDEXVERSION=2
VERCTRL=http
SRCSRV: variables ------------------------------------------
SRCSRVVERCTRL=http
PGSERVER=http://ms-ch12/source-files
PGFEED=ShurePackages
PGPKGID=Shure.TestUtilities
PGPKGVER=0.0.21.0
HTTP_EXTRACT_TARGET=%pgserver%/%pgfeed%/%pgpkgid%/%pgpkgver%/%var2%
SRCSRVTRG=%http_extract_target%
SRCSRVCMD=
SRCSRV: source files ---------------------------------------
SRCSRV: end ------------------------------------------------

It does not seem to list any source files, and the visual studio output window lists the following when trying to step in to the source of a nuget package:

SRCSRV: c:\Jenkins\jobs\CWB shure.testutilities\workspace\source\main\TestUtilities.Web\Helpers\ControllerHelper.cs not indexed

SRCSRV: Source server cannot retrieve the source code for file 'c:\Jenkins\jobs\CWB shure.testutilities\workspace\source\main\TestUtilities.Web\Helpers\ControllerHelper.cs' in module 'C:\Source\shure\shure.conferencing\Web\Web.Tests\bin\Debug\Shure.TestUtilities.Web.dll'. The system cannot find the file specified.

On the feed homepage for the module in the Symbols & Source section it writes:
Symbols and source files are available. [view]

I have inspected the package to both contain pdb files and a src section with all the source code.

ProGet report no indexing errors.

Any ideas of what is going wrong?

Product: ProGet
Version: 3.2.1

4
replies

I've created a URL Triggered Build in buildmaster with no security and have tested this by calling from a browser.

When I try via calling this from Jenkins (have tried 1) HTTP Request plugin and 2) writing a groovy script) I get an authorisation error.

I then tried adding a username and password to the URL Triggered Build and then can no longer trigger the build from a browser.

Any ideas why this isn't working?

Thanks,
Andrew

PS Can you also point me at some documentation for passing build number as a parameter

PPS Is it possible to trigger build promotion via url/api in similar way to triggering a build? The approach I am looking at is:

  1. Jenkins is building application and sending artifacts to artifactory
  2. Jenkins triggers build in BuildMaster and BuildMaster will deploy to the automated test environment
  3. Jenkins will run tests and if successful ask BuildMaster to deploy to the next environment
  4. All other Build promotion steps will be manual and done in BuildMaster

Product: BuildMaster
Version: 4.4.5

4
replies

I have an Automatic Build set for every 5 hours, from 2am to 6pm.
Based on my understanding from the documentation here, its 5 hours after the initial start time, and 5 hour increments after that until the end time.

So it should be at 7am, noon and 5pm.
The actual times last night were 6pm, 3am and 8am

I do know that when I promote builds using SQL to kick off many at once, I have to add 5 hours to my execution/promotion time due to a server time zone difference, I think. (it use to be 4 hours until daylight savings kicked in a few weeks ago)

Is there some obvious reason why these times are not making sense? Today I set up a few more to kick off every hour and they are working as expected, will see if they stop at 4pm as I desired.

Thanks,
Dan

Product: BuildMaster
Version: 4.5.2

1
replies

Can I pass a parameter to URL Triggered Build?

I'm building the application in Jenkins and placing the artifact in Artifactory. I want to pass the version number of the artifact to BuildMaster so that it will download and deploy the correct artifact.

Ta
Andrew

Product: BuildMaster
Version: 4.4.5

1
replies

It's great that you can import TeamCity artifact or Nuget package in the workflow build step, however you can only select one. We have to create an empty build plan and then import them that way. Is there any other way to do this, or the way we have done it is correct?

Product: BuildMaster
Version: 4.5.2

4
replies

Is it possible to keep the process running indefinitely? I notice that it spins down after idling for 5-10 min and it makes me login again. This also requires a longer than normal load time just after it goes to sleep.

Product: ProGet
Version: 3.2.1

1
replies

We really like that we can use Active Directory as an authentication source with ProGet. As a developer having another username and password is just a pain. A few questions regarding the implementation:

  1. If we have Active Directory authentication can we still allow for some feeds to be open/anonymous?
  2. Is it possible to still push to NuGet with the API key and not force NTML/Active Directory authentication?

Specifically I am thinking of the best way for build servers to push/pull to our private Nuget Server without having to have separate URL's/domains (one IIS site with authentication another internal URL without).

NOTE: We need a public/Internet feed (SSL) for some of our clients as they pull libraries from our NuGet server.

Product: ProGet
Version: 3.2.1

1
replies

Hi,

whats the best/correct way to implement notifications for manually package uploads from disk?

I already managed it to get working for with the after push adapter, but we want to implement notifications when we are uploading pre-packed packages from disk.

br,
Martin

Product: ProGet
Version: 3.2.1

1
replies

I am trying to set up a private feed, by making sure an anonymous user can't access the feed.
I did this by restricting the priviledges an anonymous user has and that works.
But I now need to in some way authenticate myself in visual studio to access the feed.

I have tried added the feed with [feed address] -ApiKey [username]:[password] but that does not seem to work.
How am I supposed to login as a specific user in Visual Studio?

Product: ProGet
Version: 3.2.1

1
replies

Hi,

I am trying to set a variable from file. I would like to set it as [Key]=[Value]

I am not sure how to read it using the regex function on the "Set Variable Value from File" action item.

Can you please assist.

Thanks

KP

Product: BuildMaster
Version: 4.4.7

1
replies

Hi.

After upgrading from v3.1.0 to v3.2.1, I now see the following error repeated in the indexing log on the admin page:

Package Indexing Error
Feed XXXX-R2.0
Package AAA.BBB.2.0.18654.0.nupkg
Message Sequence contains no elements
Date 11/7/2014 3:08:38 PM
Stack Trace at System.Linq.Enumerable.First[TSource](IEnumerable`1 source)
at Inedo.NuGet.Packages.NuGetPackage.ReadFromNupkgFile(Stream stream)
at Inedo.NuGet.Packages.NuGetPackage.ReadFromNupkgFile(String fileName)
at Inedo.ProGet.Extensibility.PackageStores.DirectoryPackageStore.TryReadPackage(String fileName)

Any thoughts on what might be causing this?

Product: ProGet
Version: 3.2.1

3
replies

I have a lot of issues; when I push packages I have to restart the service several times to finally see the new package.
Of course re-indexing works; BUT I don't want re-indexing every time a push a new package.

Product: ProGet
Version: 3.2.1

1
replies

All the sudden, ProGet stopped taking packages. I tried to create a new feed then upload a package from the disk. It came back show nothing. Can someone help?

Product: ProGet
Version: 3.1.7

1
replies

I am trying to use a variable to specify a service name when I am stopping and starting windows service. The replacement looks like it is working but the process is failing with the follow error details. Should variables be able to be used?

1: Start $ServiceName Service  
DEBUG: Source and target directory are the same; splitting...
DEBUG: AgentBasedAction initialization complete:
DEBUG:   Temp Directory: C:\BuildMasterAgent\_AGTTMP\_A3089\_S3089\TMP
DEBUG:   Source Directory: C:\BuildMasterAgent\_AGTTMP\_A3089\_S3089\SRC
DEBUG:   Target Directory: C:\BuildMasterAgent\_AGTTMP\_A3089\_S3089\WRK
DEBUG:   Server: recsappdev (Id: 1036)
DEBUG: Initializing action...
DEBUG: Initialization complete. Executing...
 INFO: Starting service SubmitService...
ERROR: Service could not be started: Cannot start service SubmitService on computer '.'.
DEBUG: Execution complete. Finalizing...
DEBUG: Target directory unused; joining with source.
DEBUG: Finalization complete.

Product: BuildMaster
Version: 4.4.7

1
replies

We are having trouble trying to add a package to our proget feed. We are trying to pull various packages from nuget.org. The majority of times we get an SSL error but occasionally it works (same parameters).

Unchecking the Download dependencies check box seems to help a little but doesnt fix the issue.

Error message is:

Server Error in '/' Application.

the request was aborted: Could not create SSL/TLS secure channel.

I dont have the exception handy but I think the error was a timeout.

Product: ProGet
Version: 3.2.1

1
replies

When i try to execute my workfolw in BuildMaster, it's throwing me the following errors. It seems like there is a certificate issue. Can you please help me out in fixing that.

ERROR: C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Microsoft.Common.targets(2482,5): error MSB3326: Cannot import the following key file: . The key file may be password protected. To correct this, try to import the certificate again or import the certificate manually into the current user's personal certificate store.ERROR: C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Microsoft.Common.targets(2482,5): error MSB3321: Importing key file "ppmillinous.pfx" was canceled. INFO: Done building project "wa5invqz.tmp_proj" -- FAILED. INFO: Done building project "POWERPitch.csproj" -- FAILED. INFO: Done building project "POWERPitch.sln" -- FAILED.ERROR: Build failed (msbuild returned 1).

Product: BuildMaster
Version: 4.4.7

1
replies

Is it possible to recover the admin password on the free community version of ProGet? If so, what are the steps to do so?

Product: ProGet
Version: 3.2.0

1
replies

Hi, I'm testing proget in monodevelop.

I installed nuget addin for monodevelop, and tried to search for packages that were uploaded to proget server
But nuget addin don't show any results.

In Visual Studio, searching works well. Only monodevelop and proget didn't works well.

Can you check this problem?

Thanks.

Product: ProGet
Version: 3.2.0

1
replies

Where do I have to put the assembly when I write a Simple Action Using the BuildMaster SDK?

Is there is example that shows which info to input into a Prepare ClickOnce action?

Product: BuildMaster
Version: 4.4.7

1
replies

The ProGet manual service installation instructions say the following:

  • Install the service. To do this, run ProGet.Service.exe and display help to discover the arguments for the "install" option. Administrator elevation is required to install the service and reserve URLs for self-hosted installations. If you do not reserve a URL the integrated web server will not be enabled.

I am trying to use IIS to host the website component, so as I understand it, I don't need a URL reserved. However, the installer simply reports the following:

  • URL must be specified.

What command line would be used to register the service without a URL reservation?

Product: ProGet
Version: 3.2.0

Ask A Question
Page: 123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657596162636465666768697071727374757677787980818283848586878889909192