Support Q & A Home

Ask A Question

Anyone can ask or answer a question here, but our support engineers actively monitor your questions; we typically answer within a day or two.

Filter
Viewing Page 60 of 97 (20 questions out of 1931)
1
replies

In the ProGet Documentation, 3 different API Key configurations are described. I'm using "Custom API Key" Configuration. That means

  • I've configured an API Key on the Feed property page (Minor issue: Would be nice to see it directly in the properties table and not only when editing properties)
  • I'm using a private feed and have provided credentials in the nuget.config (this generally works)
  • The user has the Feeds_AddPackage privilege assigned

I' mushing using the following command:
nuget.exe Pack.1.0.0.nupkg xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx -source https://myserver/nuget/myfeed

What i get is the following:

Pushing Pack.1.0.0 to 'https://myserver/nuget/myfeed'...
Using credentials from config. UserName: xxxxxxxxxx
Failed to process request. 'There was an error processing the request: You are not authorized to add 
a package to this feed. By default, ProGet is not configured to allow unauthenticated users to publish
packages to a feed. You will need to either authenticate (by using "name:pass" as your API Key) or give
the Anonymous User the Feeds_AddPackage privilege.'.
The remote server returned an error: (403) Forbidden..

Am I doing something wrong? As of the documentation, my understanding is that it should be possible to specify credentials for authentication in the nuget.config and providing a valid API key in the nuget push command. I don't want to provide credentials in the nuget push command line since it's part of the build process and readable by everyone while the nuget.config is protected on the build server.

Product: ProGet
Version: 3.4.7

7
replies

I’ve installed ProGet and created a nuget feed. I was able to add a package from the local browser using “Upload Package” and then retrieve it in Visual Studio.

However, I’m not able to publish a package from NuGet Package Explorer from a remote computer. I set the feed up with an API Key, “Infinias”. I get an error as shown below when I try to publish a package. I don’t find anything in the documentation that helps.

I get this error in Nuget Package Explorer: "Failed to process request: 'There was an error processing the request: Package feed was not specified.'

Product: ProGet
Version: 3.4.7

3
replies

Hi,

The Bower KB article states:
"Currently, Bower can only connect to ProGet if Windows authentication is not used."

Does this mean that you have to disable LDAP authentication altogether for the ProGet server?

If so, this it a shame as we would like to use the Bower integration but are actually paying for the Pro version because of the LDAP authentication feature.

Are you working on supporting LDAP authentication for Bower? Or it it not possible at all?

Product: ProGet
Version: 3.3.4

1
replies

I'm evaluating ProGet's Enterprise edition, and am trying to set up LDAP authentication. Am I understanding it correctly that the feature provides the following?

  • user management sync'd to an LDAP server (a ldap:// url)
  • private feeds can be consumed only if LDAP-authenticated
  • packages can be published to the feeds only if LDAP-authenticated

When I click the "Switch to LDAP Authentication" link in the Admin section, I first got the alert that Windows Authentication needed to be enabled. So I enabled it and disabled the other auths in IIS. Now I get this alert:

"There are currently no privileges granted to any LDAP users or groups.
You must grant privileges before switching to LDAP authentication."

Where do I configure the LDAP server (the ldap: url) to which to sync the users and groups? I see the "Privileges & Roles" page, but that seems to be for non-LDAP users and groups.

Mainly our team is evaluating whether to purchase the Enterprise edition for its LDAP integration, looking to not create/maintain ProGet-specific users and credentials.

Product: ProGet
Version: 3.4.7

3
replies

Are multiple npm feeds supported in ProGet?

I added two npm feeds. Running 'npm search' and 'npm publish' against either of them (command line) would give error:

"MultipleNpmFeeds The client is using the wrong search URL, and there are multiple
npm feeds available, so ProGet cannot determine which feed to search.: -/all"

If I remove one, leaving only one npm feed, then npm search/publish would work.

Does ProGet support only one npm feed? or am I missing some configuration somewhere? Thanks.

Product: ProGet
Version: 3.4.7

4
replies

Initial feed content contains a title- field. I would expect to find the name of the feed there but the title is always "Default". Would be great to have the real title in this context. Any chance to get the feed name from the feed content?

The feed "MyFeed" looks like that:

<service xmlns="http://www.w3.org/2007/app">
  <workspace>        
    <title xmlns="http://www.w3.org/2005/Atom">Default</title>        
    <collection href="Packages">          
      <title xmlns="http://www.w3.org/2005/Atom">Packages</title>        
    </collection>      
  </workspace>    
</service>

I would expect to see "MyFeed" instead of "Default" in the title.

Product: ProGet
Version: 3.4.6

5
replies

I've created a feed with caching enabled, added a connector to the nuget.org feed and pushed two of my own packages to the feed.

I expected to see hundreds of packages from nuget.org in my feed (with that antenna - or whatever it is - symbol in the icon to mark packages from connectors) and my own packages. And i did so. Everything as expected.

Then, I removed the connector, cleared the cache and switched of caching for the feed. After a few days, I expected to see nothing than my own two packages. Nope. In the feed, I have my own packages - as expected - and six random packages from the official nuget feed (this time without the antenna symbol). These packages were never downloaded from the feed. I've tried to enable/clear/disable caching again, waited another day but these packages still sit in my feed and I have no idea why and how to remove them.

Any explanation why they're still in my feed and how to get rid of them?

Product: ProGet
Version: 3.4.6

6
replies

I want to use a ProGet feed that requires authentication in my build process. I've added the credentials required to access the feed to NuGet.config. Build fails because if the fact that packages cannot be retrieved from ProGet. A little bit of investigation leads to the following problem:

NuGet relates configured credentials to the base feed url. So it can be used for authentication of the feed url (e.g. http://myserver/nuget/myfeed in ProGet or https://www.nuget.org/api/v2 for nuget.org). That's why the first step of a nuget package restore, retrieval of the package list works. For package retrieval from authenticated feeds, nuget looks if the configured feed url is base of the package url and if so, io uses the configured credentials. That works for nuget since here, feed url is base of package url (e.g. https://www.nuget.org/api/v2/package/anypackage/anyversion). You can see, the package url starts with the feed url and thus, nuget can use the configured credentials to pull the package.

In ProGet, feed url is not base of the package url (e.g. http://myserver/api/v2/package/myfeed/anypackage/anyversion) and thus, nuget will not use the configured credentials for authenticating the package pull ("http://myserver/nuget/myfeed" is not base of "http://myserver/api/v2/package/myfeed"). That's bad.

Two questions:

  1. Is there a certain reason for having package urls completely different from the base feed url. Seems to be a bit uncommon.
  2. Is there a workaround for the issue? Otherwise, ProGet is simply not usable for hosting authenticated feeds.
  • I'm using ProGet Enterprise 3.4.6

Product: ProGet
Version: 3.4.6

3
replies

I want to create both a Public-access feed (meaning anyone can view/download packages, but NOT push), and a Private (Nuget) feed (meaning only authenticated users can view/push). How would I do this? I don't see any documentation for this.

Can this be done using the free version of ProGet, or is that restricted to Enterprise?

Product: ProGet
Version: 3.1.0

3
replies

How do I properly encode or escape HTML for a parameter value of an HTTP 'Post to URL' deployment action?

Product: BuildMaster
Version: 4.5.7

2
replies

Hi,

We are currently using ProGet 3.4.6 (build6), and currently I'm trying to push a package along with *.symbols.nupkg, however I'm failing to push the *.symbols.nupkg.

When I try to push symbols package (*.symbols.nupkg), I tried using the following after submitting the *.nupkg, however its not working:

nuget push SamplePackage.1.1.0.symbols.nupkg <api-key> -Source https://proget-srv/symbols/site.team

I'm not too sure with the URL whether its correctly, I assumed its something like e.g. https://proget-srv/symbols/site.team, based on http://inedo.com/support/documentation/proget/feeds/symbol-and-source-server.

Also in http://inedo.com/support/tutorials/debug-into-internal-nuget-packages-with-proget there's a tutorial which shows the endpoint name clearly, however it seems to be an old version and in the new version the URL is not shown anywhere (or at least the administrator can't find it).

However for the *.nupkg its working fine by using something like the following:

nuget push SamplePackage.1.1.0.nupkg <api-key> -Source https://proget-srv/nuget/site.team

Any help will be greatly appreciated it, thanks.

Product: ProGet
Version: 3.4.6

2
replies

Hi I want to make proget available at for example

https://dev.mydomain.com/proget/

Is this possible? It seems that it is impossible to make proget think it's anywhere except the root.

https://proget.mydomain.com is not ideal sadly

Product: ProGet
Version: 3.4.5

2
replies

I’m just looking at ProGet free version at the moment to see if could be of use to me. I’ve installed it on my local machine using the built-in web server, and can successfully use it as a nuget server, can upload packages and add references to them in Visual Studio, but the thing I can’t get to work is debugging using the symbol server.

The package I have uploaded has the .pdb and source files in it (I use the –symbols flag when creating the package). The ProGet site for the package shows debug symbols are available and indexed.

I’ve set up VS (2013) to pull down the symbols from the feed and have the debugging settings set correctly I believe (Enable Just My Code is unchecked, Enable source server support is checked).

When I debug, the .pdb gets pulled down but the source code doesn’t, so I get an error in the output window indicating that the source file can’t be found.

Can you give me any ideas on how I can get source code debugging to work please?

Thanks in advance.

Product: ProGet
Version: 3.4.5

2
replies

We are currently setting up BuildMaster to work through our build and deployment process. For the most part this is working fine. Because we will be building several internal libraries and applications through BuildMaster, it would be in our best interest to reduce the time taken to spawn up and configure each new application however.

The deployment plans that have been configured largely contain common steps due to heavy use of Release Variables with default values.

Ideally it would be nice if we could create a global workflow which had all but one environment using a global deployment plan. This would allow us to re-use the same workflow but still have the power to tweak the single custom plan as each application requires.

Because it doesn't appear to be possible to have a custom 'per application' deployment plan inside a global workflow (makes sense as the whole thing should be global), we need to look at an alternative.

I've created a sample application which I intend other developers to be able to duplicate as required for each new library or application that needs to be set up. I was hoping that we could just duplicate this through the New Application wizard and it would be able to:

  1. Create a new application specific workflow.

  2. Copy the custom application specific deployment plan and place a new un-linked instance inside the new workflow.

  3. Maintain the global deployment plans so that they still link to the global versions.

Unfortunately it looks like we only have three options at this point in time, and none really fit what I want:

  1. Copy Deployment Plans (creates a new instance of each deployment plan, including globals).

  2. Link Entire Deployment Plans (exactly what it says on the tin, any change in the custom plan affects the sample application as well as each linked application)

  3. Link Only Action Groups (same as 1 but action groups inside the plans remain linked together).

Is there a better way than this?

  • Duplicating with the 'Link Entire Deployment Plans' option.
  • Exporting the single custom deployment plan to XML.
  • Creating a new deployment plan to replace the custom linked one.
  • Re-importing the custom deployment plan from XML.
  • Setting the execution server on all the action groups as it has disappeared.

Product: BuildMaster
Version: 4.6.0

1
replies

I am wondering if there is any log currently being kept for a feed which would show who and when a package was deleted from a feed?

Product: ProGet
Version: 3.4.3

1
replies

A symbol package for a .NET 4.5.2 component is built on TFS and uploaded to a Proget feed.
Using Visual Studio 2013, I create a new solution for a console executable and add a reference to this package; I add a line of code with a breakpoint so I can test stepping into the component;
I hit debug; It downloads the PDB file correctly to the symbol cache;
Visual Studio prompts me to find the source code. It asks for the full path that was used when the package was built on the TFS server. But I don't have the source code on my laptop. I wanted to pull it from the Proget symbol server!

I checked the downloaded PDB with srctool -r. It lists all source files, using the path used on the build server.

Isn't Proget supposed to reindex the PDB file to tell it to obtain sources from the source server? That doesn't seem to be happening.

Can someone help me with this?

Product: ProGet
Version: 3.4.4

3
replies

How do I get the feed to pick up the NuGet packages in the drop folder? I have configured the path, which is the folder in which we have been serving the packages from (just served as a folder share), but the feed shows nothing and appears to be ignoring these packages. How do I trigger the import process, or what am I missing?

Thanks,
James

Product: ProGet
Version: 3.4.5

4
replies

As our company works on PHP/Magento projects almost as often as .NET projects, it'd be quite useful if we could use ProGet to host our own internal Packagist feeds for PHP Composer. We would appreciate it if we could know if Composer/Packagist is currently planned as one of the future registries/repositories for ProGet, and if so, by which version is it planned to be supported.

Product: ProGet
Version: 3.4.5

1
replies

Since we’re a Quebec based company, we’re forced by law to enforce French language in our applications so it would be really great if the admin site would be Multilingual.

Is there a way to translate it using ressource files?

If you provide us with these files we can translate it.

Regards

Product: ProGet
Version: 3.4.2

1
replies

The browse package doesn’t work well in IE 8

Image Text

Image Text

Image Text

Product: ProGet
Version: 3.4.2

Ask A Question
Page: 1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575860626364656667686970717273747576777879808182838485868788899091929394959697