Support Q & A Home

Ask A Question

Anyone can ask or answer a question here, but our support engineers actively monitor your questions; we typically answer within a day or two.

Filter
Viewing Page 66 of 95 (20 questions out of 1887)
2
replies

Hi,

It seems the GetUpdates call doesn't work in ProGet 3.1.2

https://www.nuget.org/api/v2/GetUpdates()?packageIds=%27Json.Net%27&includePrerelease=true&includeAllVersions=true&$orderby=Version%20desc&$top=1

When tried with ProGet IIS hosted. It returns Request handler not found (404).

Is the GetUpdates API implemented in ProGet?

Product: ProGet
Version: 3.1.2

6
replies

Our company is evaluating ProGet in order to host our own NuGet gallery. I was able to get ProGet working on my developer machine - everything worked great!

However, when I installed on our development server, the installation worked fine. But using the nuget push command doesn't seem to work as expected. Here is what I've been able to find in about 15 minutes of looking...

  • The %ProgramData%\ProGet\Packages\Production directory contains all of the packages I pushed
  • The Packages table is empty in the ProGet database
  • The admin console lists zero error messages, and the LogMessages table is indeed empty

I'm thinking it's a permissions issue somewhere. Below is the command I'm using to push packages to the server. Note that I've changed the package name, ApiKey, and server name where appropriate.

nuget push C:\Temp\NugetPackages\CommonLib.1.0.1.nupkg -ApiKey [ApiKey] -Source http://servername:81/nuget/Production -Verbosity detailed

Pushing CommonLib 1.0.1 to 'http://servername:81/nuget/Production'...
PUT http://servername:81/nuget/Production/
Your package was pushed.

Is there another log file that might give me the output of ProGet Core?

Product: ProGet
Version: 3.1.2

1
replies

I am working on a task to create an extension/plugin that does the following:

When a new package is added:

  • Identifies prior instances of the package being added
  • retain the most recent and ā€œnā€ number of instances
  • removes all other packages

Do you think this can be done using ProGet SDK?

If you so could please direct me on how to write this?

Product: ProGet
Version: 3.1.2

1
replies

Hello,

I am trying to assign variables that I've made for my QA server to the deployment plan for the same server. When editing the powershell script action, I'm trying to use the variables I've assigned instead of the application-level (global) variables that I have set. However, the variables I've set are being ignored. I've tried putting the server-level variables in %%, to no avail. I've tried without them to the same result. What do I need to do to access this?

Product: BuildMaster
Version: 4.4.2

1
replies

Greeting..

I am trying to get Diagnostic info out of a powershell script into the Log..

Write-Host and Write-Output do not seem to work..

I have been able to use Write-Warning and Write-Error but these change the status of the workflow to warning or error in addition to outputting the detail in the log.

Currently I am using "Write-Warning" but I would rather have a solution that keeps the workflow as a success.

J.D.

Product: BuildMaster
Version: 4.4.3

1
replies

Hi,

I have Proget Installed on my server using IIS & MSSQL Server. Using both proxied repos & local repositories.

However. I get the following error when pulling certain large sized packages from the server: "The page was not displayed because the request entity is too large."

How can I resolve this?

Thanks,

Dan

Product: ProGet
Version: 3.1.2

3
replies

I am trialing Proget for managing our internal nuget packages. I have just installed using an existing database and selected IIS for hosting.

I have set up a new nuget feed.

The problem is that when I try to add a .nupkg package from my local machine to the new feed I still see 'No packages found' in the feed browser.

I can see that the package has been moved into the feed disk path.
The Proget Service is running.
No recent errors have appeared in the admin page.
The Default feed pointing at nuget.org appears to be working fine.

I am sure there is some config I am missing but not sure what.

Can you help at all with this problem?

Product: ProGet
Version: 3.1.2

1
replies

For business reasons, we require our ProGet installation to be open over the public internet, but we intend this to hold proprietary packages not meant for public consumption.

Is there a checklist for hardening the ProGet installation in such a manner? Is this recommended against? I would expect things like disabling anonymous authentication, requiring SSL, enabling policies to enforce max password attempts, and so forth to be included in such a checklist.

Product: ProGet
Version: 3.1.2

1
replies

I just installed ProGet express edition. Chose integrated server and not IIS.

Installation was successful however unable to connect to localhost port 81.

Verified that service is up and running.

Restarted my machine as well.

Note: I do not have admin privileges, had to have network admin to login and do custom install as admin.

Please let me know if you can help.

Thanks
-Reddy

Product: ProGet
Version: 3.1.0

2
replies

Hi guys,
today morning I see that proget have a license problem.

Invalid: Value cannot be null. Parameter name: machineUID

this is the error.

Image Text

cam you help me pls

Product: ProGet
Version: 3.1.0

3
replies

I installed ProGet as an integrated webserver. However the biggest reason I want to use proget is the integration with AD and so I'd like to turn that on. However, when I try to add new domain users and groups, proget doesn't find them. No errors or anything, it just finds nothing. So of course I can't turn on ldap.

On a separate note I was mucking around in the support settings and I set the ldap thing to true which of course was my own stupidity because no AD users had permissions so I couldn't do anything anymore. The real problem is that even with a full uninstall (including database and package library), a fresh install is still mirked. I don't think your uninstaller is really working. I still can't administrate and it still shows me my old deployment projects even though as i said I did a FULL uninstall.

Product: ProGet
Version: 3.1.0

1
replies

I'm trying to install proget on windows server 2012. I have installed asp.net mvc4 as well as iis and the iis management console. The version which comes on server 2012 is iis 8. Anyway, when I run the proget installer, I cannot select IIS as an instllation option and in red it says "IIS, the IIS management console, and ASP.NET 4 must be installed on this server for this option." even though I believe I have all of those installed.

Product: ProGet
Version: 3.1.0

2
replies

Hi

As explained on previous posts here today, there are some serious bugs with ProGet 3.1.1 release which breaks our daily builds and promotion of packages in a pretty big way.

However, it does not seem easy to downgrade to version 3.1.0. I think you need some assistance and documentation to help people to downgrade in a hurry if there are problems with a new release, especially in an enterprise environment.

The installer for 3.1.0 simply says "A newer version is installed". I am now going to try and downgrade by following some of the steps on the manual installation page, but I am still nervous because I know the installer for 3.1.1 made upgrades to the database and I am not sure what to do about those. I am hoping it will still work against the 3.1.0 web site - if not I may have to restore the database backup.

Product: ProGet
Version: 3.1.1

10
replies

I'm evaluating ProGet 3.1.1 to replace our existing solution, but the following problem is happening:

When I use the command-line:

nuget install jQuery -NoCache -Verbosity detailed -Source http://my_feed_url

It is installing the wrong version of jQuery (not the latest one).
When comparing the output of nuget.exe pointing to ProGet vs nuget.org, it is easy to see the problem:

ProGet:

C:\temp\x>nuget install jQuery -NoCache -Verbosity detailed -Source http://my_feed_url
GET http://my_feed_url/FindPackagesById()?$filter=IsLatestVersion&$orderby=Version de
sc&$top=1&id='jQuery'
GET http://my_feed_url/Packages(Id='jQuery',Version='1.10.0')
GET http://my_feed_url/jQuery/1.10.0
Installing 'jQuery 1.10.0'.
Successfully installed 'jQuery 1.10.0'.

nuget.org:

C:\temp\x>nuget install jQuery -NoCache -Verbosity detailed -Source http://nuget.org/api/v2
GET http://www.nuget.org/api/v2/FindPackagesById()?$filter=IsLatestVersion&$orderby=Version desc&$top=1&id='jQuery'
GET http://www.nuget.org/api/v2/Packages(Id='jQuery',Version='2.1.1')
GET http://www.nuget.org/api/v2/package/jQuery/2.1.1
Installing 'jQuery 2.1.1'.
Successfully installed 'jQuery 2.1.1'.

After some test, I found that the query "FindPackagesById()?$filter=IsLatestVersion&$orderby=Version desc&$top=1&id='jQuery'" is working correctly on ProGet... It is not filtering by the latest package, nor is returning just one result... it seems to be returning ALL package versions, in no particular order

Can you please help with this issue?
Thanks

Product: ProGet
Version: 3.1.1

3
replies

Does the "Create NuGet Package" extension have any ability to automatically manage dependencies? If I use a .nuspec file, I have to manually list all external and .Net dependencies, which will be a pain to manage. I was hoping that by providing a project file instead of .nuspec file in the "Create NuGet Package" action that it would be able to resolve these dependencies automatically, but it does not appear to do so. Is there any way to have this action interpret reference dependencies and packages.config dependencies and automatically build those into the NuGet package?

Product: BuildMaster
Version: 4.4.2

1
replies

Some of our applications require several different team projects in order to build. In TFS, when setting up a build, you are able to specify multiple projects to pull down within the build definition. What would be the easiest way to replicate this in BuildMaster? Would I simply have a "Get Latest From Source Control" step for each project and then do a Build action after that?

Product: BuildMaster
Version: 4.4.2

11
replies

I have two ProGet instances, each configured exactly alike, with identical ProGet Deploy feeds with the same project, with the same Chocolatey package in it. Both ProGet instances point to the same deployment server. One ProGet instance deploys to the server without any issue. The other one fails with this message:

Starting deployment...
Verifying MYSERVER...
**System.InvalidOperationException: The stored password for the server "MYSERVER" is invalid.**
   at Inedo.ProGet.Service.DeploymentExecuter.DeployToServer(Deployments_Extended deployment, Servers server, IEnumerable`1 serverTargets)
   at Inedo.ProGet.Service.DeploymentExecuter.Deploy(Deployments_Extended deployment)

Both ProGet instances use the same user name/credentials on the target deployment server.

Product: ProGet
Version: 3.1.0

1
replies

I have a very simple ProGet Deploy feed set up with one project in it, with one Chocolatey package in it. When I deploy to my server, it successfully installs the Chocolatey package, but it doesn't execute the post-deployment script. It's a simple PowerShell script that does a "Copy-Item $Source $Destination". I can run the PowerShell command manually from the ProGet server and it works just fine. For whatever reason, it doesn't seem to run as part of the ProGet deployment. I don't see any interesting messages in the debug/log, either -- it is silently failing. Is there a way to get at logs or debug messages that would help me troubleshoot this?

Product: ProGet
Version: 3.1.0

1
replies

Hello,

We use Version 4.0.9 (Build 31) and I want to upgrade to the latest release.
However I'm worried that I may break/damage our settings, what do you recommend?

  • Is there any way to make a full back up of our settings?
  • Are they any breaking changes?
  • Anything I should be concerned about?

Product: BuildMaster
Version: 4.0.9

1
replies

Hello

I'm trying to do a deployment using the ProGet Deployment feature.

Following your tutorial, I have:

  • Created my Deployment feed.
  • Uploaded to the feed a package with a windows service I want to deploy.
  • I have added it to the Project.
  • I have installed Chocolatey in the target server.
  • Enabled WinRM, and added it to TrustedHosts (Checked I can execute basic commands like dir on remote machine)
  • Added an "Install Service" script to the package.
  • Added the package to the project.

And when I try to deploy the project, I get:

		Starting deployment...Verifying PAS4-TESTSERVER...
	System.Management.Automation.PSNotImplementedException: Cannot perform operation because operation "NewNotImplementedException at offset 108 in file:line:column <filename unknown>:0:0

" is not implemented.
at System.Management.Automation.RemoteRunspace.GetSessionStateProxy()
at Inedo.ProGet.Service.DeploymentExecuter.DeployToServer(Deployments_Extended deployment, Servers server, IEnumerable`1 serverTargets)
at Inedo.ProGet.Service.DeploymentExecuter.Deploy(Deployments_Extended deployment)

What am I doing wrong?

Product: ProGet
Version: 3.1.0

Ask A Question
Page: 123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646668697071727374757677787980818283848586878889909192939495