Support Q & A Home

Ask A Question

Anyone can ask or answer a question here, but our support engineers actively monitor your questions; we typically answer within a day or two.

Filter
Viewing Page 68 of 94 (20 questions out of 1879)
1
replies

We started using ProGet to host our packages. With our project still being in the early development phase we push packages often to our server. Our team is very distributed over the world so the pulling of packages to local computer is very important. We have noticed when we do a Nuget.exe -Update on a project and it pulls down the package from the server, it downloads the complete version xml list. On average that XML file is already between 300-550kb per package and growing by the day. Now we've been on ProGet for about 6 weeks, and with this growing in version XML file size it is going to be a real problem .

I have noticed that when we run the update that the "Microsoft*" packages all of them the "body length" in Fiddler is all around 461 bytes, and the body only contain one version.

Our package in the other hand the body in Fiddler contains all the versions from day one.
Are we using ProGet wrong, or maybe a setting somewhere?

Product: ProGet
Version: 3.1.0

1
replies

Hi Tod,

Following on from my Import Plan - Nullable Object must have a value issue...

Importing a xml file.

 I have upgraded to 4.3.8  and my original problem is now fixed - thanks.

Cloning applications

 Also duplicating an application now works - thanks.

But…

When I rename the deployable in the cloned application - I find that not all the references to the deployable in the xml are changed. ( It might also be renaming a deployable in general - I have only tried it an application that was duplicated.)

Below is a snippet of xml showing a successful rename (ResearchPapersAlert) and an unsuccessful rename (FactSheetGenerator)

FYI This application has a single deployable.

 <ActionGroup DeploymentPlanActionGroupId="4396" DeploymentPlanActionGroupSequence="4" ActionGroupId="4399" Active="Y" Shared="N" Parallel="N" IterateServers="N" IterateDeployables="N" OnFailureContinue="N" DeployableName="ResearchPapersAlert">
    <Name>Build App</Name>
    <Description> build/compile action.</Description>
    <Actions>
      <Action ActionSequence="1" ServerId="1" RetryCount="0" Active="Y" ResumeNextOnFailure="N" LogFailureAsWarning="N" Name="Build $CurrentDirectory\$ApplicationName.sln" Description="with Debug configuration to $CurrentDirectory">
        <Inedo.BuildMasterExtensions.WindowsSdk.MSBuild.BuildMSBuildProjectAction Assembly="WindowsSdk">
          <Properties ProjectBuildConfiguration="Debug" ProjectPath="$ApplicationName.sln" MSBuildProperties="" IsWebProject="False" BuildToProjectConfigSubdirectories="False" LogErrorsAsWarnings="False" _ExecutionId="0" OverriddenSourceDirectory="" OverriddenTargetDirectory="" Timeout="0" />
        </Inedo.BuildMasterExtensions.WindowsSdk.MSBuild.BuildMSBuildProjectAction>
      </Action>
    </Actions>
  </ActionGroup>
  <ActionGroup DeploymentPlanActionGroupId="4397" DeploymentPlanActionGroupSequence="5" ActionGroupId="4400" Active="Y" Shared="N" Parallel="N" IterateServers="N" IterateDeployables="N" OnFailureContinue="N" DeployableName="FactSheetGenerator">
    <Name>Unit Tests</Name>
    <Actions>
      <Action ActionSequence="1" RetryCount="0" Active="Y" ResumeNextOnFailure="N" LogFailureAsWarning="N" Name="Execute NUnit Tests" Description="Run NUnit Unit Tests on ${ApplicationName}UnitTests.dll">
        <Inedo.BuildMasterExtensions.NUnit.NUnitAppAction Assembly="NUnit">
          <Properties ExePath="" TestFile="${ApplicationName}UnitTests.dll" FrameworkVersion="" AdditionalArguments="" CustomXmlOutputPath="" TreatInconclusiveAsFailure="True" GroupName="Unit Tests" LogErrorsAsWarnings="False" _ExecutionId="0" OverriddenSourceDirectory="" Timeout="0" />
        </Inedo.BuildMasterExtensions.NUnit.NUnitAppAction>
      </Action>
    </Actions>
  </ActionGroup>

It seems If I make some sort of edit to the action group, or even just save it, the system recognises that the deployable has changed and renames it.

Broken Link

BTW you have a broken link on the website - on page
http://inedo.com/support/documentation/buildmaster/change-mangement/database-change-scripts

The database providers link fails.

Product: BuildMaster
Version: 4.3.8

3
replies

I have noticed some odd behaviour: when I promote an application into production, another build for integration immediately fires up for the same release. At the same time a new release is created but with no builds.

The new release I expect, but not the rogue integration build. I have an automatic build, but there has been no check in of code. Below are my workflow settings including the strict close-out

Promotion Eligibility - Strict

Release Cancelation - Enabled

Automatic Release Close-Out - Strict

Automatic Release Creation - Enabled

Thanks

Product: BuildMaster
Version: 4.3.8

2
replies

We're redoing our security strategy for IIS Application Pools and connection to SQL server and wanted to look further into AppPoolIdentity Virtual Accounts in IIS 7.5 or above. I notice that in "Create IIS 7+ App Pool" Action, this option is not available in the User Identity.

From what I've read, the SQL issues aren't significant, and you can still use integrated security, but long story short, has anyone gotten this to work?

Product: BuildMaster
Version: 4.2.6

2
replies

I've got a simple Deploy Artifact step for a deployment plan to the Testing stage, and it's just running endlessly with no output. I've tried a few times with the same results, then just this morning I set a timeout and retry limit, but it still looks the same. The promotion details seem to say that it is both "Awaiting Execution" and "in the process of being cancelled". I didn't set it to run in the future, and I didn't cancel it until it had been running for several hours without results.

Product: BuildMaster
Version: 4.2.8

3
replies

Using LDAP integration in ProGet, I have the following issues:

  1. I cannot add privileges for Domain Users, Authenticated Users or Domain Admins.
  2. I can add Users which I suspect is the local machines group BUT even though Domain Users is a member of this group, access is not granted and I get an error 500.
  3. Please change this error 500 to a 403 so that we can distinguish between setup issues and authorisation issues.

2 is a show stopper.

I look forward to your replies.

S.

Product: ProGet
Version: 3.1.0

1
replies

Hi

On the official nuget.org feed, it is possible to hide packages without deleting them permanently.

Does ProGet support the same feature? The "Delete" button seems to delete the package permanently, but I would like to remove a package from the feed without deleting it completely, i.e. I don't want it to show up if someone adds a new package, but if someone already has a dependency on it, I don't want it to break when trying to download the package during a build.

Regards
Riko

Product: ProGet
Version: 3.1.0

2
replies

Hi

After switching to ProGet we are having some issues using different major versions of our nuget packages. All the different package versions are displayed and can be downloaded from the ProGet browser but in the VS nuget package manager and the standalone nuget package explorer, only the latest major version is available. Can this behavior be changed somehow?

ProGet browser

https://www.dropbox.com/s/lp00uc995s3h5rl/2014-07-10%2015_28_09-GamePlay%202.0.23.png

Nuget Package Explorer

https://www.dropbox.com/s/lp00uc995s3h5rl/2014-07-10%2015_28_09-GamePlay%202.0.23.png

Best Regards,
Fredrik

Product: ProGet
Version: 2.2.13

1
replies

We upgraded to 4.3.8 from 4.2.4 and my server variables are no longer translating. These are legacy projects configured to support variable old and new variable formats. I tried all notation styles $SERVER.SESSIONSTATE, ${SERVER.SESSIONSTATE}, %SERVER.SESSIONSTATE%. I tried removing and recreating the variable. Any ideas about what to try next?

Product: BuildMaster
Version: 4.3.8

5
replies

Every time I try to delete one of my applications, it asks me to confirm, then waits for a few moments and throws a .NET exception in the modal window with the error "Timeout expired".

I have noticed the same behavior since 4.1.0.

Product: BuildMaster
Version: 4.3.8

1
replies

We are using build master 4.0.9 version. Many time we are facing agents' status is checking. This has been going on for over 10 hours and deployment is very slow i.e. for 10 MB data transfer to another server it will take more 2 hours.Any idea what would cause this?

Thanks,
Yogeshwar

Product: BuildMaster
Version: 4.0.9

3
replies

Using Buildmaster 4.3.7 we cannot get Buildmaster to accept the format of a private key for logging into a unix system.

The key has been generated by Putty, I have also tried exporting the key in openssh format but neither are accepted. Buildmaster reports Invalid Private Key File.

What formats are accepted by Buildmaster ?

Product: BuildMaster
Version: 4.3.8

3
replies

In older versions of BM, there was a method allowing a forced update to a specific build agent, but it appears to no longer exist in the current version (not sure when it was removed). I have about 15 different build servers running build agents, none of which are on the same network. If an agent fails to update, I no longer have a way to update the specific agent. My only option is to update all agents at once. Is there another way to initiate a specific build agent update?

Product: BuildMaster
Version: 4.3.8

3
replies

Hi there :)

I was previously running a TeamCity nuget feed which was unreliable so I am trialling ProGet.

I have successfully installed a ProGet server on a dedicated server :)

We use Teamcity to create nupkg packages and I want to integrate the Teamcity NuGet Publish Build Step to upload packages to ProGet. When I perform a NuGet publish from Teamcity, it fails with error

	[08:45:12]Step 3/3: Publish to ProGet (ABT Prod server) (NuGet Publish)
	[08:45:12][Step 3/3] push: Publish package Build\packages\SciChart.3.1.0.4680.nupkg
	[08:45:12][push] NuGet command: C:\BuildAgent\plugins\nuget-agent\bin\JetBrains.TeamCity.NuGetRunner.exe C:\BuildAgent\tools\NuGet.CommandLine.DEFAULT.nupkg\tools\NuGet.exe push C:\BuildAgent\work\fd34bcf86028b09c\Build\packages\SciChart.3.1.0.4680.nupkg %%teamcity_nuget_api_key_1404377112639%% -Source http://anonymised-feed-url'
	[08:45:12][push] Starting: C:\BuildAgent\temp\agentTmp\custom_script681410212521114575.cmd
	[08:45:12][push] in directory: C:\BuildAgent\work\fd34bcf86028b09c\Build\packages
	[08:45:12][push] JetBrains TeamCity NuGet Runner 8.0.27692.9
	[08:45:12][push] Registered additional extensions from paths: C:\BuildAgent\plugins\nuget-agent\bin\plugins-2.5
	[08:45:12][push] Starting NuGet.exe 2.8.50506.491 from C:\BuildAgent\tools\NuGet.CommandLine.DEFAULT.nupkg\tools\NuGet.exe
	[08:45:13][push] Pushing SciChart 3.1.0.4680 to 'http://anonymised-feed-url'...
	[08:45:13][push] Failed to process request. 'There was an error processing the request: You are not authorized to add a package to this feed. By default, ProGet is not configured to allow unauthenticated users to publish packages to a feed. You will need to either authenticate (by using "name:pass" as your API Key) or give the Anonymous User the Feeds_AddPackage privilege.'. 
	[08:45:13][push] The remote server returned an error: (403) Forbidden..
	[08:45:13][push] Process exited with code 1
	[08:45:13][Step 3/3] Step Publish to ProGet (ABT Prod server) (NuGet Publish) failed

Now I couldn't get the suggested Name:Pass API key method to work either this fails with error too.

	[08:51:31]Step 3/3: Publish to ProGet (ABT Prod server) (NuGet Publish)
	[08:51:31][Step 3/3] push: Publish package Build\packages\SciChart.3.1.0.4680.nupkg
	[08:51:31][push] NuGet command: C:\BuildAgent\plugins\nuget-agent\bin\JetBrains.TeamCity.NuGetRunner.exe C:\BuildAgent\tools\NuGet.CommandLine.DEFAULT.nupkg\tools\NuGet.exe push C:\BuildAgent\work\fd34bcf86028b09c\Build\packages\SciChart.3.1.0.4680.nupkg %%teamcity_nuget_api_key_1404377491436%% -Source  http://anonymised-feed-url'
	[08:51:31][push] Starting: C:\BuildAgent\temp\agentTmp\custom_script2375221507479887116.cmd
	[08:51:31][push] in directory: C:\BuildAgent\work\fd34bcf86028b09c\Build\packages
	[08:51:31][push] JetBrains TeamCity NuGet Runner 8.0.27692.9
	[08:51:31][push] Registered additional extensions from paths: C:\BuildAgent\plugins\nuget-agent\bin\plugins-2.5
	[08:51:31][push] Starting NuGet.exe 2.8.50506.491 from C:\BuildAgent\tools\NuGet.CommandLine.DEFAULT.nupkg\tools\NuGet.exe
	[08:51:32][push] Pushing SciChart 3.1.0.4680 to 'http://anonymised-feed-url'...
	[08:51:32][push] Failed to process request. 'There was an error processing the request: Invalid API key.'. 
	[08:51:32][push] The remote server returned an error: (403) Forbidden..
	[08:51:32][push] Process exited with code 1
	[08:51:32][Step 3/3] Step Publish to ProGet (ABT Prod server) (NuGet Publish) failed
	[08:51:32]Publishing internal artifacts

So, eventually I had to allow the anonymous user to have the Feeds_AddPackage privilege, which as you can imagine, is not idea.

Can you tell me how to enable NuGet publish from Teamcity to ProGet using authentication?

Product: ProGet
Version: 3.1.0

5
replies

Hi,

I export a deployment plan, but when I try to import it to another application I get

 a Nullable object must have a value exception.

The xml I am trying to import is :

<?xml version="1.0" encoding="utf-8"?>
<DeploymentPlan xmlns="http://inedo.com/schemas/buildmaster/2014/05/bmxplan">
  <Servers>
    <Server Id="1" LastModified="2000-01-01T00:00:00Z">DUB6WSD56001</Server>
  </Servers>
  <Providers />
  <ActionGroup DeploymentPlanActionGroupId="3292" DeploymentPlanActionGroupSequence="1" ActionGroupId="3287" Active="Y" Shared="N" Parallel="N" IterateServers="N" IterateDeployables="N" OnFailureContinue="N">
    <Name>Get Labelled Source Version From Perforce</Name>
    <Description>Actions in this group should label or tag a path in source control and then retrieve code from that path.</Description>
    <Actions>
      <Action ActionSequence="1" ServerId="1" RetryCount="0" Active="Y" ResumeNextOnFailure="N" LogFailureAsWarning="N" Name="Get Source from $SCMDir Labeled $ReleaseNumber.$BuildNumber" Description="to $CurrentDirectory">
        <Inedo.BuildMaster.Extensibility.Actions.SourceControl.GetLabeledAction Assembly="BuildMasterExtensions">
          <Properties UserDefinedLabel="$ReleaseNumber.$BuildNumber" SourcePath="$SCMDir" ClearTargetDirectory="False" ProviderId="7" LogErrorsAsWarnings="False" _ExecutionId="0" OverriddenTargetDirectory="" Timeout="0" />
        </Inedo.BuildMaster.Extensibility.Actions.SourceControl.GetLabeledAction>
      </Action>
      <Action ActionSequence="2" ServerId="1" RetryCount="0" Active="Y" ResumeNextOnFailure="N" LogFailureAsWarning="N" Name="Set File Attributes" Description="Clear read-only flag on files matching * in (default).">
        <Inedo.BuildMaster.Extensibility.Actions.Files.SetFileAttributesAction Assembly="BuildMasterExtensions">
          <Properties FileMasks="*" Recursive="True" ReadOnlyState="False" OverriddenSourceDirectory="" Timeout="0" />
        </Inedo.BuildMaster.Extensibility.Actions.Files.SetFileAttributesAction>
      </Action>
    </Actions>
  </ActionGroup>
  <ActionGroup DeploymentPlanActionGroupId="3293" DeploymentPlanActionGroupSequence="2" ActionGroupId="3288" Active="Y" Shared="N" Parallel="N" IterateServers="N" IterateDeployables="N" OnFailureContinue="N">
    <Name>Copy the Source as a reference</Name>
    <Description>So we can record the source used for the build.  Note we do not build the source - we deploy from the artifact</Description>
    <Actions>
      <Action ActionSequence="1" ServerId="1" RetryCount="0" Active="Y" ResumeNextOnFailure="N" LogFailureAsWarning="N" Name="Synchronize Directory Contents" Description="of $BuildSrcDir\$EnvironmentName\$ApplicationName\ with files and directories from $CurrentDirectory" TargetServerId="1">
        <Inedo.BuildMaster.Extensibility.Actions.Files.TransferFilesAction Assembly="BuildMasterExtensions">
          <Properties SourceDirectory="" TargetDirectory="$BuildSrcDir\$EnvironmentName\$ApplicationName\" DeleteTarget="True" IncludeFileMasks="*" Timeout="0" />
        </Inedo.BuildMaster.Extensibility.Actions.Files.TransferFilesAction>
      </Action>
    </Actions>
  </ActionGroup>
  <ActionGroup DeploymentPlanActionGroupId="3294" DeploymentPlanActionGroupSequence="3" ActionGroupId="3289" Active="Y" Shared="N" Parallel="N" IterateServers="N" IterateDeployables="N" OnFailureContinue="N">
    <Name>Deploy App</Name>
    <Description>Deploy the artifacts created in the build actions, and then any configuration files needed.</Description>
    <Actions>
      <Action ActionSequence="1" ServerId="1" RetryCount="0" Active="Y" ResumeNextOnFailure="N" LogFailureAsWarning="N" Name="Deploy $ApplicationName Artifact" Description="to $BuildDropDir\$EnvironmentName\$ApplicationName\">
        <Inedo.BuildMaster.Extensibility.Actions.Artifacts.DeployArtifactAction Assembly="BuildMasterExtensions">
          <Properties ArtifactName="$ApplicationName" DeployAsZipFile="False" DoNotClearTargetDirectory="False" LogIndividualFiles="False" OverriddenTargetDirectory="$BuildDropDir\$EnvironmentName\$ApplicationName\" Timeout="0" />
        </Inedo.BuildMaster.Extensibility.Actions.Artifacts.DeployArtifactAction>
      </Action>
    </Actions>
  </ActionGroup>
</DeploymentPlan>

What is the Issue?

Product: BuildMaster
Version: 4.3.6

1
replies

Hi,
Hope you can help me.
Can I configure MSTest action to run all tests from a .testsettings file instead of particular test dll?
Also, how can I email the test results?
Thanks,
ODP

Product: BuildMaster
Version: 4.3.7

3
replies

Hi,

I'm trying to push to ProGet (running on IIS). However, when I push to my repository using Admin:Admin (I will change this soon) I get the error. I have followed the instructions in the documentation.

F:\TFSOnline\PaginationHelpers\bin\Debug
>nuget push PaginationHelpers.1.0.1.nupkg -ApiKey Admin:Admin -s http://pro
get.zibrant.com/nuget/Zibrant
Pushing PaginationHelpers 1.0.1 to 'http://proget.zibrant.com/nuget/Zibrant'...
Failed to process request. 'There was an error processing the request: Invalid A
PI key.'.
The remote server returned an error: (403) Forbidden..

Does anyone know what I'm doing wrong?

Matt

Product: ProGet
Version: 3.1.0

1
replies

Dear support,

Within our organization we use a release schema of YYWW, for example 1403, 1404, etc.
This is related to the sprints we have every 2 weeks.
So, at this moment we have the release 1412 in production.

Last monday, we started the new sprint, named 1413.
The deployment consists of 3 different applications.
All was working well, up to now.

One of the applications was craching so an emerency fix was needed.
In stead of having an emercency deployment plan, the release was cancelled.
The new releasenumber was set to ... "141201".
The intention was to identify the first "01" sub-release of "1412".

Of course this worked, but now we have the problems generating the new releases.

For this specific application, the release "1413" can not be un-cancelled, because of the newer release.

Can you give us a hint to regenerate our scheme and reactivate "1413".

Kind regards
Martin van Berkel

Product: BuildMaster
Version: 3.6.5

4
replies

In trying to set up the subversion source control extension, I came upon the following error when I clicked Test Connection:

An unexpected error occurred while attempting to connect. Assembly Subversion was not found. The extension may be out of date, have been deleted, or could not be loaded.
Parameter name: assemblyName

I am running BuildMaster on the server that our repository is on; BuildMaster seems to be able to find the repo easily, but can't find subversion itself to connect to. Any ideas as to what could be going on?

Product: BuildMaster
Version: 4.3.7

1
replies

Hi Guys,
we have Proget run in a VM on a Microsoft Hyper-V Server, we get no machine UID displayed.
You have any idea how we get the processor's serial number in the VM to Proget?

Product: ProGet
Version: 3.1.0

Ask A Question
Page: 1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666870717273747576777879808182838485868788899091929394