Support Q & A Home

Ask A Question

Anyone can ask or answer a question here, but our support engineers actively monitor your questions; we typically answer within a day or two.

Filter
Viewing Page 73 of 89 (20 questions out of 1767)
1
replies

Is there a way to terminate an arbitrary executable as part of a deployment step? Our product will kick off long-running executables in the background. If we deploy while those are still running, the deploy will fail; however, these are not typical IIS or Windows Service processes. Is there a way to terminate arbitrary processes, or a way to wait until those processes finish execution? Right now we only see one option: manually ensuring those executables are not running on the target deployment machine.

1
replies

Hello,

The latest version of a package not showing in proget.

I restarted the service it just in case it is an indexing error, and I also reset IIS. I also set the Rebuild to true. It's having problems opening the zip. These are nuget packages I'm creating from buildmaster. The settings hasn’t changed. Also I can’t seem to make it re-read these files. This is the error:

Can not access a closed Stream:
System.IO.Compression.DeflateStream.Flush()
at MS.Internal.IO.Packaging.CompressStream.Flush()
at MS.Internal.IO.Packaging.CompressStream.Dispose(Boolean disposing)
at System.IO.Stream.Close()
at MS.Internal.IO.Zip.ZipIOLocalFileBlock.Dispose(Boolean disposing)
at MS.Internal.IO.Zip.ZipIOLocalFileBlock.Dispose()
at MS.Internal.IO.Zip.ZipIOBlockManager.Dispose(Boolean disposing)
at MS.Internal.IO.Zip.ZipIOBlockManager.Dispose()
at MS.Internal.IO.Zip.ZipArchive.Dispose(Boolean disposing)
at System.IO.Packaging.ZipPackage.Dispose(Boolean disposing)
at System.IO.Packaging.Package.System.IDisposable.Dispose()
at Inedo.ProGet.Service.IndexedFeed.UpdatePackage(PackageStorePackage storePackage)
at Inedo.ProGet.Service.IndexedFeed.<>c__DisplayClassa.<RebuildIndex>b__7(PackageStorePackage storePackage)

From what I can tell it looks fine. I was able to unzip it. That would leave me to believe that somehow they are locked and proget can’t open them .I’ve searched for open handles, but I don’t see any of them open.

5
replies

Hi

I am running proget Version 2.2.7 (Build 3) on a Windows 2012 server hosted on IIS with my own instance of MSSQL Enterprise.

I cannot delete packages from a feed using the nuget exe.

When I run >>nuget delete package_id version -Source http://proget/nuget/feed_name It returns a 404 error.

When I run >>nuget delete package_id version -Source http://proget/feeds/feed_name It claims to succeed for any package_id or version I enter but nothing happens on the server.

Regards,
Calvin

2
replies

Error getting SCM state for schedule #3: System.AggregateException: One or more errors occurred. ---> System.InvalidOperationException: Failed to receive response: The connection with the server was terminated abnormally
at Inedo.BuildMasterExtensions.Git.Clients.LilGitClient.UpdateLocalRepo(IGitRepository repo, String branch, String tag)
at Inedo.BuildMasterExtensions.Git.GitSourceControlProviderCommon.GetCurrentRevision(String path)
at Inedo.BuildMaster.Windows.ServiceApplication.ScmTriggerExecuter.GetScmState(BuildSchedules_Extended schedule)
at System.Threading.Tasks.Task1.InvokeFuture(Object futureAsObj) at System.Threading.Tasks.Task.Execute() --- End of inner exception stack trace --- at System.Threading.Tasks.Task.Wait(Int32 millisecondsTimeout, CancellationToken cancellationToken) at Inedo.BuildMaster.Windows.ServiceApplication.ScmTriggerExecuter.GetCurrentState(BuildSchedules_Extended build, Providers provider) at Inedo.BuildMaster.Windows.ServiceApplication.ScmTriggerExecuter.RunTriggeredBuild(BuildSchedules_Extended build, Providers provider) ---> (Inner Exception #0) System.InvalidOperationException: Failed to receive response: The connection with the server was terminated abnormally at Inedo.BuildMasterExtensions.Git.Clients.LilGitClient.UpdateLocalRepo(IGitRepository repo, String branch, String tag) at Inedo.BuildMasterExtensions.Git.GitSourceControlProviderCommon.GetCurrentRevision(String path) at Inedo.BuildMaster.Windows.ServiceApplication.ScmTriggerExecuter.GetScmState(BuildSchedules_Extended schedule) at System.Threading.Tasks.Task1.InvokeFuture(Object futureAsObj)
at System.Threading.Tasks.Task.Execute()<---

8
replies

The log output for the failed action:

Action Group 23: Build MyApp webapp
Action 1: Build MyApp.Web.Mvc.csproj Target:Package Properties:(none)
Custom Variables: (none)
Source and Target directory same; splitting.
AgentBasedAction Initialization Complete:
  Temp Directory: C:\BuildMaster\_SVCTMP\_A3\_S4\TMP
  Source Directory: C:\BuildMaster\_SVCTMP\_A3\_S4\SRC
  Target Directory: C:\BuildMaster\_SVCTMP\_A3\_S4\WRK
  Server: SNYDEVEL (Id: 1)
Initializing action...
Initialization complete. Executing...
Arguments: "C:\Windows\Microsoft.NET\Framework64\v4.0.30319\msbuild.exe" "C:\BuildMaster\_SVCTMP\_A3\_S4\SRC\Solutions\MyApp.Web.Mvc\MyApp.Web.Mvc.csproj" "/t:Package" "/p:outDir=C:\BuildMaster\_SVCTMP\_A3\_S4\WRK\"
Working Directory: C:\BuildMaster\_SVCTMP\_A3\_S4\SRC
Executing C:\BuildMaster\_SVCTMP\ExtTemp\WindowsSdk\BmBuildLogger.exe
Building Project "MyApp.Web.Mvc.csproj" (Package target(s)):
C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Microsoft.Common.targets(276,5): error MSB4184: The expression "[System.IO.Path]::Combine(C:\BuildMaster\_SVCTMP\_A3\_S4\SRC\Solutions\MyApp.Web.Mvc, C:\BuildMaster\_SVCTMP\_A3\_S4\WRK"\)" cannot be evaluated. Illegal characters in path.
Done building project "MyApp.Web.Mvc.csproj" -- FAILED.
MSBuild action failed; msbuild.exe returned code 1
Execution complete. Finalizing...
Target directory unused; joining with source.
Finalization complete.
1
replies

Hi,

I am running proget Version 2.2.7 (Build 3) on a Windows 2012 server hosted on IIS with my own instance of MSSQL Enterprise.

When I do an API call to delete a package from a feed I see the package remains on the file system. I can no longer find the package on the website or the database however the problem arises when I call to the API again for all available packages on that feed and the package magically re-appears.

I think if the API was deleting the package from the file system as well as the DB I wouldn't be experiencing this issue.

Regards,
Calvin

6
replies

Proget 2.2.7 Build 3 has a recurring problem with files that are being used by another process.
see error:

Package Indexing Error
Feed	Staging
Package	ifmviewer.core.1.0.0.nupkg

Message	The process cannot access the file 'd:\ProGet\Packages\Staging\ifmviewer.core.1.0.0.nupkg' because it is being used by another process.
Date	10-12-2013 16:37:46

Stack Trace	 at 
System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, String msgPath, Boolean bFromProxy)
at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)
at Inedo.NuGet.Packages.NuGetPackage.ReadFromNupkgFile(String fileName)
at Inedo.ProGet.Extensibility.PackageStores.DirectoryPackageStore.TryReadPackage(String fileName)

Proget is installed on it own dedicated server.

4
replies

Is there a way to open the Powershell 2.0 version after doing the BuildMaster 4.0 upgrade which now uses the .net 4.0 runtime. I am trying to execute scripts against SharePoint 2010 which still uses the old runtime version.

1
replies

I am having problems compiling a vs2010 project.

It is a large project with some legacy components that have been installed on the server. When I run the Build action 'solution from default directory to the \bin{config} subdirectory of each project in the solution' I get the following message:

licenses.licx(1,0): error LC0004: Exception occurred creating type 'Syncfusion.Core.Licensing.LicensedComponent, Syncfusion.Core, Version=5.202.0.25, Culture=neutral, PublicKeyToken=632609b4d040f6b4' System.InvalidOperationException: Showing a modal dialog box or form when the application is not running in UserInteractive mode is not a valid operation. Specify the ServiceNotification or DefaultDesktopOnly style to display a notification from a service application.

Although it appears the component in question is trying to invoke some license screen, I am fairly certain this is a Build Master issue. For if I cut and paste the MsBuild command that is output in the log (Framework64\v4.0.30319\msbuild.exe" "...\wrk\MySolution.sln" "/p:Configuration=Debug") running it against the wrk directory, I can compile it cleanly- as there is a license file in the Project as an embedded resource directory. (I can also open the project in visual studio and compile.)

So it seems that Buildmaster is not using that license file but doing something else.

I have tried a number of things such as:

  • using the add 'Add Licenses' action with both the name of the component (Syncfusion.Core.Licensing.LicensedComponent) and the full assembly identity (Syncfusion.Core.Licensing.LicensedComponent, Syncfusion.Core, Version=5.202.0.25, Culture=neutral, PublicKeyToken=632609b4d040f6b4')

  • not using the 'Add Licenses' action - which still gives me the above InvalidOperationException error.

  • I have tried deleting the original license file before the Add Licenses action - which causes MsBuild to raise "Could not find file message '..SRC\Momentus.WindowsApp\licenses.licx"

So given that from the command list msbuild compiles the solution without exception, what is causing the issue?

Is there a way to see the contents of the SRC directory when the build fails - it seems to be removed?

1
replies

We are experiencing problems with the Web package Search. Certain packages that we verify as being included in the package repository does not appear in the search.

Is there a way of rebuilding the indexes or change in configuration to redo the list of packages such that the search will pickup these missing packages?

1
replies

I am testing ProGet free on windows 8 with SQL.

I downloaded Proget from http://cdn.inedo.com/downloads/proget/ProGetSetup2.2.6.exe

Installation went fine:

  • I was managed to obtain license
  • I can see new database created in ms sql 2012
  • website is created in iis
  • apppool is created, and it has .net 40 integrated mode
    website is accessible - I created simple .txt file and it opens fine.

When i open root i see blank page
when i try to publish with nuget Ii recieve 404
windows event log doesn't have any errors.

4
replies

I'm getting the following error when trying to browse the feed:

An unexpected error has occurred: Unable to cast object of type 'System.Func2[Inedo.ProGet.Packages.LocalPackageSource+LocalPackage,System.Boolean]' to type 'System.Func2[Inedo.ProGet.Packages.ProGetFeedPackage,System.Boolean]'.

I'm using IIS hosted ProGet 2.2.6 (build 8).

Freshly installed. It was working, I pulled a few packages from the public NuGet server, then it stopped working.

1
replies

Since upgrading from BuildMaster 3.6 to 4.0.7, I can't find the auto-incrementing release number option any more. I've searched high and low, especially on the application options page where the documentation ( http://inedo.com/support/documentation/buildmaster/core-concepts/releases ) still says the option can be found.

So has it been removed, or is it just in a different place now?

3
replies

On Buildmaster 4.0.7 build 19 with authentication by Active Directory.

We currently have to update the Buildmaster database by direct SQL to use a variable as the "responsible principle" of a Manual Action.

Do you know when Buildmaster will support this without the SQL workaround ?

Thanks
Dave

1
replies

Using the latest version I have configured the source control as Perorce.

I create a new application using the standard application and successfully complete the steps. But when I run it I get the following mesage:

Action 1: Get Latest from depot/TemporaryTestProject/BuildTests/TestWinApp to default directory.Custom Variables: (none)Source and Target directory same; splitting.AgentBasedAction Initialization Complete: Temp Directory: D:\BuildMaster_SVCTMP_A3_S4\TMP Source Directory: D:\BuildMaster_SVCTMP_A3_S4\SRC Target Directory: D:\BuildMaster_SVCTMP_A3_S4\WRK Server: DUB6WSD56001 (Id: 1)Initializing action...Initialization complete. Executing...Executing Get Latest CommandExecuting C:\Program Files (x86)\Perforce\p4.exe
Arguments: -G -c "Dubmomttpro" -p "Dubmomttpro:1666" -u "Dub.Momentus" "sync" "//depot/TemporaryTestProject/BuildTests/TestWinApp/..."
Parsing 147 bytes of data.
An unhandled exception occurred while executing this action: System.InvalidCastException: Unable to cast object of type 'Inedo.BuildMaster.Extensibility.Agents.Local.LocalAgent' to type 'Inedo.BuildMaster.Extensibility.Agents.IFileOperationsExecuter'.
at Inedo.BuildMasterExtensions.Perforce.PerforceProvider.GetLatest(String sourcePath, String targetPath)
at Inedo.BuildMaster.Extensibility.Actions.ActionBase.ExecuteInternal(IActionExecutionContext context, ExtensionConfigurerBase extensionConfigurer, Boolean resumeNextOnError, Boolean logErrorsAsWarnings)

1
replies

I create a Tutorial Application, such as Calculator or whiskey menu and I immediately get 500 Internal server error.

The same happens when I use the create new .Net application wizard. I get the same message after selecting the provider file.

I cannot see any message in the log

1
replies

Using Buildmaster 4.0.7 build 19.

I have declared a Promotion variable for the first environment and set it as "value is required".

But when you next access the variable the "set only on initial promotion" is no longer checked. If you check this and try to save you get an SQL error.

And when you promote the build to the first environment you never get an opportunity to set the variable value.

Can you please investigate this issue.

Thanks
Dave

1
replies

We are using Buildmaster 4.0.7 build 19.

We had a failed build which we wanting to re-execute from the last failed action. But clicking this button caused the build to re-execute from the start.

Do you know why this failed ?

Thanks
Dave

3
replies

I upgraded our server from 4.0.6 to 4.0.7 and then my problems started. I got the 'value cannot be null Parameter name activation code' similar to the previous poster. I could not get to the license page http://buildmaster-server/administration/licensing - I tried all sorts of permutations. (I also did not see any warning about license activation - in fact I thought I had activated it.)

So I thought I would try to uninstall and re-install the product.

Except I cannot uninstall it - the program is still registered in control panel. It seems to me that to get part way through and raises a silent exception. I have even ticked the database removal (I installed the sql express version) - but it is still there. The extensions and artefacts have gone.

The problem I cannot re-install - I get a message that Buildmaster is already installed. So now I am stuck I cannot uninstall or install.

How can I get passed the product is already installed message?

8
replies

I'm getting this error message after logging in:
Value cannot be null.
Parameter name: activationCode

I recently upgraded from v4.0.6 to 4.0.7, and this message was the only response to my login attempt. I tried uninstalling and reinstalling (leaving the database in place) but I'm still getting the same error. Is it possible something went wrong during some database schema change?

Ask A Question
Page: 123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707173757677787980818283848586878889