Support Q & A Home

Ask A Question

Anyone can ask or answer a question here, but our support engineers actively monitor your questions; we typically answer within a day or two.

Filter
Viewing Page 87 of 95 (20 questions out of 1887)
2
replies

We have installed the Jenkins extension but the Buildmaster extensions page always says Jenkins is v0.0.0.0 and should be upgraded. Other than that the Jenkins integration seems to work.

Here is the text from the Buildmaster Extensions page:
Jenkins (v0.0.0.0)
Contains actions to get artifacts and trigger builds in Jenkins. Update Available (v3.0)

2
replies

I am wanting to use the subversion Get Latest action to check out files on a Solaris target which has been setup as a Linux SSH Agent.

The Get Latest fails with the following exception:

Action 1: Get Latest from CusmodServer/scripts/trunk to /appl/cusdev/scripts
Preparing remote servers for execution...
Preparing DEV_dwdcs-cmas01_cusdev for execution...
Preparing SYBDEV_dwdcs-cmas01 for execution...
Preparing DEV_dwdcs-cmas01_cusbld for execution...
Preparation complete.
Initializing action...
An unhandled exception occurred while executing this action: System.InvalidOperationException: Action is not supported on this type of agent (requires IPersistedObjectExecuter) at Inedo.BuildMaster.Windows.ServiceApplication.SlimPlanActionExecuter.RemoteAction_InitializeRemoteConfiguration(Object sender, RemoteConfigurationEventArgs e) at System.EventHandler`1.Invoke(Object sender, TEventArgs e) at Inedo.BuildMaster.Extensibility.Actions.RemoteActionBase.OnInitializeRemoteConfiguration(RemoteConfigurationEventArgs e) at Inedo.BuildMaster.Extensibility.Actions.RemoteActionBase.OnBeforeExecute(EventArgs e) at Inedo.BuildMaster.Extensibility.Actions.ActionBase.Execute(IActionCancellationToken cancellationToken, ExecutionContext context, ExtensionConfigurerBase extensionConfigurer, Boolean resumeNextOnError, Boolean logErrorsAsWarnings)

11
replies

We are trying to use the Transfer File action copy files from one unix machine to another (both are setup as Agents Buildmaster can login).

But when we run the action it always fails with the error: source file does not exist - even if you select the folder using the Browse option.

Does the Transfer File option work with unix machines or should we be doing this some other way ?

2
replies

Hi, We are using the linux SSH-Agent (3.10.01) to execute a shell script on a linux target and Buildmaster (3.5.10 build 6) always thinks the step is successful regardless of the return code. I have tried sh, ksh and bash scripts but cannot get Buildmaster to register a failure.

Do you have any suggestions on what I am doing wrong ?. Thanks.

2
replies

I'm trying to use the SVN source control provider with an SSH agent, but I get this error: "AgentId is invalid or did not return an IPersistedObjectExecuter"

Any suggestions?

3
replies

Does BuildMaster support adhoc deployments to environments?

For our core environments we have a strict worklfow - dev, sit, uat, preprod, production, but we also have some other environments for a completely separate team who's system links to ours but have it installed in isolation to ours so not impacting on each other.

I would like to have their environments in our workflow but able to release to it at any time.

I had thought of creating additional workflows, for each adhoc environment but that means creating a new release for each additional workflow which doesn't really fit.

2
replies

The BuildMaster Service was not starting, probably after the lastest windows updates were applied. First discovered the problem with Jenkins and found this advice

https://issues.jenkins-ci.org/browse/JENKINS-15596

which worked so I also applied it to BuildMaster in bmservice.exe.config:
<runtime>
<generatePublisherEvidence enabled="false"/>
</runtime>

This also worked. Is this a known issue and is there a better work around / patch for it?

3
replies

Hi, getting an error on the setup wizard, after specifying our source control (and SVN instance), and then the path, and error like:

Exception Details: System.InvalidOperationException: svn: E155007: 'C:\WINDOWS\Temp\tmpBC6F.tmp' exists and is not a directory

Note the above is with the source control set to use the command line client. If not ticked, the error is similar but this:

Exception Details: SharpSvn.SvnInvalidNodeKindException: 'C:\WINDOWS\TEMP\tmpBC82.tmp' exists and is not a directory

Ie. same problem but from somewhere else.

Subversion is 1.7.8 and connection checked as Ok (indeed when setting up for this project, selector allows selection).

No idea how to fix this, and as such at a dead end. Thanks for any help or pointers.

1
replies

Hello,

I'm having issues running a Database change script from BuildMaster.

The steps to reproduce:

  1. Create a Database change script file with the following:
    SET @OLD_UNIQUE_CHECKS=@@UNIQUE_CHECKS, UNIQUE_CHECKS=0;

  2. Add it to BuildMaster

  3. Try to execute it on a MySQL database.

When I run the same command from the MySQL command line (as the same user) it goes through as expected:
mysql> SET @OLD_UNIQUE_CHECKS=@@UNIQUE_CHECKS, UNIQUE_CHECKS=0;
Query OK, 0 rows affected (0.00 sec)

The error message I'm getting from the BuildMaster is simply "Fatal error encountered during command execution" which does not give me any information to go on.

5
replies

We are trying to do manual installation of BuildMaster but the service (INEDOBMSVC) will not start when pointing to a manually installed database. We get the error "The BuildMaster Service (INEDOBMSVC) service on Local Computer started and then stoped. Some services stop...". The only error written to the event log is "Service cannot be started. The handle is invalid".

The very same service WILL start when pointing to an automatically installed database (by changing the connection string).

To manually install the database we have:

  1. Created a blank database in SQL Server 2008 SP1
    1a) Created the DB with SQL_Latin1_General_CP1_CI_AS collation
    1b) Created the DB using the same account under which the BM service runs under so that it is dbowner and has a default schema of dbo
  2. Run bmdupdate.exe
    2a) Selected option 3 to update the DB
    2b) Entered the connection string
    2c) Entered "yes"
    2d) Confirmed there were no errors
  3. Run OBJECTS-v3.5.10.6.sql against the database using SQL Server Management Studio in SQLCMD mode
    3a) Confirmed there were no errors

Is there anything else that has to be done for a correct database install?

1
replies

I recently upgraded to 3.5.10 and the time picker that was in the previous version is no longer there, was this removed on purpose or is something configured wrong in my new setup?

1
replies

I have 2 environments, UAT and Prod, that are not connected except both can see the source control server. I need BuildMaster in both environments with the same Applications. If I set up an Application in the UAT BuildMaster how do I copy it to the production environment?

2
replies

I am trying to install a proget instance against an existing database, but I can't get it to work. The installation guide indicates that if I put a database name in the connection string, the installer will not try to create a database. But when I run the installer, and use the connection string

Data Source=sqldbadev102.taltrade.com;Initial Catalog=stage_proget;Integrated Security=true

The installer attempts a "CREATE DATABASE",and fails because the account it is running as doesn't have database create rights. How do I make the installer use an existing database?

3
replies

I'm having trouble configuring up SMTP settings in BM free. I'm trying to use my Gmail account, and I've properly entered all the Gmail SMTP settings per this page (http://email.about.com/od/accessinggmail/f/Gmail_SMTP_Settings.htm). However, when I try to send a test email, BM spins for a while, and finally returns a "Timeout Error". I couldn't see anything in the BM logs related to this error.

I've tried using other SMTP servers (road runner, for instance), and none of them worked either. For a few settings, BM returned a "server does not support secure emails" or "failure to send email" error, but no further details.

I've looked at the Firewall settings on my server, and nothing seems to be blocking emails. I've also watched HTTP traffic through Fiddler while trying to send a test email, and that didn't trap anything obvious either.

What other steps can I try? Any thoughts as to what might be wrong? Thanks for your help.

Matthew

1
replies

One of our installations contains many pieces - website, web services, background apps, windows services, queuing mechanisms, desktop GUI apps, etc. Written in a number of different languages, and built as separate projects.

There are, of course, dependencies among them. Most work against a common database, and have a dependency on the table schema. The older VB desktop GUI apps (which we've not yet been able to eliminate) depend upon a COM object, written in C++.

I've been reading through your whitepapers, and everything seems simple and clear, there. Mainly because the examples are simple and clear.

How do you deal with more complex situations?

Does a build wrap a single project? Or can it wrap multiples? How does Buildmaster deal with dependencies between projects?

Does a release map to a single projects? Or can it contain multiples?

Would a complex environment of the sort I've described be organized as a single release? Or would the various parts be handled as separate releases?

Is there any mechanism for meta-releases? For a top-level release that contains multiple lower-level releases?

1
replies

Hi

We have a team in our organisation which requires the right to deploy, using BuildMaster, to our production environment. However, out of this team of five, only on person will ever be required to do this at any given time. Is it allowable, from a licensing perspective, to set up a BuildMaster account for any one of these five employees to use or do they all need their own account/license?

Thanks

Tim

1
replies

All the installers I can find for BuildMaster are for a Windows PC. Is it possible to install the server on Unix?

2
replies

I have two of my own internal feeds in ProGet. The first feed has a connector to the second. I cannot seem to download files from the second feed via the first feed. The package appears in the feed list, however, I get a 500 - Internal Server Error when trying to download.

I can download the file when using the second feed directly and I've gone through the admin and permission configurations for the feeds and users, but I'm uncertain what I'm missing.

I cannot download the file directly in ProGet via the download button if I've browsed to the package via the first feed. Same 500 error.

Currently my Anonymous (using this + API key for publishing/fetching) user has these permissions:

Feeds_AddPackage, Feeds_DownloadPackage, Feeds_OverwritePackage, Feeds_PullPackage, Feeds_ViewFeed

Currently, the file only exists in the second feed and the first feed is not caching files from the second. I have tried downloading the file with caching on and off.

I don't see much in the way of logs. There's some in IIS, but messages don't seem to indicate the problem.

I'm using the free edition of ProGet 2.0.4 on a 64-bit 2008 R2 with IIS. Maybe the free version is limited, but I thought Connectors (not the filters) were OK in this edition.

4
replies

I'm getting the following error after installing. Help?
(Installing enterprise trial w/ existing sql server db on IIS. win 2008 r2 sp1 - 64bit.
(Removed domain/user from below)

Event code: 3005
Event message: An unhandled exception has occurred.
Event time: 4/29/2013 8:47:05 AM
Event time (UTC): 4/29/2013 1:47:05 PM
Event ID: b1de36d61e644ba9b5165ca0d0237866
Event sequence: 4
Event occurrence: 3
Event detail code: 0

Application information:
Application domain: /LM/W3SVC/2/ROOT-1-130117165917405922
Trust level: Full
Application Virtual Path: /
Application Path: D:\BuildMaster\WebApp\
Machine name: FIT-BDMSTDEV-01

Process information:
Process ID: 3172
Process name: w3wp.exe
Account name: (domain)\app-account

Exception information:
Exception type: InvalidOperationException
Exception message: Handler has not been mapped to this request.

Request information:
Request URL: http://localhost/
Request path: /
User host address: ::1
User:
Is authenticated: False
Authentication Type:
Thread account name: (domain)\app-account

Thread information:
Thread ID: 9
Thread account name: (domain)\app-account
Is impersonating: False
Stack trace: at Inedo.BuildMaster.Web.WebApplication.BuildMasterHttpModule.PostMapRequestHandler(HttpApplication app)
at System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

Custom event details:

1
replies

Is there a way of changing the frequency BuildMaster polls source control providers?

Ask A Question
Page: 123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858789909192939495