Support Q & A Home

Ask A Question

Anyone can ask or answer a question here, but our support engineers actively monitor your questions; we typically answer within a day or two.

Filter
Viewing Page 13 of 97 (20 questions out of 1931)
3
replies

The SELECT permissions was denied on the object 'Configuration', database 'ProGet', schema 'dbo'.

Get the above error when attempting to upgrade from 4.0.8 to 4.7.1. Not sure what user needs what permissions or why those permissions aren't set in the first place (how did this get installed originally without the appropriate permissions?)

Product: ProGet
Version: 4.7.1

1
replies

Hi,

hi, just starting using the SVN provider and I have hit a problem that I can't seems to fix
I am getting this error message
→Arguments: export "C:\BuildMaster_SVCTMP\SrcRepos\svn.riouxsvn.com_fpp" "C:\BuildMaster_SVCTMP_E513_D0" "--force" --non-interactive --trust-server-cert --

If I try the same parameter from cmd line I get the same error. If I remove the trailer backslash the cmd works from cmd line. How do I remove the backslash in BM

I have the latest version of BM

Product: BuildMaster
Version: 5.6.8

1
replies

Running Linux proget 4.6.7, when attempting to configure replication from an external feed returns a 500 error, pasted below. I don't see this mentioned in any release notes so I haven't upgraded yet to find out if there's an existing fix.

When it comes to upgrading proget using the docker container, will a new container spinning up perform all necessary DB updates? In that case, should all other hosts be shut down prior to launching a new version of the container? I don't see any specific guidance on how to correctly perform an upgrade other than shutting down one container and spinning up another. Let me know if this should be a separate question, but I know I'll need to perform that to apply any fix.

Npgsql.PostgresException
42883: function Feeds_SetLastSyncDate(@Feed_Id => integer, @LastSync_Date => timestamp without time zone, session_user_name => text) does not exist

Description: HTTP 500.Error processing request.
Details: Non-web exception. Exception origin (name of application or object): mscorlib.
Exception stack trace:
  at Npgsql.NpgsqlConnector.DoReadMessage (Npgsql.DataRowLoadingMode dataRowLoadingMode, System.Boolean isPrependedMessage) [0x000bc] in <4985dea8374f4819bebb7847d95ad483>:0 
  at Npgsql.NpgsqlConnector.ReadMessageWithPrepended (Npgsql.DataRowLoadingMode dataRowLoadingMode) [0x00056] in <4985dea8374f4819bebb7847d95ad483>:0 
--- End of stack trace from previous location where exception was thrown ---
  at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw () [0x0000c] in <8f2c484307284b51944a1a13a14c0266>:0 
  at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess (System.Threading.Tasks.Task task) [0x0004e] in <8f2c484307284b51944a1a13a14c0266>:0 
  at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification (System.Threading.Tasks.Task task) [0x0002e] in <8f2c484307284b51944a1a13a14c0266>:0 
  at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd (System.Threading.Tasks.Task task) [0x0000b] in <8f2c484307284b51944a1a13a14c0266>:0 
  at System.Runtime.CompilerServices.TaskAwaiter.GetResult () [0x00000] in <8f2c484307284b51944a1a13a14c0266>:0 
  at System.Web.TaskAsyncResult.Wait (System.IAsyncResult result) [0x0003a] in <79d7580b4e46487286a5f8386a98413d>:0 
  at System.Web.HttpTaskAsyncHandler.System.Web.IHttpAsyncHandler.EndProcessRequest (System.IAsyncResult result) [0x00000] in <79d7580b4e46487286a5f8386a98413d>:0 
  at Inedo.Web.Handlers.AsyncHandlerWrapper.EndProcessRequest (System.IAsyncResult result) [0x00000] in <23fdb4c7144946fa87eea57c7dd622b3>:0 
  at System.Web.HttpApplication.async_handler_complete_cb (System.IAsyncResult ar) [0x0001e] in <79d7580b4e46487286a5f8386a98413d>:0 

Product: ProGet
Version: 4.6.7

9
replies

Hi,

I'm evaluating Otter and there seems to be an issue with the way variables are being evaluated when they are assigned at the Environment level. Say I have 3 environments:

  • Development
  • Testing
  • Production

If I assign a $TestValue variable to each environment with a different value for each one, then I expected that the variables would be evaluated based on which environment the server was in when I run a plan. This doesn't appear to be the case however because every time I execute a plan the value from the "Development" environment is used.

For example, if I set the following values for the $TestValue variable:

  • Development: DevelopTestValue
  • Testing: TestingTestValue
  • Production: ProductionTestValue

and I run a plan that logs the values, the output is always "DevelopTestValue" even if the server is in the Testing environment. Am I misinterpreting how variables work or is this some type of bug.

3
replies

Package variables defined in a release template are not populated when creating a package from 'Packages'->'Create Release Package' (localhost:82/applications/7/packages). This results in a "Could not resolve variable" error during plan execution. The variables do populate when going through the release overview and clicking 'Create Package' (localhost:82/applications/7/releases/release?releaseNumber=1.9.0).

Product: BuildMaster
Version: 5.6.8

2
replies

One of the more powerful improvements to the latest Buildmaster is the relationship between pipelines and deployment plans. It dramatically simplifies things here at TLG for code deployment orchestration.

I'm able to deploy webcode in a deployment plan and allow the pipeline configuration decide where it needs to go based on what environment stage I'm in.

I'm wondering if this also extends to configuration variables.

For example, my aforementioned scenario of webcode and pipeline stages might have the set of stages {dev,qa,staging,production}. An application using that pipeline could have a deployment file called example.config with the set of environments {dev,qa,staging,production} (the same as the pipeline).

Can I call a 'deploy config file' action and let the pipeline stage and associated environment pick the corresponding config file instance?

This feature would really bring the end-to-end deployment process full circle for our organization!

Product: BuildMaster
Version: 5.6.8

3
replies

Is there a way to have variable expansion inside of another variable? It would be nice to be able to build up variables using other variables that are fully evaluated during execution.

{
  "CommonPath": "\common\path",
  "SpecificPath1": "$CommonPath\specific\place\here",
  "SpecificPath2": "$CommonPath\another\place\there"
}

Log-Information $SpecificPath2;

INFO:  \common\path\another\place\there

Product: BuildMaster
Version: 5.6.8

0
replies

Hello,
we have a variable $token which we would like to be automatically pre-filled with the date in the following format: $Date(yyyyMMdd-hhmmss).
Is this possible at all?
Please advise,
// Francesco

Product: BuildMaster
Version: 4.9.7

5
replies

First question, is there a link to a overview of the Variable hierarchy?
I have a situation where I'd like to setup variables in a pipeline for a stage but also have those same variables available for setting at run time so I put them in a release template.
However at run time I can fill in the variable but then it is not used during execution, instead the one in the pipeline is being used.

Second question, I am also trying to possibly handle a situation where I will be reading in some values from a database which then determines the values for a loop. However, we also want to allow for the thing to be run manually with the person entering one value.
So I was trying to use multiple variables and create a List in script but in my testing I can't seem to create a list.

Here is what I've tried:

set @custId = @ListInsert(@custId, $clientId,0);

but when run I just keep getting an error: Could not Resolve Variable @custId

Product: BuildMaster
Version: 5.6.7

1
replies

One of my packages seems to have lost some versions, but we have no retention policy set up.

Product: ProGet
Version: 4.7.1

1
replies

How to Configure the Microsoft BizTalk ESB Toolkit using powershell script

Product: BuildMaster
Version: 5.6.7

4
replies

I'm currently configuring Buildmaster applications to have a one-to-one deployment plan to pipeline stage configuration, but I'm interested in leveraging the fact that pipeline stages can reference servers.

How do deployment plans interact with pipeline stage servers? For example, if I want a deployment plan to deploy an artifact to a remote server -- how do I tell it to deploy to whatever server(s) are defined in the pipeline stage?

Thank you!

Product: BuildMaster
Version: 5.6.7

1
replies

We use the above action for things like attaching code coverage reports during a build. There is a corresponding otterscript operation, but the conversion process doesn't convert this legacy action to the operation.

Is this a known bug, and will it be fixed?

Product: BuildMaster
Version: 5.6.7

3
replies
  1. Create a Docker Swarm using the new “Docker Swarm Mode”, built in since Docker 1.12. Swarm should have at least two nodes: 1 manager and one worker.
  2. Upload a Docker image to ProGet.
  3. SSH into the manager node and login to ProGet using:
    docker login <proget host>
  4. SSH into the manager node of the Swarm and try to create a service using the following command, replacing portions that are wrapped in <>:
    docker service create –name <some service name> --replicas 1 --constraint 'node.hostname== <worker host name>' --with-registry-auth <image name>:<version>
  5. Check the status of the service via the command line using:
    docker service ps <service name>
    Services that have failed or been rejected will give an indication as to why. In this case, the message reads: Unable to find image…
  6. Check the ProGet logs, and you will see an error message stating:
    An error occurred in the web application: Value cannot be null. Parameter name: username
  7. Remove the test service using:
    docker service rm <service name>
  8. SSH into the worker node and pull the container image using:
    docker pull <image name>:<version>
  9. SSH into the manager node and try the create again, this time omitting the –with-registry-auth parameter.
  10. The service should be up and running correctly.

The details of the proget error are:

URL: https://repoman.kaneva.com/v1/repositories/kava-docker/library/config-service/images
Referrer: (not set)
User: (unknown)
User Agent: docker/1.13.0 go/go1.7.3 git-commit/49bf474 kernel/3.10.0-514.6.1.el7.x86_64 os/linux arch/amd64
Stack trace: at Inedo.ProGet.Extensibility.UserDirectories.BuiltInDirectory.TryGetAndValidateUser(String userName, String password)
at Inedo.ProGet.WebApplication.ProGetHttpModule.ValidateUser(HttpApplication app, String userName, String password)
at Inedo.Web.InedoHttpModule.AuthenticateRequestAsync(HttpApplication app)
at Inedo.Web.InedoHttpModule.ProcessBegin(Object sender, EventArgs e, AsyncCallback cb, Object extraData)
at System.Web.HttpApplication.AsyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

Product: ProGet
Version: 4.6.7

1
replies

Can multiple ProGet be installed with the integrated web server and placed behind a Windows Server 2016 NLB configuration?

I am aware of the "High Availability Mode" and "Load Balancing Mode" which require IIS, but I am wondering if the same can be achieved by placing standalone installations behind an NLB.

Related to the first question - what happens if you install multiple standalone nodes and point them to the same database on a clustered SQL environment?

Product: ProGet
Version: 4.6.7

2
replies

Hi,
I'm trying to automate the purge old packages from a docker repository using the upack api, but I'm having problems.

The documentation says:
DELETE or POST /upack/«feed-name»/delete/«group-name»/«package-name»/«package-version»

Where group and version are optional, however using this URL:
curl -X DELETE "http://<server>/upack/winecomdocker/delete/frontendcms_106/"

Is returning:
Expected URL of format [group]/[name]/[version]

Is there anything wrong on the documentation or the call ?

Thanks,
Francisco

Product: ProGet
Version: 4.6.7

2
replies

Hi Team,

I am new to proget NuGet feed, I have some doubts in free license editions, please find the queries below,

  1. is there any restrictions in the feed count(number of feeds)
  2. I hope there is no expiration for this free license

Regards,
Nagaraj

Product: ProGet
Version: 4.6.7

4
replies

In an effort to store our PowerShell code as Script assets instead of embedded script and using "PSEval". PSEval currently works in that it properly return data from PowerShell scripts (even can return lists). When I use PSCall, I am unable to figure out how to get the output. Here is a sample:

# Script asset
function Get-Data {
     $OutVar = "HELLO WORLD"
}


template Test-PowerShellOutput
{
# Otter script
PSCall Get-Data {
     OutVar => $OutData
}

Log-Debug $OutData;
}

I also would really like to be able to return a list or map using PSCall.

3
replies

Hi, i am trying to install ProGet silently with /ConfigureIIS, however it never actually installs as IIS. Whenever i check the debug logs it still says ConfigureIIS = False.

I'm following instructions from the silent installation page:
http://inedo.com/support/documentation/proget/installation/silent-installation

My full command is:
ProGetSetup.exe /S /Edition=LicenseKey /LicenseKey=x /InstallSqlExpress /ConfigureIIS

Is this parameter suppose to work?

Product: ProGet
Version: 4.6.7

4
replies

Hi

We're trying to push a windows image from docker 1.13.1 on windows to proget.
The error we receive is: error parsing HTTP 400 response body: invalid character 'B' looking for beginning of value: "Bad Request"

In docker log file we get
[13:15:45.769][WindowsDockerDaemon][Info ] time="2017-02-10T13:15:45.769251100+01:00" level=warning msg="failed to upload schema2 manifest: error parsing HTTP 400 response body: invalid character 'B' looking for beginning of value: "Bad Request""
[13:15:45.769][WindowsDockerDaemon][Info ] time="2017-02-10T13:15:45.769251100+01:00" level=error msg="Attempting next endpoint for push after error: error parsing HTTP 400 response body: invalid character 'B' looking for beginning of value: "Bad Request""

Which looks similar to this issue https://github.com/docker/docker/issues/27580
And that issue seems related to the Jfrog registry.

So our question is if it should be possible to push a windows docker image to proget?

Product: ProGet
Version: 4.6.7

Ask A Question
Page: 1234567891011131516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394959697