Support Q & A Home

Ask A Question

Anyone can ask or answer a question here, but our support engineers actively monitor your questions; we typically answer within a day or two.

Filter
Viewing Page 22 of 94 (20 questions out of 1879)
1
replies

Hello,

I am having difficulty to access proget page when changing connection string to connect to a remote SQL server we have.

When using " Data Source=MSR-TG-PKG01\ProGet; Initial Catalog=ProGet; Integrated Security=SSPI " , which is the default setting, I have no issues, the proget server works fine.

When I try "Server=[Server name];Database=[DB name];User ID=[Username];Password=[Password]"

I get following error : [SqlException (0x80131904): Cannot open database "tg_proget" requested by the login. The login failed.
Login failed for user 'sql_tg_proget'.]
Cannot open database "tg_proget" requested by the login. The login failed.
Login failed for user 'sql_tg_proget'.

The login works fine, I have tested it through SQL Server 2014 and can login to the database so the issue is not there.

I am suspecting either I'm missing a configuration within IIS or within Proget.

Thanks for your help!

Product: ProGet
Version: 4.3.1

1
replies

Hi,
I'm currently evaluating Otter for handling our Configuration Management. We are using Desired State Configuration but I cannot seem to get it to work. I have a set up a simple demo system with 3 roles, 1 server (localhost). Here's the minimum I have to do to reproduce the error. I created a plan for one of the roles with:

##AH:UseTextMode
PSDsc File
(
    Otter_ConfigurationKey: DestinationPath,
    DestinationPath: C:\Windows\,
    Contents: test file ensured
);

This quickly produces an error message:
ERROR: The term 'Invoke-DscResource' is not recognized as the name of a cmdlet, function, script file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try again.

Am I missing some pre-requisite on my system or am I missing something obvious?

Regards,Hans

1
replies

Hi,

I was just wondering if Buildmaster can manage *.ini config files (that aren't XML) in the same manner as a standard XML formatted *.config file?

For example, the config file is already in key /value pairs:

[Application Settings]
environment=Production
path=\\server\share

etc...

and i want to modify those values for each environment with different instances.

Thanks,

Clint

Product: BuildMaster
Version: 5.3.7

1
replies

I want to create a connector to another proget server. Does the url contain the feeds, some api path, etc? I tried this and no luck:
http://myprogetserver:8080/feeds/myfeed

Product: ProGet
Version: 4.0.8

1
replies

I'm trying to create a Universal Package from Jenkins. When I run the build step, I get the following error:

D:\Jenkins\Acquisition\EOI\EOI_Sep16>exit 0
[ProGet] Packaging Artifacts
ERROR: Build step failed with exception
D:\Jenkins\Acquisition\EOI\EOI_Sep16 does not exist.
at org.apache.tools.ant.types.AbstractFileSet.getDirectoryScanner(AbstractFileSet.java:483)
at org.apache.tools.ant.types.AbstractFileSet.getDirectoryScanner(AbstractFileSet.java:460)
at com.inedo.proget.api.ProGetPackager.getFileList(ProGetPackager.java:208)
at com.inedo.proget.jenkins.UploadPackageBuilder.perform(UploadPackageBuilder.java:174)
at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:20)
at hudson.model.AbstractBuild$AbstractBuildExecution.perform(AbstractBuild.java:785)
at hudson.model.Build$BuildExecution.build(Build.java:205)
at hudson.model.Build$BuildExecution.doRun(Build.java:162)
at hudson.model.AbstractBuild$AbstractBuildExecution.run(AbstractBuild.java:537)
at hudson.model.Run.execute(Run.java:1741)
at hudson.model.FreeStyleBuild.run(FreeStyleBuild.java:43)
at hudson.model.ResourceController.execute(ResourceController.java:98)
at hudson.model.Executor.run(Executor.java:408)
Build step 'ProGet Package Upload' marked build as failuretext

But I know that the content is present:

D:\Jenkins\Acquisition\EOI\EOI_Sep16>dir d:\Jenkins\Acquisition\EOI\EOI_Sep16
Volume in drive D is JENWK0D1VND01_D
Volume Serial Number is ACAD-1029

Directory of d:\Jenkins\Acquisition\EOI\EOI_Sep16

09/01/2016 04:29 PM <DIR> .
09/01/2016 04:29 PM <DIR> ..
09/01/2016 04:28 PM 22,787 AllProjects_SONAR.sln
09/01/2016 04:28 PM 256 AllProjects_SONAR.vssscc
09/01/2016 04:28 PM <DIR> Application
09/01/2016 04:29 PM <DIR> Assemblies
09/01/2016 04:29 PM <DIR> Database
09/01/2016 04:29 PM <DIR> Deployment
09/01/2016 04:29 PM <DIR> ExternalDependencies
09/01/2016 04:29 PM <DIR> InstallPackages
09/01/2016 04:29 PM <DIR> Scripts
09/01/2016 04:29 PM <DIR> Tests
09/01/2016 04:29 PM <DIR> Web
2 File(s) 23,043 bytes
11 Dir(s) 17,781,252,096 bytes free

Any ideas what is wrong? Jenkins and ProGet are running on a Windows Server 2012 server.

Product: ProGet
Version: 4.3.1

1
replies

I've recently installed proget

I am using the Integrated Web Server. How do I set it up to use SSL?

Product: ProGet
Version: 4.3.1

1
replies

I found out that tagging for Subversion is not working with OtterScript plans but it works just fine with the legacy plans.

Apparently there is no Apply-Tag operation and the Apply-Label only gives this error:
ERROR: The Subversion provider does not support labeling/tagging. Consider using the "Apply-Label" operation instead. For more information, consult the documentation on Source Control Integration.

Unfortunately I couldn't find anything useful in the documentation.

However, when I was toying around with the converted legacy plan I noticed that there is Execute-LegacyAction operation but it would be nice to have a proper support for it.

Product: BuildMaster
Version: 5.3.6

1
replies

Hi,

I've recently installed latest version of ProGet, I've set it up to use an existing local SQL instance (the plan is to have a remote instance, but still in testing phase), and integrated it to IIS (ASP, .Net, etc are all installed).

so I've kept the default local host connection string.

When attempting to launch proget (or selecting to browse to it from IIS) I simply get a blank page. No errors are given.

What am I doing wrong or what am I missing?

Thank you!

Product: ProGet
Version: 4.3.1

5
replies

When trying to use Ensure-AppPool and using variables for the properties.
The problem I'm having is that the Ensure-AppPool has some properties that are required to be certain types, TimeSpan, Int, etc. so when I try to use it, it fails.
I could not find any documentation about declaring variable types in Otterscript, is there some way to do this? If so can I also do it in the Template area where you can set the Required parameters?

Thanks

Product: BuildMaster
Version: 5.3.6

3
replies

Hi

We are using nuget feed

https://api.nuget.org/v3/index.json

When I setup a connector to point to this url then I get the the error:

"There was an error with a connector:
Data at the root level,is invalid. Line1 position 1"

the error is displayed when I am trying to access the feed that is using the connector with
url as

https://api.nuget.org/v3/index.json

IS this url supported by ProGet?

Thanks

Regards

Alberto

Product: ProGet
Version: 4.3.1

2
replies

When I browse a feed page ( e.g. http://localhost:12345/feeds/MyFeed ), displayed packages are not sorted, or might be sorted in order of timestamp when they pushed.

I prefer to sorting packages in alphabetical order. Is there any option or something to achieve this?

Environment : Windows10. IIS for ProGet web server.

Thanks in advance.

Product: ProGet
Version: 4.3.1

1
replies

When a release is created, user needs to select a value from a list, say it's a list of files, which is dynamic depending on the folder.

I tried to create a txt file which contains the list of files that it needs, and set it to the list variable using $FileContents. It doesn't seem to populate the list with the file content.

How to dynamically populate the list variable from release template?

Product: BuildMaster
Version: 5.3.6

4
replies

Referring to the original question http://inedo.com/support/questions/5187, the answer accepted there is to use template. Template works, but it may not be ideal for all cases:

  1. Assume pipeline 1 has a stage X which has many plans. Same stage in a pipeline 2, also has these plans, but needs to execute in different sequence. And yet other pipelines 3, 4, 5, etc., with same plans but different sequence. If using templates, it might lead to many similar templates (like creating template X1, X2, X3, etc.).

Also in the pipeline we can't directly see what's inside the template, compared to plans directly in the pipeline where we'll be able to see.

  1. In the pipeline and stage, we can configure server for each plan, which is quite nice for reuse. It seems we are not able to configure that if within a template.

Template is good, but creating concrete templates may be too much work for only the sequence, especially when the combination of different sequences increases.

It may be good to introduce some sort of sequence wrapper (anonymous template?) in the pipeline stage. Or more granularly and do away wrappers/templates, If we can specify the execution sequence number directly on the plan, then it can execute the plans sequentially according to the number; for the same number, plans will be executed concurrently.

Something nice to have for your consideration.

Product: BuildMaster
Version: 5.3.6

1
replies

How can I get the full execution log from BuildMaster? I found this (http://inedo.com/support/tutorials/get-a-complete-build-log-by-build-number-through-the-json-api) tutorial but it doesn't work. The 'api/json/Builds_GetExecutionLog' gives 404 error.

Product: BuildMaster
Version: 5.3.6

1
replies

My buildmaster service user has local admin rights. I try to use powershell to terminate another user's process as part of the pipeline.

However, to kill another user's process in powershell, it needs to run as Administrator, but powershell executed by buildmaster is not in privileged running mode.

Is there a way to promote the powershell to be in administrator mode, or is there another way to kill off another user's process?

Product: BuildMaster
Version: 5.3.6

6
replies

So far the other projects I've been building with 5.x have not had extra properties being set so they have been building fine.
Now I've converted another project to 5 and the MSBuild action, using the new one, fails with this strange error. This project has several properties that are passed in.
Nothing in this project has changed and none of the properties have changed, the only change is converting to BM 5.

Here is the piece of Otter Script, note all the variables shown have the correct values:

Code

with timeout = 240
    {
        Build-Project $WorkingDirectory\Sci\Framework\Service\Sm\Scheduling\Api\SchedulingServer\Sci.Framework.Service.Sm.Scheduling.Api.SchedulingServer.csproj
        (
            Configuration: Release,
            Platform: AnyCPU,
            MSBuildProperties: DeployOnBuild=true;PublishProfile=$RelPublishProfile;VisualStudioVersion=11.0;WORKSPACE=$WorkingDirectory,
            Arguments: /m:$BUILD_PROCESSES /nologo /t:rebuild
        );
    }

and here is the Error info:

Error: C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Microsoft.Common.targets(340,29): error MSB4115: The "HasTrailingSlash" function only accepts a scalar value, but its argument "$(IntermediateOutputPath)" evaluates to "obj\Release;Platform=AnyCPU;DeployOnBuild=true;PublishProfile=Build_Deploy_Release;VisualStudioVersion=11.0;WORKSPACE=D:\InedoAgent\BuildMaster\Temp_E2046_D1016" /m:16 /nologo /t:rebuild" which is not a scalar value.

I tried changing all the properties to be /p: without the semicolons but that failed the exact same way. Something about the way it's combining all the info and passing to MSBuild doesn't seem to be working correctly.

Product: BuildMaster
Version: 5.3.6

6
replies

My NuGet proxy feed was appearing empty so I tried to update the proxy settings of the server.

Now the server is not reachable at all. Is there a way to restore the proxy setting without the web interface?

Thanks!

Product: ProGet
Version: 4.3.1

6
replies

When I add multiple plans to a pipeline stage, they execute concurrently. Is this the intended behavior, and are there any plans to allow for setting an execution order?

I'm using global plans and global pipelines.

Product: BuildMaster
Version: 5.3.3

4
replies

Trying to setup symbols to be able to debug nuget package as described here:
http://inedo.com/support/kb/1036/using-progets-symbol-server

Package gets built and pushed to Proget using BuildMaster. I setup VS options as described and I do see the .pdb files when I open package page in Proget and click on the View for "Symbols and source files are available", meaning they exist and are indexed. I configured the feed to not strip the symbols when downloading the package. Then I install the package via Nuget Package Manager UI or Package Manager Console with -Source option.

When debugging through the code that uses this package VS tries to open the source file on the Buildmaster server, where it was built from, as local file (D:\Buildmaster_SVCTMP...) and sure enough the file is not on my local drive, it's on BM server.

What am I missing?
Thanks,
Nik

Product: ProGet
Version: 4.0.9

3
replies

Hi,

Currently during the release package, a stage is marked success if any of its target is success, irregardless whether other targets in the same stage is failed or not.

Is it possible to change the behavior so that
(1) to mark the stage success only after all its targets are success? And
(2) if any of its target fails, the stage should be marked as fail.

This sounds more logical to me than the current behavior. Please advise. Thanks.

Regards,
Aris

Product: BuildMaster
Version: 5.3.4

Ask A Question
Page: 1234567891011121314151617181920222425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394