Support Q & A Home

Ask A Question

Anyone can ask or answer a question here, but our support engineers actively monitor your questions; we typically answer within a day or two.

Filter
Viewing Page 24 of 95 (20 questions out of 1887)
6
replies

I have a variable that I initialize outside of all blocks (so that it won't be scoped to a server or deployable). Then, I attempt to set it to a new value inside an async block. I know the set inside the async is working, because I can log the value. But, after the blocks are finished, the value has reverted back to the default set before the async.

Is there a way to persist the value after the async, or in other words, to have a thread safe variable?

Code:

set $ScriptError = P;

Log-Information $ScriptError;

with async
{
    set $ScriptError = X;

    Log-Information $ScriptError;
}

await;

Log-Information $ScriptError;

Output in Log:

P
X
P

What I want:

P
X
X

This is a simplified version of my code. In reality, I am running scripts on several servers simultaneously, and each server has its own variable in which to report status.

Product: BuildMaster
Version: 5.3.1

6
replies

Hi

I cannot find any documentation on how to setup LDAP

Could you please point me to it?

Thanks

Product: ProGet
Version: 4.2.1

2
replies

I'm setting a variable I want to use in the entire plan but the variable is set by reading in the value from a file. Is there a way to set it as a plan wide variable?

Product: BuildMaster
Version: 5.3.1

2
replies

When I use this function to get a stored credential:

Log-Debug $GetCredentialProperty(DSSOtterAzure,Password);

It prints out: DEBUG: System.Security.SecureString

I assume that means it contains a secure string (and it's not just not a string containing the words "System.Security.SecureString" ) but how can I pass this to a powershell script (using pscall) for use in a credentials object?

If I try and pass it as a secure string parameter it complains that it's the wrong type:
Cannot convert the "System.Security.SecureString" value of type "System.String" to type "System.Security.SecureString".

If I pass it as a string and then convert it to a secure string in the script it says the credentials are wrong :(

Thanks!

4
replies

Why is ProGet silent install failing silently?

As ADMIN I have run:

ProGetSetup4.2.1.exe /S /LogFile=log.txt

I get nothing in the console and no log file.
I have tried cmd prompt, powershell and git bash.
I have also tried using an absolute path.

Any ideas?
Thanks!

Product: ProGet
Version: 4.2.1

1
replies

When I navigate to a feed's page, I get this error at the top of the screen:

There was an error with a connector:
The underlying connection was closed: An unexpected error occurred on a receive., The underlying connection was closed: An unexpected error occurred on a receive.

The problem is I have five connectors setup, so I'm not sure which one is the issue. Three of the connectors are for internal feeds hosted on the ProGet server, the other two are external connectors.

Is there a way to troubleshoot this further?

Product: ProGet
Version: 4.0.10

4
replies

Recently some of our users had a password reset of their AD credentials. After resetting their password they (via ADUC) they were unable to login to the environment overnight (roughly 9-10 hours).

I was able to get the authentication going again, but not after I tried both restarting the services (failed) and restarting the server (worked).

During this time, users that did not have a password reset were working fine. What is the standard way to handle this situation? Turning it off and on seems a bit heavy handed!

Product: BuildMaster
Version: 5.2.3

6
replies

After installing ProGet I have gotten the repository up running and I have setup the Powershell feed, but upon publishing Module I get the next error:
Image Text

And IIS Logging:
<code>
2016-08-02 08:56:12 ::1 PUT /nuget/powershell/ - 81 - ::1 NuGet+Command+Line/2.8.60717.93+(Microsoft+Windows+NT+6.2.9200.0) - 500 0 0 859
</code>

This has maybe something to do with that i have copied the nuget package provider to "C:\Program Files\PackageManagement\ProviderAssemblies\nuget\2.8.5.205". I had to do this because my Windows 2012 WMF 5.0 machine does not have access to the internet and i cannot install the nuget packageprovider.

The erros has led me to this page:
http://inedo.com/support/questions/1303
But I’m not sure what the build-agent exactly is. The only service I can find is the “Proget Service”.

Also, procmon shows me that de nuget package has been created by the nuget executable. But the files T empPublishError.txt and TempPublishOutput.txt are gone before I can troubleshoot.

Can you please help me resolve this issue?

Product: ProGet
Version: 4.2.0

1
replies

I have several places in my plans where I set a variable value from a file. In OtterScript (since 5.0), it is shown as a legacy action. What recommendation do you have for bringing it up-to-date? Is there a different action I should use? Or do I need to write a custom function? I'm also curious as to why this isn't supported any more...

Sample:

Execute-LegacyAction

        (
            Config: <Inedo.BuildMaster.Extensibility.Actions.Variables.SetVariableFromFileAction Assembly="BuildMasterExtensions"><Properties VariableName="RunScripts" FileName="ScriptsToRun.txt" MaxLength="14" OverriddenSourceDirectory="C:\BuildMasterAgent\buildscripts" /></Inedo.BuildMaster.Extensibility.Actions.Variables.SetVariableFromFileAction>
        );

Product: BuildMaster
Version: 5.2.3

1
replies

I notice that the GetCredentials function is not listed in Administration->Extensions->InedoCore, and when I try to use it it errors: "Could not resolve function $GetCredentials".

It is mentioned in the documentation though. Has is been removed for some reason?

1
replies

Hi Team ,

Can i get a response whether you have following capabilities:

  1. Group pipelines by Project/Codebase - Does the Pipeline (UI) provide for easier segregation based on branch/repository in SCM?
  2. Clone a pipeline/pipeline template - Can the pipeline template for a project be cloned by other project for workflow configuration?
  3. Enable/Disable steps in a pipeline/ Run a single step - Ability to disable steps/tasks for each stage of pipeline
  4. Configure dependent pipeline - Multiple pipelines which are used to deploy dependent components (for e.g. Web services and corresponding UI for Participant Profile)
  5. Ability to do rollbacks - Manual and Automated rollback of deployment
  6. Support for custom script execution - Gradle/Ant/Maven script execution triggered from Pipeline

Product: BuildMaster
Version: 5.2.3

2
replies

Just wondering when we can expect all the missing IIS and Windows functions that are supposed to be in 5 of Buildmaster?
Things like Ensure-AppPool, Ensure-website, Ensure-service, etc.

Considering the push to move to 5 and then not having those functions available even in their old form in the initial release I would have expected them by now.

Thanks.

Product: BuildMaster
Version: 5.2.3

2
replies

I have a pretty default install of Otter but with IIS serving the site.

I have created an orchestration plan that runs a powershell script with pscall, and a template that applies it to localhost. I can trigger the job template manually and it runs (Jobs->Create Orchestration Job), but if I try via the API call it returns "Error creating job: Invalid name.".

The template is enabled for API calls, I have tried with and without using a key, and I have checked the IIS logs.

Any idea how I can resolve this or find more info on this error?

1
replies

Do you have plans to support a VSIX extension feed in ProGet - this would be very useful feature please!

Thanks

Product: ProGet
Version: 4.2.1

4
replies

I setup a connector for a feed I created to Chocolatey.org so I could pull packages from the public repo at Chocolatey.org into my local feed, but when I do "choco list" I see EVERY package from Chocolatey.org vs. just the two I pulled in. Ideally, I just want to see what's in our local repo, as we'd disable the internet repos and only use what we have in our local repo. Is there a way to set this up?

Disclosure: I am very new to ProGet and Chocolatey, so I may have something setup incorrectly.

Product: ProGet
Version: 4.1.3

1
replies

So, in testing how to do the license filtering, I create a new feed called test of type npm. I add a feed connector to https://registry.npmjs.org. This works great.

The issue comes when I try a set up a License Filter. Based on the help in the dialog box, I am under the impress is either wide-open, or a white-list, i.e. only the licenses listed are allowed. However, when I enter a bogus URL to test (call it https://www.google.com), and run an npm install socketio which is under ICS license, it still will install, along with the rest of the dependencies which are a mix of BSD-3-Clause, MIT, and ISC.

Now, most of the package.json files simply have a line like:

 "license": "ISC",

and not an actual URL, but one, configya, does in fact contain a URL pointing to the MIT license over at opensource.org.

So, what am I doing wrong, or is the software does not work that way?

Product: ProGet
Version: 4.2.0

6
replies

Hi,
can you help me with an example of how to use it? in the sample below only retrieves the deployable name but not the numbers that I need.

# Loop
foreach $Deployable in @DeployablesInRelease
{
    set $BuildComponents = $BuildComponents + $Deployable $ReferencedReleaseNumber.$ReferencedPackageNumber
    Log-Debug  $BuildComponents;

}

Many thanks.

Product: BuildMaster
Version: 5.2.3

1
replies

Hi,

I'm trying to get Approval required event listener to work, but it doesn't. Approval received event listener works though.

My setting for the listener is:

Application filter: all
Application group filter: all
Pipeline stages filter: all (there're no matched pipeline stages anyway, not sure if this is a sign of any symptoms)
Email address: my email (same email works for approval received event listener)
Email behavior: Notify all users whose approval is required in addition to the email addresses specified above
Additional options: Event listener is active ticked.

Product: BuildMaster
Version: 5.2.3

2
replies

Hi,
I'm trying to figure out why my bower feed on ProGet is not called when I try to install bower packages.
Bower feed

I put a .bowerrc file in my project but it's ignored by the bower command.

{ 
  "registry":{
    "search":"http://xxxxxx:81/bower/tsi-bower"
  },
  "timeout": 300000
}

I've run bower install angular, and it's installed from github and statics page shows 0 packages in the bower feed.

Image Text

Product: ProGet
Version: 4.2.0

0
replies

Hello,

####Context
We are encountering a problem with a Nuget feed with a connector pointing to MyGet.
We are receiving the following error when trying to search on that said Nuget feed.

The remote server returned an error: (500) Internal Server Error.```

####Repro Steps
1. Have a MyGet feed and find the `Feed Details` page (`www.myget.org`)
2. Copy the Nuget V2 pre-authenticated URL
3. Create a Nuget Proget connector and  use the copied URL
4. Add this connector to a nuget feed
5. Try the Proget search bar `Search packages:`

You should then face the error described previously.

Thank you and have a nice day

\- Frank

Product: ProGet  
Version: 4.1.2
Ask A Question
Page: 123456789101112131415161718192021222426272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889909192939495