Support Q & A Home

Ask A Question

Anyone can ask or answer a question here, but our support engineers actively monitor your questions; we typically answer within a day or two.

Filter
Viewing Page 43 of 105 (20 questions out of 2087)
1
replies

We have several feeds in our ProGet server (one for each business unit) and we've had historical problems with debugging NuGet packages from all the feeds. After taking over the project, I was able to get one feed working correctly where symbols files are correctly indexed and source files are being downloaded without any issue.

Taking the exact same steps I created for that feed, I moved onto the next feed and I'm still running into issues. Visual Studio correctly downloads the symbols file (verified this with Fiddler) and I see in the symbols cache the PDB file. When I debug, however, Visual Studio 2013 gives me a "PDB does not match image." When I look at the symbol load information, I that it went to the feed correct feed and downloaded the correct PDB file.

Here is where it gets interesting. I take the exact same NuGet package and push into a different feed that is currently working, I have no issues debugging with symbols.

Here are the settings for the feed that works:

  • Feed Type: NuGet
  • Disk path override: Default
  • Buil import drop path: Default
  • NuGet API key: Default
  • Options:
  • Active -> Checked
  • Cache packages from this feed's connectors -> Checked
  • Enable symbol and source server for this feed -> Checked
  • Automatically strip PDB files when downloading packages -> Checked

Here are the settings for the feed that does not work:

  • Feed Type: NuGet
  • Disk path override: Default
  • Buil import drop path: Default
  • NuGet API key: Default
  • Options:
  • Active -> Checked
  • Cache packages from this feed's connectors -> Checked
  • Enable symbol and source server for this feed -> Checked
  • Automatically strip PDB files when downloading packages -> Checked

As you can see, they are identical. The only difference is the broken feed does have connectors setup for it. The ProGet UI does not show any indexing errors (a few JSON errors for an NPM feed I'm not currently working on) and nothing shows up in the event viewer. If you have an suggestions or thoughts on what the issue might be or a way to get more details to find the issue, it would be most appreciative.

Thanks in advance for your help.

Product: ProGet
Version: 3.5.5

6
replies

Hi,

Is this doable?

Thanks,
Joel

Product: ProGet
Version: 3.8.0

2
replies

Hi,

This is a follow-up to this question: http://inedo.com/support/questions/4413
It wasn't clear to me from that how to accomplish this task. I tried and was told the API accepts only POSTs and GETs. How should I construct a POST to do this?

Also, is there a plan to make this functionality externally viewable?

Thanks,
Joel

Product: ProGet
Version: 3.8.0

7
replies

Hi,

I am trying to upgrade my existing free installation (4.0.8) to 4.0.9 and the company's antivirus is triggered, because it detects a Trojan Dropper.

I tried to get it whitelisted by the IT department, but apparently the detection is legit.

Am I the only one with this issue? Is there anything you can do to prevent that from happening, so I can safely upgrade?

Thanks

Product: ProGet
Version: 4.0.9

1
replies

I've had Proget setup with LDAP to our single domain Active Directory for close to a year, and it works great. I was just wondering if there was a way to force the LDAP sync to occur. When I add new users to my groups in Active Directory, it takes hours before Proget sees the change.

Also, I can't seem to find the documentation I used to setup the LDAP integration. I see descriptions of the different types of authentication but no actual implementation guide. I have three groups in Active Directory 'Proget_ViewOnly', 'Proget_Developer', and 'Proget_Administrator'. Proget sees the users in these Active Directory groups and adds them to the respective Proget role, but I'm looking through configs and can't find where I actually set that up. Hoping you can refresh my memory so I can document this time.

Thanks,
Brad Kehoe

Product: ProGet
Version: 3.8.6

1
replies

1> Is there a way to automate publishing packages to Proget ? We are a .NET shop with CruiseControl and TFS for our continuous integration. If project/solution is set up for daily build in CruiseControl followed by powershell or windows command to package it into nuget package. After that we want to be able to automatically publish this in Proget. (Not using the Add Package wizard that comes up. in the sense no user ). At present Proget server is on the same box as Cruise Control(build and deploy) server.

2> How to update a package hosted in Proget ? Delete and add seems to be the only option here. Is there a way to update an existing package ?

Product: ProGet
Version: 4.0.9

1
replies

The admin section states that the service is currently not running but when I click manage service the popup says its running.

Product: ProGet
Version: 4.0.9

3
replies

Hello,

I made a sample symbols package and pushed it to the ProGet server. Visual Studio is correctly configured, according to the tutorial.

According to Fiddler, VS retrieves successfully the PDB from the server, but it does not try to get the sources. It tries to access the source locally, from where it was compiled.

> pdbstr -r -s:srcsrv -p:NuGetProjectSample.pdb
SRCSRV: ini ------------------------------------------------
VERSION=2
INDEXVERSION=2
VERCTRL=http
SRCSRV: variables ------------------------------------------
SRCSRVVERCTRL=http
PGSERVER=http://localhost:81/source-files
PGFEED=Default
PGPKGID=NuGetProjectSample
PGPKGVER=1.1.0.0
HTTP_EXTRACT_TARGET=%pgserver%/%pgfeed%/%pgpkgid%/%pgpkgver%/%var2%
SRCSRVTRG=%http_extract_target%
SRCSRVCMD=
SRCSRV: source files ---------------------------------------
d:\users\gservera\documents\visual studio 2013\projects\nugetprojectsample\nugetprojectsample\sample.cs*Sample.cs
SRCSRV: end ------------------------------------------------

Product: ProGet
Version: 4.0.9

3
replies

I have installed ProGet behind a firewall. Due to the firewall configuration that particular machine does not have internet access. I would like to manually activate the license, but no matter what page I go to in admin settings, I only get a page saying that the license needs to be activated. Because of this, I can't get my machine's UID.

Product: ProGet
Version: 4.0.9

1
replies

Hi,
Is ProGet supports IE? is there any document to know the list of browsers that ProGet supports/Not-supports?

I am unable to browse the packages list from IE. No error, but from last 1hr I am trying to browse the packages, but page is not opening. No issues in chrome.

Thanks

Product: ProGet
Version: 4.0.9

1
replies

I'm looking to get some thoughts on what might be the recommended way to upgrade and/or migrate our ProGet server. Currently, we are running v3.5.5 on Windows 2008R2 with SQL Server 2005 Express running. We are looking to replace this single server with two servers running Windows Server 2012R2 with SQL Server 2012 as the new database engine.

What I was sure of was how should I go about doing the upgrade.

My initial thought was to upgrade the current instance, migrate the database to the new database server, update the compatibility mode to be SQL 2012, then install ProGet on the two web nodes and point them to the new database server.

Has anyone done a similar upgrade and could comment on if this worked for them or did they run into issues? I'm also open to suggestions on other ways to do the upgrade that might be better then what I've spelled out.

Thanks in advance!

Product: ProGet
Version: 3.5.5

1
replies

What are the options for deploying a war file to a remote application server (such as tomcat)?

Product: BuildMaster
Version: 4.9.7

2
replies

I have an Azure DB to store Proget data.
I tried to run the installer to upgrade from 4.0.8 to 4.0.9 but it halts with the following message: "Database xxxx does not exist and the current user does not have the privileges to create it."
The database already exists and the user has full privileges...

Product: ProGet
Version: 4.0.8

1
replies

Is there a file limitation size for downloading from the proget server using the built in WebServer?

Product: ProGet
Version: 4.0.9

1
replies

When attempting to install ProGet 4.0.9 on Windows Server 2012 R2 x64, our System Center Endpoint Protection stopped the installer with the Severe alert level detection of Trojan:Win32/Gatrid.E!cl in file %TEMP%\ProGetSetup\bmdbupdate.exe

Category: Trojan

Description: This program is dangerous and executes commands from an attacker.

Recommended action: Remove this software immediately.

How should I proceed?

Product: ProGet
Version: 4.0.9

7
replies

Does this also work with Visual Studio Team Services (builds from TFS/Git/GitHub) ? (This was previously called Visual Studio Online.)

Product: BuildMaster
Version: 4.9.7

2
replies

Is there a settings which disallows overwriting packages ?

Product: ProGet
Version: 4.0.9

1
replies

Hey

Currently we are using SVN to move our code to local server. How do I deploy this in BuildMaster ?

Product: BuildMaster
Version: 4.9.7

4
replies

Hi,

We discovered an issue with Proget's NPM package web page that becomes inaccessible when multiple version of a package is uploaded. As soon as 10 to 15 version of the same package is uploaded to the feed, it's package page (not the feed page) becomes inaccessible (The web browser load indefinitely). The npm feed itself is still perfectly working and package can be downloaded correctly.

I've been able to reproduce this on 2 different IIS installation with version 4.0.8 and 4.0.9.

Thanks,
Carl

Product: ProGet
Version: 4.0.9

4
replies

When I click "Delete Feed" in Manage Feeds, I get the error.

System.Web.HttpUnhandledException: Exception of type 'System.Web.HttpUnhandledException' was thrown. ---> Npgsql.NpgsqlException:
update or delete on table "Feeds" violates foreign key constraint "FK__EventOccurrences__Feeds" on table "EventOccurrences"
Severity: ERROR
Code: 23503
at Npgsql.NpgsqlState+<ProcessBackendResponses>d__0.MoveNext () <0x40e644c0 + 0x0150b> in <filename unknown>:0

Is there a newer Linux build than 4.0.2 that addresses this? Or a way to switch the DB library from SQL server to Postgres on the newer manual releases?

Thanks.

Product: ProGet
Version: 4.0.4

Ask A Question
Page: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 43 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105