Support Q & A Home

Ask A Question

Anyone can ask or answer a question here, but our support engineers actively monitor your questions; we typically answer within a day or two.

Filter
Viewing Page 48 of 94 (20 questions out of 1879)
2
replies

Hello,
I am trying to connect ProGet to an SQL 2012 Express instance on a remote server. I have tried the following without success:
Data Source=ServerName\SQLEXPRESS; Initial Catalog=ProGet; Integrated Security=False;User Id=Domain\username;Password=password;

Can you tell me what the correct connection string is?

Product: ProGet
Version: 3.7.4

3
replies

I have a package that I am unable to get source indexing working on. VS is downloading the PDB, but not able to get the source. The problem is when I try to step into a line of code from the package VS is unable to find it.

In VS "Just my code" is off and "Enable source server support" is on.

I looked in fiddler and I can see the symbols being downloaded, but I don't see any requests from VS for the source.

srctool says none of the files are index.

c:\>srctool c:\source\symbols\Orbis.OA.Framework.Core.pdb\BEE6D23881A74643BC674C92062AF8D51\Orbis.OA.Framework.Core.pdb c:\source\symbols\Orbis.OA.Framework.Core.pdb\BEE6D23881A74643BC674C92062AF8D51\Orbis.OA.Framework.Core.pdb: none of the 3 source files are indexed

pdbsrc shows seemingly correct srcsrv details. And if I contstruct the source URL in the browser I get the source.

c:\>pdbstr.exe -r -s:srcsrv -p:c:\source\symbols\Orbis.OA.Framework.Cor
e.pdb\BEE6D23881A74643BC674C92062AF8D51\Orbis.OA.Framework.Core.pdb
SRCSRV: ini ------------------------------------------------
VERSION=2
INDEXVERSION=2
VERCTRL=http
SRCSRV: variables ------------------------------------------
SRCSRVVERCTRL=http
PGSERVER=http://nuget.orbisaccess.com/source-files
PGFEED=internal
PGPKGID=Orbis.OA.Framework.Core
PGPKGVER=0.1.0-ci0005
HTTP_EXTRACT_TARGET=%pgserver%/%pgfeed%/%pgpkgid%/%pgpkgver%/%var2%
SRCSRVTRG=%http_extract_target%
SRCSRVCMD=
SRCSRV: source files ---------------------------------------
c:/tc/buildagent/work/7185b5ab5ed6f01a/core/domainnameattribute.cs*DomainNameAttribute.cs
c:/tc/buildagent/work/7185b5ab5ed6f01a/core/exceptions/staledataexception.cs*Exceptions/StaleDataExc
eption.cs
c:/tc/buildagent/work/7185b5ab5ed6f01a/core/session/nullsessionscopeprovider.cs*Session/NullSessionS
copeProvider.cs
SRCSRV: end ------------------------------------------------

This is what the PDB download says in VS:

c:\users\p.coleman\documents\visual studio 2015\Projects\ConsoleApplication1\bin\Debug\Orbis.OA.Framework.Core.pdb: Cannot find or open the PDB file.
... snip ...
c:\source\symbols\Orbis.OA.Framework.Core.pdb\bee6d23881a74643bc674c92062af8d51\Orbis.OA.Framework.Core.pdb: Symbols loaded.

And this is what the source loading information in VS reports:

Locating source for 'c:\TC\BuildAgent\work\7185b5ab5ed6f01a\Core\Exceptions\StaleDataException.cs'. (No checksum.)
The file 'c:\TC\BuildAgent\work\7185b5ab5ed6f01a\Core\Exceptions\StaleDataException.cs' does not exist.
Looking in script documents for 'c:\TC\BuildAgent\work\7185b5ab5ed6f01a\Core\Exceptions\StaleDataException.cs'...
Looking in the projects for 'c:\TC\BuildAgent\work\7185b5ab5ed6f01a\Core\Exceptions\StaleDataException.cs'.
The file was not found in a project.
Looking in directory 'C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\include\'...
... snip ...
Looking in directory 'C:\Program Files (x86)\Windows Kits\10\Include\ucrt'...
Looking for source using source server...
The debug source files settings for the active solution indicate that the debugger will not ask the user to find the file: c:\TC\BuildAgent\work\7185b5ab5ed6f01a\Core\Exceptions\StaleDataException.cs.
The debugger could not locate the source file 'c:\TC\BuildAgent\work\7185b5ab5ed6f01a\Core\Exceptions\StaleDataException.cs'.

**When packing in TeamCity this is the output:**

[11:26:00]NuGet command: C:\TC\BuildAgent\plugins\nuget-agent\bin\JetBrains.TeamCity.NuGetRunner.exe C:\TC\BuildAgent\tools\NuGet.CommandLine.DEFAULT.nupkg\tools\NuGet.exe pack C:\TC\BuildAgent\work\7185b5ab5ed6f01a\Core\Framework.Core.csproj -OutputDirectory C:\TC\BuildAgent\work\7185b5ab5ed6f01a\nuget-pack-out -Verbose -Symbols -Properties ReleaseNotes=
[11:26:00]Starting: C:\TC\BuildAgent\temp\agentTmp\custom_script3014486825383318696.cmd
[11:26:00]in directory: C:\TC\BuildAgent\work\7185b5ab5ed6f01a\Core
[11:26:00]JetBrains TeamCity NuGet Runner 8.0.30168.9
[11:26:00]Registered additional extensions from paths: C:\TC\BuildAgent\plugins\nuget-agent\bin\plugins-2.8
[11:26:00]Starting NuGet.exe 2.8.50506.491 from C:\TC\BuildAgent\tools\NuGet.CommandLine.DEFAULT.nupkg\tools\NuGet.exe
[11:26:00]WARNING: Option 'Verbose' has been deprecated. Use 'Verbosity' instead.
[11:26:00]Attempting to build package from 'Framework.Core.csproj'.
[11:26:00]Packing files from 'C:\TC\BuildAgent\work\7185b5ab5ed6f01a\Core\bin\Debug'.
[11:26:00]Using 'Framework.Core.nuspec' for metadata.
[11:26:01]Id: Orbis.OA.Framework.Core
[11:26:01]Version: 0.1.0-ci0005
[11:26:01]Authors: Orbis
[11:26:01]Description: Framework Core
[11:26:01]Project Url: http://code.orbisaccess.com/client-app
[11:26:01]Dependencies: None
[11:26:01]Added file 'lib\net40\Orbis.OA.Framework.Core.dll'.
[11:26:01]Added file 'lib\net40\Orbis.OA.Framework.Core.pdb'.
[11:26:01]Successfully created package 'C:\TC\BuildAgent\work\7185b5ab5ed6f01a\nuget-pack-out\Orbis.OA.Framework.Core.0.1.0-ci0005.nupkg'.
[11:26:01]Attempting to build symbols package for 'Framework.Core.csproj'.
[11:26:01]Packing files from 'C:\TC\BuildAgent\work\7185b5ab5ed6f01a\Core\bin\Debug'.
[11:26:01]Using 'Framework.Core.nuspec' for metadata.
[11:26:01]WARNING: File 'C:\TC\BuildAgent\work\7185b5ab5ed6f01a\Core\bin\Debug\Orbis.OA.Framework.Core.pdb' is not added because the package already contains file 'lib\net40\Orbis.OA.Framework.Core.pdb'
[11:26:01]Id: Orbis.OA.Framework.Core
[11:26:01]Version: 0.1.0-ci0005
[11:26:01]Authors: Orbis
[11:26:01]Description: Framework Core
[11:26:01]Project Url: http://code.orbisaccess.com/client-app
[11:26:01]Dependencies: None
[11:26:01]Added file 'lib\net40\Orbis.OA.Framework.Core.dll'.
... snip ...
[11:26:01]Added file 'src\Session\NullSessionScopeProvider.cs'.
[11:26:01]Successfully created package 'C:\TC\BuildAgent\work\7185b5ab5ed6f01a\nuget-pack-out\Orbis.OA.Framework.Core.0.1.0-ci0005.symbols.nupkg'.
[11:26:01]Process exited with code 0

Product: ProGet
Version: 3.4.2

1
replies

I'm currently looking to replace Nuget with a different solution.

We have a very high number of private packages (about 17,000 plus) and the performance of our Nuget feed is quite poor. Would the Nuget feed of Proget improve upon this?

Product: ProGet
Version: 3.7.4

1
replies

Is it possible to extend ProGet (using the SDK) to add support for RubyGems feeds? (http://guides.rubygems.org/rubygems-org-api/)

If not, is there any chance of seeing this feature added to ProGet core in the future?

Product: ProGet
Version: 3.7.3

3
replies

I have a NuGet package I'm trying to publish that contains both assemblies and content files. After publishing the standard and symbols packages, the content files from the standard package are gone.

When I run NuGet packaging the filesystem looks like this:

MyProduct.nuspec
content/
  Web.config.install.xdt
lib/
  net45/
    MyProduct.dll
    MyProduct.pdb
    MyProduct.xml
src/
  Class1.cs
  Class2.cs

As you can see, I have it all set up and ready to go.

I then run the commands to pack the NuGet packages using nuget.exe version 2.8.5:

nuget.exe pack MyProduct.nuspec
nuget.exe pack MyProduct.nuspec -Symbols

What I get out of that is two package files:

MyProduct.1.0.0.nupkg
MyProduct.1.0.0.symbols.nupkg

If I look inside the MyProduct.1.0.0.nupkg file, I see:

content/
  Web.config.install.xdt
lib/
  net45/
    MyProduct.dll

If I look inside MyProduct.1.0.0.symbols.nupkg I see:

lib/
  net45/
    MyProduct.dll
    MyProduct.pdb
    MyProduct.xml
src/
  Class1.cs
  Class2.cs

Note the important difference there: the symbols package doesn't contain the content files. That's not something I have control over - it's the way nuget.exe packages things and is the standard per the NuGet documentation.

I then push the first package to my ProGet server:

nuget.exe push MyProduct.1.0.0.nupkg myapikey -s http://proget/feeds/Default

If I download that package immediately after pushing, I can open it up and see the content files are still there. It's exactly like the MyProduct.1.0.0.nupkg file that I pushed. ProGet doesn't show symbols as being available yet because, obviously, they're not.

I then push the symbols package:

nuget.exe push MyProduct.1.0.0.symbols.nupkg myapikey -s http://proget/feeds/Default

ProGet now shows symbols as being available and I can download a symbol package that includes PDB and source files. If I download the symbols package MyProduct.1.0.0.symbols.nupkg from ProGet, it's exactly like the one I pushed.

If I download the MyProduct.1.0.0.nupkg package now, after pushing symbols, the content files are gone. The MyProduct.1.0.0.nupkg on ProGet now looks like this inside:

lib/
  net45/
    MyProduct.dll

The content is gone.

I did find this question where it sounded like folks assumed a symbol package only differs from a regular package by the fact that the symbol package has everything the regular package has with the addition of PDB and source files.

This is not the case. Symbol packages strip out content, build, tools, and other stuff that isn't symbols.

I am guessing that by uploading the symbols package, ProGet is dynamically re-creating the non-symbol package internally based on what's in the symbols package. I can't say for sure, but that's certainly how it appears.

As a temporary workaround, I'm going to have to stop publishing symbols for this package until I have a resolution.

Where did my content go and how can I get it back?

Product: ProGet
Version: 3.7.3

1
replies

We get an internal error when deleting a NPM feed from the UI.

The Windows event log shows this:

    Exception type: SqlException 
    Exception message: 547`16`0`Feeds_DeleteFeed`168`The DELETE statement conflicted with the REFERENCE constraint "FK__ScheduledTasks__NpmConnectors". The conflict occurred in database "ProGet", table "dbo.ScheduledTasks", column 'NpmConnector_Id'.
   at System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection, Action`1 wrapCloseInAction)
   at System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj, Boolean callerHasConnectionLock, Boolean asyncClose)
   at System.Data.SqlClient.TdsParser.TryRun(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj, Boolean& dataReady)
   at System.Data.SqlClient.SqlCommand.FinishExecuteReader(SqlDataReader ds, RunBehavior runBehavior, String resetOptionsString)
   at System.Data.SqlClient.SqlCommand.RunExecuteReaderTds(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, Boolean async, Int32 timeout, Task& task, Boolean asyncWrite, SqlDataReader ds)
   at System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method, TaskCompletionSource`1 completion, Int32 timeout, Task& task, Boolean asyncWrite)
   at System.Data.SqlClient.SqlCommand.InternalExecuteNonQuery(TaskCompletionSource`1 completion, String methodName, Boolean sendToPipe, Int32 timeout, Boolean asyncWrite)
   at System.Data.SqlClient.SqlCommand.ExecuteNonQuery()
   at Inedo.Data.SqlServerDataFactory.ExecuteNonQuery(String storedProcName, IList`1 parameters)
   at Inedo.ProGet.WebApplication.Pages.Administration.Feeds.Management.DeleteFeedPage.<>c__DisplayClass2.<CreateChildControls>b__1(Object s, EventArgs e)
   at Inedo.Web.Controls.ButtonLinks.PostBackButtonLink.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument)
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

Product: ProGet
Version: 3.7.3

1
replies

As I understand it, the client and server side for NuGet v3 is basically a full rewrite and breaking API change. How long after the v3 release, coming next week, will we see a ProGet server that supports the v3 NuGet server API that integrates with VS2015?

Thank you,

Ian Davis

Product: ProGet
Version: 3.7.3

1
replies

Hi
guys we get in our TeamCity sometimes an Error 500 file not found from proget but the file is there. on the next retry proget found the file.
The feed has an connector and I think something went wrong with the searche

Can Proget log the Error 500?

Product: ProGet
Version: 3.6.1

1
replies

SHould I just move the files stored in the local folders to some place else? How does it work.

Product: ProGet
Version: 3.6.2

1
replies

We are using git flow branching strategy and would like to automaticaly build and deploy every commit to the current release branch. The naming convention for the branch is release/<release number> (i.e. release/8.5)

Is there a way to trigger automatic build from commit to any Git branch that starts with release/ ?

Product: BuildMaster
Version: 4.5.7

4
replies

We have two npm feeds in our proget setup. The first feed (http://feed.domain/npm/DefaultNPM) is a default feed for caching and proxying the public npm registry. The second feed is where we publish our private modules. We cannot add the second feed (http://feed.domain/npm/PrivateNPM) as a connector to our first one.

How do we connect the two feeds so that we can centralize all npm requests into one feed?

Product: ProGet
Version: 3.6.1

1
replies

I created a maven connector but it shows nothing.
I added a local nexus connection but it still shows nothing.

What am I doing wrong ?

Product: ProGet
Version: 3.7.3

1
replies

i installed build master but got an below error when i opened localhost:

Please help.

Config Error This configuration section cannot be used at this path. This happens when the section is locked at a parent level. Locking is either by default (overrideModeDefault="Deny"), or set explicitly by a location tag with overrideMode="Deny" or the legacy allowOverride="false".
Config File \?\C:\BuildMaster\WebApp\web.config

Product: BuildMaster
Version: 4.7.4

1
replies

Helllo.

I'm getting started with BuildMasterBuildMaster and I've just had an error creating a custom extension, this is the output:

Method not found: 'Inedo.BuildMaster.Data.StoredProcedures.Applications_GetApplications Inedo.BuildMaster.Data.StoredProcs.Applications_GetApplications(System.Nullable`1<Int32>)'.

What can I do?

Thanks

Product: BuildMaster
Version: 4.7.4

8
replies

I can’t get ProGet to start. The machine has multiple IPs, and I only want ProGet to bind to one of them. I added a reservation to the correct URL (http://nuget.atg.analog.com:80/ ) but it fails to start:

Application: ProGet.Service.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.Net.HttpListenerException
Stack:

Server stack trace: 
   at System.Net.HttpListener.AddAllPrefixes()
    
All URL reservations on NWD2HSCJNKS2:
http://*:2869/ (NT AUTHORITY\LOCAL SERVICE)
http://*:5357/ (NT AUTHORITY\LOCAL SERVICE, BUILTIN\Users)
https://*:5358/ (NT AUTHORITY\LOCAL SERVICE, BUILTIN\Users)
http://+:47001/wsman/ (NT SERVICE\Wecsvc, NT SERVICE\WinRM)
http://+:5985/wsman/ (NT SERVICE\Wecsvc, NT SERVICE\WinRM)
https://+:5986/wsman/ (NT SERVICE\Wecsvc, NT SERVICE\WinRM)
https://+:443/sra_{BA195980-CD49-458b-9E23-C84EE0ADCD75}/ (NT AUTHORITY\SYSTEM, BUILTIN\Administrators, NT SERVICE\SstpSvc)
http://+:80/Temporary_Listen_Addresses/ (\Everyone)
http://+:8733/Design_Time_Addresses/ (NT AUTHORITY\INTERACTIVE)
http://127.0.0.1:47873/help/ (\Everyone)
http://nuget.mydomain.com:80/ (MYDOMAIN\mfowler)

Product: ProGet
Version: 3.7.3

2
replies

Currently we build all our Nuget packages to a file-share, and use a Feed Drop Path in ProGet to scan that folder for packages. This works perfectly for .nupkg packages, but it does not pick up symbols packages (.symbols.nupkg).

Any ideas anyone?!

Product: ProGet
Version: 3.7.3

4
replies

Hi there,

I'm using ProGet to provide private NuGet feeds to my customers. Once they pay for a subscription, I'm adding their company as a ProGet user. Currently this is a completely manual process, and I'm willing to use ProGet JSON API to automate it.

I've found the Users_CreateOrUpdateUser method under the /reference/api url, however I can't find how to:

  1. Set a password for a user – there is no any method to do this. There is the Users_SetPassword stored procedure, but I don't know how to generate salt bytes.
  2. How to form a Groups_Xml argument, since I completely don't know the required XML schema.

Can you help me with the questions?

Product: ProGet
Version: 3.7.1

13
replies

I've currently got ProGet v3.7.3 setup with LDAP authentication. However the problem is that when our build process tries to download feeds it's prompted for a username and password. I'm not really sure how to setup ProGet so that the build process can access the feeds anonymously to download packages, but genuine interactive users are prompted for a username/password (if accessing from different domain) or automatically logged straight in if they have permissions and accessing from the same domain as the server. I think something is not right with my settings because even if I try and access ProGet from a machine on the same domain as the server (say after an iisreset), even though LDAP authentication is enabled and I have admin privileges, I still get prompted for a username & password.

Product: ProGet
Version: 3.7.3

1
replies

Is there a way to make the auto Git-triggered build use the branch that actually triggered the build?
It looks like you can only trigger a preset deployment plan with the branch predefined, and not make it build the relevant branch for that trigger.

Basically I'm trying to set up a deployment plan that can attempt to build and run unit tests every time someone pushes to any branch.

Is this possible?

Product: BuildMaster
Version: 4.7.4

3
replies

I get the following error from the NUnit extension after running the tests.
System.FormatExcepyion: Input string was not in correct format.
I'm using Windows Server 2012 Standard.

Maybe the extension doesn't specify CultureInfo.InvariantCulture in their Double.Parse call?
I've tried changing the decimal separator in Windows Region settings but it didn't work.

Image Text

Same issue as this question:
link text

Error outout:

run: 4, Errors: 0, Failures: 0, Inconclusive: 0, Time: 0,146542291976769 seconds INFO: Not run: 0, Invalid: 0, Ignored: 0, Skipped: 0
ERROR: An unhandled exception occurred while executing this action: System.FormatException: Input string was not in a correct format.
at System.Number.ParseDouble(String value, NumberStyles options, NumberFormatInfo numfmt)
at Inedo.BuildMasterExtensions.NUnit.NUnitAppAction.RunTests()
at Inedo.BuildMaster.Extensibility.Actions.Testing.UnitTestActionBase.Execute()
at Inedo.BuildMaster.Extensibility.Actions.ActionBase.ExecuteInternal(IActionExecutionContext context, ExtensionConfigurerBase extensionConfigurer, Boolean resumeNextOnError, Boolean logErrorsAsWarnings)

Product: BuildMaster
Version: 4.7.3

Ask A Question
Page: 1234567891011121314151617181920212223242526272829303132333435363738394041424344454648505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394