BuildMaster 4.0.9 Has Been Released

We just shipped BuildMaster 4.0.9. It's a maintenance release of BuildMaster 4.0 which means that there is minimal risk to upgrading from an earlier 4.0. However, if you're planning to upgrade from a version prior to 4.0, make sure to read the appropriate upgrade notes.

To install or upgrade, simply download BuildMaster and run the installer.

Here's what we changed between 4.0.8 and 4.0.9:

  • BM-1330 - Do not assign default release name when editing a release
  • BM-1329 - FIX: Log Errors as Warnings stills logs as an error for legacy actions
  • BM-1328 - Allow deployable to be selected when generating changescripter
  • BM-1327 - FIX: Execution Status predicate should not fail with warnings
  • BM-1326 - Add option to not log warning when there are no scripts to execute
  • BM-1324 - FIX: DATE,DATE2 variables are always in UTC now and always refer to the execution start date instead of the current date
  • BM-1323 - Show loaded extension components on extension details page
  • BM-1322 - FIX: Providers should be in alphabetical order and not allow duplicate names
  • BM-1321 - FIX: Change Server Type recipe should skip agents that can't be deserialized
  • BM-1320 - FIX: Use release name as alias on included deployables
  • BM-1319 - FIX: Windows extension should not be deleted on upgrade
  • BM-1317 - Add server errors list to server overview page

To learn more about how we distinguish between major, minor, and maintenance releases, make sure to check out KB#1059 - When should I update?