BuildMaster 5.0.10 Has Been Released

We just shipped BuildMaster 5.0.10. It's a maintenance release of BuildMaster 5.0 which means that there is minimal risk to upgrading from an earlier 5.0. However, if you're planning to upgrade from a version prior to 5.0, make sure to read the appropriate upgrade notes.

To install or upgrade, simply download BuildMaster and run the installer.

Here's what we changed between 5.0.9 and 5.0.10:

  • BM-2000 - FIX: Error Cloning Application with Global Pipeline
  • BM-2001 - FIX: Permissions error using build step without environment association
  • BM-2002 - FIX: Jenkins Plug-in May See 404s when using the BuildMaster API
  • BM-2003 - FIX: Permissions resolution for /plans and /template-plans
  • BM-2004 - FIX: Configuration File Deployment may not replace Runtime variables (only configuration)
  • BM-2005 - FIX: Null AllowedIP Range may Crash Scheduled Triggers View
  • BM-2006 - FIX: Add Cascade Deletes to BuildScheduleVariableDefinitions
  • BM-2007 - FIX: Templates without descriptions cause errors in visual editor
  • BM-2008 - FIX: Cannot edit multi-repository providers that were created in between v4.7 and v5.0
  • BM-2009 - FIX: Invalid EventListeners on a Pipeline Cause Deserialization Error

To learn more about how we distinguish between major, minor, and maintenance releases, make sure to check out KB#1059 - When should I update?