Otter 2.0.6 Has Been Released

We just shipped Otter 2.0.6. It's a maintenance release of Otter 2.0 which means that there is minimal risk to upgrading from an earlier 2.0. However, if you're planning to upgrade from a version prior to 2.0, make sure to read the appropriate upgrade notes.

To install or upgrade, simply download Otter and run the installer.

Here's what we changed between 2.0.5 and 2.0.6:

  • OT-216 - API key generation should not generate characters that require escaping
  • OT-215 - FIX: Automatic package collection does not occur if the server has no configuration plan
  • OT-213 - On the server configuration page, it shows "current" in the brief period of time between collection run initialization and the first configuration data is collected instead of "collecting"
  • OT-212 - FIX: Execution Details page has a JavaScript error (and breaks layout) when there are no log scopes for an execution
  • OT-211 - FIX: Removing all statements from the role configuration plan editor UI is not updated when saved
  • OT-210 - FIX: invalid Windows path characters in a script asset name cause an error on the scripts overview page
  • OT-208 - Add warning on Edit Role page about renaming role
  • OT-207 - FIX: Raft item version history gives an unhelpful error message for rafts that don't support version history
  • OT-206 - FIX: Execution Details page display error
  • OT-205 - FIX: @ServersInRoleAndEnvironment, @ServersInRole, and @ServersInEnvironment return 0 servers

To learn more about how we distinguish between major, minor, and maintenance releases, make sure to check out KB#1059 - When should I update?