ProGet 3.4.3 Has Been Released

We just shipped ProGet 3.4.3. It's a maintenance release of ProGet 3.4 which means that there is minimal risk to upgrading from an earlier 3.4. However, if you're planning to upgrade from a version prior to 3.4, make sure to read the appropriate upgrade notes.

To install or upgrade, simply download ProGet and run the installer.

Here's what we changed between 3.4.2 and 3.4.3:

  • PG-322 - Add error message for when service cannot communicate with database
  • PG-321 - Improve performance for browsing npm feeds
  • PG-320 - FIX: Bower search URL not always mapped to correct handler
  • PG-319 - FIX: Connector packages cannot be installed from Bower without first being pulled to ProGet
  • PG-318 - Add special 404 handler for feed roots
  • PG-317 - Improve package import error logging
  • PG-316 - Admin_ManageFeeds should be scopeable by feed

To learn more about how we distinguish between major, minor, and maintenance releases, make sure to check out KB#1059 - When should I update?