ProGet 4.0.7 Has Been Released

We just shipped ProGet 4.0.7. It's a maintenance release of ProGet 4.0 which means that there is minimal risk to upgrading from an earlier 4.0. However, if you're planning to upgrade from a version prior to 4.0, make sure to read the appropriate upgrade notes.

To install or upgrade, simply download ProGet and run the installer.

Here's what we changed between 4.0.6 and 4.0.7:

  • PG-515 - FIX: Cannot remove users from groups without supplying the user's password
  • PG-513 - FIX: npm package download counts are cached too heavily
  • PG-514 - FIX: Pulling npm packages can cause an invalid hidden validation appearing as if nothing was pulled
  • PG-512 - FIX: Removing the default feed causes privilege validation errors to be generated in the error log
  • PG-511 - Allow PackagesRootPath to be optionally configured in .config files for load-balanced and high availability installations
  • PG-509 - FIX: Symbol server does not return the closest match for symbols of multiple ages
  • PG-507 - FIX: Packages overview page should not include cached packages in the listing
  • PG-506 - FIX: Universal package sample code displays some console arguments in the wrong format
  • PG-504 - Option to create default connector when creating a new feed should either be unchecked by default or removed
  • PG-505 - FIX: When assigning a Chocolatey connector to a feed, the UI incorrectly reports that there aren't any

To learn more about how we distinguish between major, minor, and maintenance releases, make sure to check out KB#1059 - When should I update?