Ask A Question

View Question

Hi,
I am evaluating the BuildMaster and I was able to get the latest from TFS and when I execute the MSBuild, it failes with an error code -1. Here is output I see:

Action 1: Build (Debug; AnyCPU) SPE.WebServices.WebApi.Internal.sln using .NET 3.5 from default directory to the \bin{config} subdirectory of each project in the solutionCustom Variables: (none)Source and Target directory same; splitting.AgentBasedAction Initialization Complete: Temp Directory: C:\BuildMaster_SVCTMP_A2_S3\TMP Source Directory: C:\BuildMaster_SVCTMP_A2_S3\SRC Target Directory: C:\BuildMaster_SVCTMP_A2_S3\WRK Server: IE9WIN7 (Id: 1)Initializing action...Initialization complete. Executing...Building Application Action: Build; Path: C:\BuildMaster_SVCTMP_A2_S3\SRC\SPE.WebServices.WebApi.Internal.slnArguments: "C:\Windows\Microsoft.NET\Framework\v3.5\msbuild.exe" "C:\BuildMaster_SVCTMP_A2_S3\SRC\SPE.WebServices.WebApi.Internal.sln" "/p:Configuration=Debug;Platform=AnyCPU"Working Directory: C:\BuildMaster_SVCTMP_A2_S3\SRCExecuting C:\BuildMaster_SVCTMP\ExtTemp\WindowsSdk\BmBuildLogger.exeStep failed (msbuild returned code -1)Execution complete. Finalizing...Target directory unused; joining with source.Finalization complete.

Few troubleshooting questions:

Is there any indication of an error message logged in that output? What version of BuildMaster are you using, and what version of the WindowsSDK extension?

Also, you almost never need to supply a .NET version number to the Build MSBuild Project action as the project file will have that information within it.

Hi, Thanks for the response.
There is no other error or failure I see in the log. TFS get latest completed just fine before the build.

Also, I tried the way you mentioned as well (not supplying the .net framework version) It still throws me the same error.

I am using the latest version of BuildMaster 4.0.9

What happens if you run an Execute Command Line action with the following options:

Exe Path: C:\Windows\Microsoft.NET\Framework\v3.5\msbuild.exe

Arguments: "SPE.WebServices.WebApi.Internal.sln" "/p:Configuration=Debug;Platform=AnyCPU"

Command line works just fine..

Answer Question