Ask A Question

View Question

I am trying to add VSS as a source control provider and am running into problems and hope someone can help.

I have downloaded the extension and am adding the provider but having difficulty with the Database Connection section.

Our VSS database file (srcsafe.ini)is stored on a shared drive at \filer1\vss\VS2010\srcsafe.ini.

However if I enter this for the 'Database File Path' and click 'Test Connection' I get the following error: 'An unexpected error occurred while attempting to connect. The database file at '\filer1\vss\VS2010\srcsafe.ini' does not exist.'

Additionally if I click '...' (next to 'Database File Path') I get a browse dialog with only c: and d: listed. Can the VSS extension not handle mapped or network drives, or am I doing something else wrong?

thanks in advance

It's most likely the account that BuildMaster is running as does not have access to the share (e.g. it is running as Local System or Network Service?)

Easiest test is to change the credentials on either the IIS application pool to run as your account (for the IIS agent), or update the credentials of the integrated web server service (for a self-hosted BuildMaster installation).

If that's not the problem, we're in the process right now of adding our extension source code to GitHub ( http://github.com/inedo ) if you wanted to take a look at it we'll move SourceSafe to the top of the list.

Karl,

Thanks for the quick response.

I'm pretty sure when I installed I went for the default 'local system'.

How do I change this to a specific account?

During the install, did you choose to host BuildMaster with IIS or the Integrated Web Server?

Integrated Web Server

There's a Windows service running named "BuildMaster Web Server" (INEDOBMWEBSRV), just go into its properties and change the Log On user to the user you want.

I managed to get the source provider set up correctly but am now having a problem creating an application.

I create a new .net app, but on the Source Control step (step 3) after I fill in the 'Path of solution or project' and click next I get an unexpected error.

"Could not find file 'C:\Documents and Settings<username>\Local Settings\Temp<systemname>'. "

I suspect this is because I originally installed as 'local system' and it doen't have rights to create the temp folder or something like that,

Can you advise if this is the case and how to correct?

Answer Question