View Question

Good news! We have migrated all the Q&A on this site to https://forums.inedo.com, and are currently monitoring questions there!

Here are some important links:

All posts here are permanently locked (and will be redirected soon), and if you have any issues with the new site, please submit a support ticket, use the contact form, or visit our Slack Workspace.

On a Windows Server 2016 (Standard) server, I upgraded BuildMaster from v5.8.1 to v5.8.3 (the latest available version).

However, now the BuildMaster Service (INEDOBMSVC) will not start. I have tried rebooting the server, but the service still fails after reboot. The only error message that seems to be logged is: "Service cannot be started. The handle is invalid"; attempting to start the service from the Services control panel logs the same error.

The "BuildMaster Web Server (INEDOBMWEBSRV)" service is running fine.

If I open an administrative command prompt and attempt to start the service, using "net start inedobmsvc", I get the following output:
The BuildMaster Service (INEDOBMSVC) service is starting.
The BuildMaster Service (INEDOBMSVC) service could not be started.
The service did not report an error.

I may attempt to rollback to the previous version (I do have a database backup), but any suggestions for troubleshooting or fixing the current installation are welcome.

Product: BuildMaster
Version: 5.8.3

From a Google search, I found this article:
https://inedo.com/support/questions/699
Which led me to:
https://inedo.com/support/kb/1015/running-an-inedo-products-services-interactively

I tried the process in this article, and received an error message that the BuildMaster service could not connect to the SQL Server instance: "A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections."

I then checked the "SQL Server" service in the Services applet and found that it wasn't running (it was set to Automatic start), so I started it and it started successfully. After that, I was able to successfully start the "BuildMaster Service (INEDOBMSVC)" service from the Services applet.

Now, everything is running fine.

I still need to investigate why the SQL Server service did not start after a reboot.

Thanks for posting an update!

Anecdotally, this used to happen to us "all the time" when rebooting a hypervisor server (i.e. server hosting multiple VMs) because the host/hypervisor server didn't have enough resources to give to each booting virtual machine, and SQL Server couldn't start due to low start-up resources (memory, etc).

We've mostly corrected this by staggering start times and increasing VM hardware.