New Reply

Good news! We have migrated all the Q&A on this site to https://forums.inedo.com, and are currently monitoring questions there!

Here are some important links:

All posts here are permanently locked (and will be redirected soon), and if you have any issues with the new site, please submit a support ticket, use the contact form, or visit our Slack Workspace.

Hi, getting an error on the setup wizard, after specifying our source control (and SVN instance), and then the path, and error like:

Exception Details: System.InvalidOperationException: svn: E155007: 'C:\WINDOWS\Temp\tmpBC6F.tmp' exists and is not a directory

Note the above is with the source control set to use the command line client. If not ticked, the error is similar but this:

Exception Details: SharpSvn.SvnInvalidNodeKindException: 'C:\WINDOWS\TEMP\tmpBC82.tmp' exists and is not a directory

Ie. same problem but from somewhere else.

Subversion is 1.7.8 and connection checked as Ok (indeed when setting up for this project, selector allows selection).

No idea how to fix this, and as such at a dead end. Thanks for any help or pointers.

We've seen this error before when the BuildMaster service/IIS app pool are running as Network Service. Can you verify that both services are running under a different account?

Hi Tod,

To confirm, both services running as Domain Admin. BM using it's own built in web server, so IIS/App pool shouldn't play any part (well not that I can change).

Error remains. And I'm stuck.

Thanks for your help so far.

Just to update anyone reading this. Having spoken to support I was being a bit of an idiot.

When prompted to select from SVN (Step = Select Provider/File) it wants a file, not a folder.

So /Project/ will error, but if you pick a file in that folder all works.