New Reply

Last week I clean installed Windows Server 2016 with all updates, SQL Server 2017 with CU11, and ProGet 5.1.14. I configured ProGet feeds and bulk imported existing npm and NuGet packages. Everything was working fine.

Today I tried to upgrade to ProGet 5.1.15, which has just been released, via InedoHub. It seemed to succeed, however on closer inspection the ProGet Web Server standalone Windows service failed to start. Changing the service recovery to always restart the service just puts it into a crash loop where it continuously crashes just after service start.

Event log entries look like the following:

Faulting application name: ProGet.Service.exe, version:, time stamp: 0x5bca7f76
Faulting module name: KERNELBASE.dll, version: 10.0.14393.2580, time stamp: 0x5bbdace7
Exception code: 0xe0434352
Fault offset: 0x0000000000034048
Faulting process id: 0x1658
Faulting application start time: 0x01d46a5a1b885e2b
Faulting application path: C:\Program Files\ProGet\Service\ProGet.Service.exe
Faulting module path: C:\Windows\System32\KERNELBASE.dll
Report Id: 9ac7d4e2-f1fa-458a-8b47-06af94da3c80
Faulting package full name: 
Faulting package-relative application ID:

Product: ProGet
Version: 5.1.15

It's mostly database related, but you can run the service interactively

That was useful, thanks George! There was minimal output:

C:\Temp>"C:\Program Files\ProGet\Service\ProGet.Service.exe" run webonly
Attempting to use shared configuration for ProGet.
Shared configuration file loaded from C:\ProgramData\Inedo\SharedConfig\ProGet.config.

... but that was enough for me to check the shared config again and it turns out that part of the config had been overwritten with defaults. Specifically, I had previously changed the web port from 8624 to 80, and the upgrade reset it back to 8624:

<?xml version="1.0" encoding="utf-8"?>
  <ConnectionString>Data Source=localhost;Initial Catalog=ProGet;Integrated Security=False;User ID=****;Password=****</ConnectionString>
  <WebServer Enabled="true" Urls="http://*:8624/" />

Note that in order to do this, after the original install I had also reassigned the http port reservations since this was the only web server on the box:

netsh http add urlacl url=http://*:80/ user="NT AUTHORITY\NETWORK SERVICE"
netsh http delete urlacl url=http://*:8624/

Problem solved, but considering that the InedoHub has a configuration tab that lets you change the "web server urls", it's poor form that an upgrade overwrites this. Hopefully this gets fixed in future!

Hi Sean,

Sorry about the poor experience here. We've logged the issue as DH-4 in our issue tracker for investigation. I know a similar issue to this was fixed in the past.

Was 5.1.14 also installed using InedoHub, or was it using the traditional installer?

I installed 5.1.14 using InedoHub.

Thanks, Sean. We've updated the InedoHub to fix this. It shouldn't happen again going forward.


i am upgrade my old installlation 5.0.10 to Proget today.
And i run into the same issue. My Port customization has been overwritten in the C:\ProgramData\Inedo\SharedConfig\ProGet.config. I fixed it manually and now it works.

Answer Details


Post Reply