New Reply

So,

a few days ago everything was all good with TFS / Gitlab runners, even being able to push locally from my own machine to Proget.

I updated to the latest version and now everytime I try to upload a package I get a 403 (Forbidden).

I have seen earlier posts regarding scenarios where this can occur but my issue does not seem to match.

On the feed (any of them) I have NO API key. I specify a config file in which I have tried using a ClearTextPassword and Password for the credentials to use. I have tried multiple different credentials (in case there was something wrong). I have used my own account (I am an admin) and also a service account which has all the appropriate permissions given to it.

I have also tried to downgrade Proget, by uninstalling and then reinstalling the previous version and rolling back the database to the backup made prior to upgrade. I still have the same issue.

I have also tried different versions of Nuget.exe to push to Proget - from 3.4.3 (even earlier) to 4.9.2 (and many inbetween). Still no joy....

The error I get is as follows;-

WARNING: No API Key was provided and no API Key could be found for 'https://proget.gmgmt.dimensiondata.com/nuget/Aperture-R1.0'. To save an API Key for a
source use the 'setApiKey' command.
Pushing Aperture.Identity.Connector.Eventing.1.3.242.nupkg to 'https://proget.gmgmt.dimensiondata.com/nuget/Aperture-R1.0'...
PUT https://proget.gmgmt.dimensiondata.com/nuget/Aperture-R1.0/
Using credentials from config. UserName: xxxxxxxxx
The remote server indicated that the previous request was forbidden. Please provide credentials for: https://proget.gmgmt.dimensiondata.com/nuget/Apertur
e-R1.0

I have commented out the username but it is a valid domain account.

I have also created a builtin account and tried that too - but still all I get is

The remote server indicated that the previous request was forbidden

Anything else I could look at?

Product: BuildMaster
Version: 6.1.0

If it still doesn't work after you've granted anonymous to the feed, then one possibility is that you have WebDAV (caused from a Windows Update?), or a proxy server blocking the PUT request. I've seen that quite a bit..

Answer Details

Preview:

Post Reply