Support Q & A Home

Ask A Question

Anyone can ask or answer a question here, but our support engineers actively monitor your questions; we typically answer within a day or two.

Viewing Page 55 of 114 (20 questions out of 2275)

I get the following error when trying to use the "Set Release Notes" deployment task to send release notes to our Nuget repository when setting the From selection to "Resolved Issue Tracker Items" or "Both". It works OK when set to "Application Release Notes", but that doesn't send any of our Issue Tracking information to ProGet. This worked fine on BuildMaster version 4.8.6 using the TFS 2012 extension. I am now using BuildMaster version 4.9.7 and the new TFS extension.

Server Error in '/' Application.

Sequence contains no elements

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.InvalidOperationException: Sequence contains no elements

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

Stack Trace:

[InvalidOperationException: Sequence contains no elements]
System.Linq.Enumerable.First(IEnumerable1 source) +514 Inedo.BuildMasterExtensions.NuGet.SetReleaseNotesActionEditor.SetReleaseNotesActionEditor_ValidateBeforeSave(Object sender, ValidationEventArgs1 e) +211
Inedo.BuildMaster.Web.Controls.Extensions.ExtensionEditorBase1.OnValidateBeforeSave(ValidationEventArgs1 e) +225
Inedo.BuildMaster.Web.Controls.Extensions.ExtensionEditorBase1.DoValidateBeforeSave(TExtension extension) +123 Inedo.BuildMaster.Web.Controls.Extensions.Internal.ExtensionEditorHostBase1.<Initialize>b__49_0(Object s, EventArgs e) +154
System.Web.UI.WebControls.Button.OnClick(EventArgs e) +12338057
System.Web.UI.WebControls.Button.RaisePostBackEvent(String eventArgument) +155
System.Web.UI.WebControls.Button.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument) +18
System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument) +29
System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData) +49
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +3804

Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.34280

Product: BuildMaster
Version: 4.9.7



  1. Why does the file of a certain node package is not being displayed when I enter the package (like in the official npm registry) ?

Product: ProGet
Version: 4.0.6


Hello Proget.

When I trying install packages using nuget install It return error "Could not found package". but It works good on the web page.

Here are some error logs, at the admin page.

URL: http://localhost:7777/nuget/Frameworks/Packages(Id='Jit.Common.Debug',Version='')
Referrer: (not set)
User: (unknown)
User Agent: NuGet/ (Microsoft Windows NT 10.0.10586.0)
Stack trace:    위치: System.Net.HttpListenerResponse.set_StatusDescription(String value)
   위치: System.Web.HttpResponse.WriteHeaders()
   위치: System.Web.HttpResponse.Flush(Boolean finalFlush, Boolean async)
   위치: System.Web.HttpWriter.Write(String s)
   위치: Inedo.ProGet.WebApplication.SimpleHandlers.NuGet.ODataHandler.WriteError(HttpContext context, Int32 statusCode, String message, String fullMessage)
   위치: Inedo.ProGet.WebApplication.SimpleHandlers.NuGet.ODataHandler.<ProcessRequestAsync>d__11.MoveNext()
--- 예외가 throw된 이전 위치의 스택 추적 끝 ---
   위치: System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)
   위치: System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   위치: System.Web.TaskAsyncHelper.EndTask(IAsyncResult ar)
   위치: System.Web.HttpApplication.CallHandlerExecutionStep.OnAsyncHandlerCompletion(IAsyncResult ar)

Product: ProGet
Version: 4.0.6


Does Otter provide an API (e.g. REST API) that would enable managing configuration programmatically?


We needed to reinstall the product from the scratch, so when uninstalling it the option of removing the database was selected. However upon reinstallation, all settings were still there and we checked that the database was never deleted. Unistalled again and could see that the DB instance and file were still in place besides asking for their removal.

In order to produce a clean install we had to delete the Proget DB manually

Product: ProGet
Version: 4.0.5


When trying to create a connector for a chocolatey feed, when saving the system outputs an ASP.NET error page with the following information:
Exception Details: System.Data.SqlClient.SqlException: 547´16´0´Connectors_CreateOrUpdateConnector´39´The INSERT statement conflicted with the CHECK constraint "CK__Connectors__FeedType". The conflict occurred in database "ProGet", table "dbo.Connectors", column 'FeedType_Name'.

[SqlException (0x80131904): 547´16´0´Connectors_CreateOrUpdateConnector´39´The INSERT statement conflicted with the CHECK constraint "CK__Connectors__FeedType". The conflict occurred in database "ProGet", table "dbo.Connectors", column 'FeedType_Name'.] System.Data.SqlClient.SqlConnection.OnError(SqlException exception, Boolean breakConnection, Action´1 wrapCloseInAction) +388 System.Data.SqlClient.TdsParser.ThrowExceptionAndWarning(TdsParserStateObject stateObj, Boolean callerHasConnectionLock, Boolean asyncClose) +752 System.Data.SqlClient.TdsParser.TryRun(RunBehavior runBehavior, SqlCommand cmdHandler, SqlDataReader dataStream, BulkCopySimpleResultSet bulkCopyHandler, TdsParserStateObject stateObj, Boolean& dataReady) +4493 System.Data.SqlClient.SqlDataReader.TryConsumeMetaData() +117 System.Data.SqlClient.SqlDataReader.get_MetaData() +126 System.Data.SqlClient.SqlCommand.FinishExecuteReader(SqlDataReader ds, RunBehavior runBehavior, String resetOptionsString) +522 System.Data.SqlClient.SqlCommand.RunExecuteReaderTds(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, Boolean async, Int32 timeout, Task& task, Boolean asyncWrite, SqlDataReader ds) +3101 System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method, TaskCompletionSource´1 completion, Int32 timeout, Task& task, Boolean asyncWrite) +536 System.Data.SqlClient.SqlCommand.RunExecuteReader(CommandBehavior cmdBehavior, RunBehavior runBehavior, Boolean returnStream, String method) +104 System.Data.SqlClient.SqlCommand.ExecuteReader(CommandBehavior behavior, String method) +267 System.Data.SqlClient.SqlCommand.ExecuteDbDataReader(CommandBehavior behavior) +167 Inedo.Data.DatabaseContext.ExecuteInternal(String storedProcName, GenericDbParameter[] parameters) +206 Inedo.Data.DatabaseContext.ExecuteNonQuery(String storedProcName, GenericDbParameter[] parameters) +36 Inedo.ProGet.Data.Context.Connectors_CreateOrUpdateConnector(String FeedType_Name, String Connector_Name, String Connector_Url, String Filter_Csv, String User_Name, Byte[] Password_Bytes, Nullable´1 Timeout_Period, Nullable´1 Connector_Id) +750 Inedo.ProGet.WebApplication.Pages.Connectors.<>c__DisplayClass13_0.<CreateChildControls>b__1(Object s, EventArgs e) +746 Inedo.Web.PageFree.<>c__DisplayClass58_1.<ProcessPostBack>b__1(ControlCollection col) +166 Inedo.Web.PageFree.<>c__DisplayClass58_1.<ProcessPostBack>b__1(ControlCollection col) +193 Inedo.Web.PageFree.SimplePageBase.ProcessRequest(HttpContext context) +246 System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +712 System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +169

Product: ProGet
Version: 4.0.5


I'm facing several problems with the NPM connector. First of all and, as mentioned in question 4302 by chris the packages are simply not listed. I've run the FullNpmConnectorIndex scheduled task several times but still the same. The task runs fine, just outputing the warnings about versions property. However in the event log nothing get's registered (in v3.8.6 each package generated a message regarding whether it was created or updated).

Additionally, the IncrementalNpmConnectorIndex is failing with the following details:

DEBUG: Getting metadata from ERROR: Error processing JSON: System.Exception: uninclused at Inedo.ProGet.ScheduledTasks.Npm.NpmConnectorIndexScheduledTaskBase.<IndexConnectorAsync>d__1.MoveNext()

If you try to access a specific package page (using the /<feed>/<package>/<version> convention) you get part of the page but not the versions. And in the errors console you can see a classical An error occurred in the web application: Object reference not set to an instance of an object. with the following stack trace:

URL: http://myserver:81/0x44/ProGet.WebApplication/Inedo.ProGet.WebApplication.Pages.Npm.Feeds.NpmPackageVersionPage/GetFullPackageInfo Referrer: http://myserver:81/npm-feeds/mynpm/npm/3.7.2 User: MorpheAdmin User Agent: Mozilla/5.0 (Windows NT 6.3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/48.0.2564.109 Safari/537.36 Stack trace: at Inedo.ProGet.WebApplication.Pages.Npm.Feeds.NpmPackageVersionPage.<GetFullPackageInfo>d__7.MoveNext() --- End of stack trace from previous location where exception was thrown --- at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task) at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) at System.Runtime.CompilerServices.TaskAwaiter´1.GetResult() at Inedo.Web.Handlers.JsonDataHttpHandler.AsyncHandler.<ProcessRequestAsync>d__6.MoveNext() --- End of stack trace from previous location where exception was thrown --- at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task) at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) at System.Web.TaskAsyncHelper.EndTask(IAsyncResult ar) at System.Web.HttpApplication.CallHandlerExecutionStep.OnAsyncHandlerCompletion(IAsyncResult ar)

Finally, when you try to install anything from the npm feed in proget you end up with errors regarding no compatible version found (when you don't specify a version correctly) or version not found (when you target a specific version).

At this point the NPM feed is totally useless, so I'd really apreciate some insight on what's going on and what can be done to solve it.

Product: ProGet
Version: 4.0.5


I created a user without groups as I had not yet created the group I needed to add them to.

I created a group and if I try to add the user from the group panel, it won't add them. I pick their name, it appears in the Group Members box. Clicking "Save" gives no errors - but the page does not update with their name and reclicking the group does not show them in it.

If I open the user object, I can pick the group, (leave password as "unchanged") - when I clck "Save" - then "Required" appears under the "Password" Prompt. If I reenter a temporary password and press "Save", then the dialog refreshes with username blanked out and of course there is no way forward from that because the username is not an editable field because this was an existing user.

I suspect this may only happen when a user is initially created with NO GROUP at all.

Product: ProGet
Version: 4.0.6


Today I've noticed that the nuget connector is failing with a 400 - Bad Request. It seems to be something on side, as this is failing both for v4.0.5 and 3.8.6 with the same configuration. And I'm certain that until a few days ago there where no problems (at least with the v3.8.6).

I've fiddled a little with the Filter and seems the problem is that api is not accepting more than 13 criterias. We have a very comprehensive list of allowed packages and as soon as we include more than 13 items it starts failing. For example:

  • Antlr
  • bootstrap
  • CommonServiceLocator
  • Dapper
  • EntityFramework
  • jQuery
  • jQuery.Validation
  • log4net
  • Microsoft.AspNet.*
  • Microsoft.Bcl.*
  • Microsoft.Exchange.WebServices
  • Microsoft.jQuery.Unobtrusive.Validation
  • Microsoft.Net.Http
  • Microsoft.Web.Infrastructure

If you remove any of those 14, it works, otherwise the feed page will show

There was an error with a connector:

The remote server returned an error: (400) Bad Request.

Just in case it was a matter of request length, I've tried concatenating two of the names in the same line but that works fine. I still have to check with the networking team just in case the firewall is scrambling the requests but shouldnt be the case.

Has anyone experienced something like that?

Product: ProGet
Version: 4.0.5



Does proget has REST API support, so that i can write my custom scripts to get data?


Product: ProGet
Version: 4.0.6


Just started to use version 4.0.6, so far we've been doing som POC on 3.8.6 and everything was fine. But with the new version, after deleting the default feed so to start creating the custom ones, the /feeds endpoint always fails with the following exception:

An error occurred in the web application: Exception of type 'Inedo.ProGet.WebApplication.SecuredTaskDeniedException' was thrown.

URL: http://eccompilars1:81/feeds
Referrer: http://eccompilars1:81/connectors

User: Admin

User Agent: Mozilla/5.0 (Windows NT 6.3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/48.0.2564.109 Safari/537.36

Stack trace: at Inedo.ProGet.WebApplication.Pages.Feeds.FeedsOverviewPage.ValidatePrivileges()

at Inedo.ProGet.WebApplication.ProGetHttpModule.ValidatePrivileges(HttpApplication app, IHttpHandler handler)

at Inedo.ProGet.WebApplication.ProGetHttpModule.PostMapRequestHandler(HttpApplication app)

at System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()

at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

Has anyone seen something similar? Just raised a support request but maybe someone in the community has seen it

Product: ProGet
Version: 4.0.6


This is a list of potential issues in the latest version.

  • If I try to create a feed for either chocolatey, npm, or bower, and have the "create default connector" checked, it never creates the connector.
  • If I try to add a connector from the feed manage page for Chocolatey, it creates a connector of type Nuget. Note this is new in 4.0.6, 4.0.5 was fine.
  • NPM feeds do not list remote packages (through a connector as nuget, chocolatey, or bower). I don't know if this is expected behavior (due to NPM's APIs or the nature of the json from the registry).
  • When I create a retention rule and uncheck all of the deletion rules, I cannot save due to a message that this would delete all packages. While I agree with the utility of the rule to be nil at this point, isn't the net affect the opposite? If it doesn't have any conditions on when it should delete, why would it delete packages?
  • When viewing a package, if I click on one of its dependencies, I go back to the listing page (for the feed). The URL appears to be correct initially before a redirect. Ideally the URL fragment would at least populate the search box if the package doesn't exist.
  • If I pull in a Nuget package, shouldn't it automatically pull in all dependencies (all the way down the tree)?

That is it for now. Thank you in advance!

Product: ProGet
Version: 4.0.6


I'm currently using the Free version.

Is there a way to automatically pull in cached packages into ProGet?

The use case is as follows:

  • Create a new project from VS based on a template
  • Restore packages (VS 2015, ASP.NET 5 Tooling bits)
  • Go into ProGet and pull in recently cached packages

The problem is that when I go into ProGet, none of the retrieved packages are pulled in, instead they are all cached. This is perfectly fine behavior, but if I desire for all of those packages from the template to be pulled in, I'd have to manually add the package.
Furthermore, there is no filtered view to be able to see the cached packages.

Assuming my conclusions are correct, I'd suggest the following:

  1. Be able to sort/filter by package "status" in a feed (remote, cached, pulled-in).
  2. Be able to pull in the package on the package list page

Product: ProGet
Version: 4.0.6


(Crossposting from StackOverflow:

Note: I'm very new to Otter script so if this is simple then I apologize in advance!

Here is the main nugget of the script I've got now:

    Name: LonTest,
    Credentials: SVC_LonTest1,
    AutoStart: false,
    QueueLength: 1500,
    Pipeline: Integrated,
    Runtime: v4.0

Otter does create the app pool, but it is always started even though the docs seem to indicate that "AutoStart: false" should change the value of the "Start application pool immediately" checkbox in the Basic Settings of the app pool.

What do I need to do here to make sure that value is unchecked and that the app pool is initially stopped when it is created?

PS: Otter is not an option in the list of products on this forum ;)


I have the following structure:


I have created two nupkg files.
a.nupkg containing binaries bin\a.lib, bin\a.pdb
a-symbols.nupkg containing sources: src\a.cpp

I create a new project and add a package a.nupkg .
Now I want to debug and step into sources.
This doesn't work.
Visual Studio doesn't download the symbols package at all.

However this works in case of dll file for instance a.dll.
That way Visual Studio downloads the symbols and can step into source.

What is the proper way of making symbols package for library ?

Product: ProGet
Version: 4.0.6



We are testing the Proget in our team. I am very new to this.

We have our own in house nuget server, I have added the connector and configured the nuget server url, where the connectors shows healthy but its not showing the number of packages.

"citrixnuget Healthy (as of 2/12/2016 3:14 AM) unknown allow all packages"

Also, when i click on the feed which is configured with this connector, i am getting the following error.

"There was an error with a connector:The remote server returned an error: (404) Not Found."

Please let us know what could be the issue.


Product: ProGet
Version: 4.0.5


I saw on one of your emails that there are performance improvements in 4.0, can you go into more detail on those?

Product: ProGet
Version: 3.8.6


Update This has been fixed in ProGet 4.0.6

I just upgraded to Proget 4.0.5 and I now have periodic issue with it. At some point it throws the following error and it is only recoverable with an IIS app-pool recycle (IIS have yellow sceen of death showing the same error and nuget Api is unreachable)...

Image Text

The underlying error appears to be:

Timeout expired. The timeout period elapsed prior to obtaining a connection from the pool. This may have occurred because all pooled connections were in use and max pool size was reached.

I don't know what exactly is causing this but it seems to be proportional to the usage of the website...

Product: ProGet
Version: 4.0.5



I have a frustrating problem i'm having hard time understand.

I have a pretty easy deployment plan, that creates a bat file that calls other bat files that are on the server already:

this is bat file being created:

call script1.bat           
call script2.bat     
call script3.bat        
call script4.bat

The next step is running this bat file.
All the script are running perfectly fine. but when it finishes the last script (script4.bat) it's just stuck there. not doing anything for infinite time.

I also added "Exit" command in the script4.bat script and yet it doesn't go back to the mother script and finished the deployment?

Why? What am i doing wrong?


Product: BuildMaster
Version: 4.9.6



I was trying to upgrade our 3.8 version of ProGet to the latest version. Our current install is in Azure and is connected to a remote SQL server also in Azure. Simply running the executable to begin install, towards the end of extraction I get and error shown below. I have tried running it as admin, running it in various compatibility settings, using compatibility assistant, clicking properties -> Unblock button. In all cases the below error is displayed and OS would not allow me to install the update. Please note, I used a Small Installer.

Problem signature:

  • Problem Event Name: CLR20r3
  • Problem Signature 01: ProGet.Setup.exe
  • Problem Signature 02:
  • Problem Signature 03: 56b5398b
  • Problem Signature 04: System.Data
  • Problem Signature 05: 4.6.1055.0
  • Problem Signature 06: 563c13ab
  • Problem Signature 07: 1d21
  • Problem Signature 08: 27
  • Problem Signature 09: System.Data.SqlClient.Sql
  • OS Version: 6.3.9600.
  • Locale ID: 1033

Read our privacy statement online:

If the online privacy statement is not available, please read our privacy statement offline:

Product: ProGet
Version: 4.0.5

Ask A Question
Page: 1 50 51 52 53 55 57 58 59 60 114