Support Q & A Home

Ask A Question

Anyone can ask or answer a question here, but our support engineers actively monitor your questions; we typically answer within a day or two.

Filter
Viewing Page 87 of 108 (20 questions out of 2142)
4
replies

Hello,

I just wanted to report a possible bug with the build agent’s stability. I don’t know what upgrade seemed to have introduced this, but our build agents randomly terminate connections. It could be in the middle of a build and the connection just closes. It appears to happen at random times, even after successfully connecting and already having executed a previous build step. The only fix I know is to login to the affected target server and restart the build agent service. Sometimes retrying the last failed step works, but most of the time it doesn’t, so I’ve trained myself to simply login and restart the agent service and everything will work for a while. I believe this happened a couple versions ago—sorry I don’t have better specifics. I figured it was temporary, but it just hasn’t gone away. I’d be happy to provide additional details if requested.

Our Environment:

  • The build agents are running on both Windows Server 2012 and 2012 R2
  • The build controller is running on Windows Server 2012
  • The servers are not on the same network (the build agents have ports accessible via the Internet, * the build controller communicates via those public ports)
  • The build agents utilize the “Agent.SecurityToken” app setting (we were previously using SSL also, * but around the same time this became a problem, SSL seems to have stopped working)
  • All build agents are configured as self-hosted TCP agents

Sample Error:

Logged	3/13/2014 3:42:07 PM
Message	[Exec #258] Unhandled exception: System.InvalidOperationException: The connection was closed unexpectedly.
at Inedo.BuildMaster.Extensibility.Agents.Tcp.TcpAgentClient.SendHandshake(String securityToken)
at Inedo.BuildMaster.Extensibility.Agents.Tcp.TcpAgentClientPool.CreateClient(Endpoint endpoint)
at Inedo.BuildMaster.Extensibility.Agents.ClientConnectionPool`2.AcquireConnection(TEndpoint endpoint)
at Inedo.BuildMaster.Extensibility.Agents.Tcp.TcpAgentClientPool.GetClient(String hostName, Int32 port, String securityToken, Boolean ssl, Boolean ignoreCertificateErrors)
at Inedo.BuildMaster.Extensibility.Agents.Tcp.TcpAgent.GetClient()
at Inedo.BuildMaster.Extensibility.Agents.Tcp.TcpAgent.Inedo.BuildMaster.Extensibility.Agents.IRemoteMethodExecuter.InvokeMethod(MethodBase method, Object instance, Object[] parameters)
at Inedo.BuildMaster.Extensibility.Agents.AgentExtensions.InvokeFunc[TResult](IRemoteMethodExecuter agent, Func`1 method)
at System.Lazy`1.CreateValue()
at System.Lazy`1.LazyInitValue()
at Inedo.BuildMaster.Extensibility.Agents.Tcp.TcpAgent.<.ctor>b__2()
at Inedo.BuildMaster.Extensibility.Agents.RemoteFileOperationsExecuter.Inedo.BuildMaster.Extensibility.Agents.IFileOperationsExecuter.GetBaseWorkingDirectory()
at Inedo.BuildMaster.Windows.ServiceApplication.PlanExecuter.AgentBasedActionExecuter.InitializeRemoteConfiguration()
at Inedo.BuildMaster.Windows.ServiceApplication.PlanExecuter.AgentBasedActionExecuter.Initialize()
at Inedo.BuildMaster.Windows.ServiceApplication.PlanExecuter.ExecutingPlan.ExecutePlan()
Stack Trace	at System.Environment.GetStackTrace(Exception e, Boolean needFileInfo)
at System.Environment.get_StackTrace()
at Inedo.BuildMaster.Diagnostics.DatabaseErrorMessenger.Inedo.Diagnostics.IMessenger.Message(IMessage message)
at Inedo.Diagnostics.Logger.Message(MessageLevel messageLevel, String message)
at Inedo.BuildMaster.Windows.ServiceApplication.PlanExecuter.ExecutingPlan.ExecutePlan()
at System.Threading.Tasks.Task.Execute()
at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.Tasks.Task.ExecuteWithThreadLocal(Task& currentTaskSlot)
at System.Threading.Tasks.Task.ExecuteEntry(Boolean bPreventDoubleExecution)
at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state)
at System.Threading.ThreadHelper.ThreadStart(Object obj)

Product: BuildMaster
Version: 4.1.5

1
replies

How do you connect Proget to LDAP? I have turned on Windows authentication for the IIS site I have set Proget up on. I dont know what to do next. I can see that in the settings I can set LDAP to true but when I do that I can no longer get into proget. So something is not connecting up what am I missing here? Thanks.

Product: ProGet
Version: 2.2.13

1
replies

I have encountered a weird issue with the NUnit extension. I have included a section of the log file below.

I was wondering that have I misconfigured something is this a possible bug?

I think that the error is caused by the decimal symbol which is in Finnish locale comma (,) and not dot (.) and I would guess that the issue is caused by the double.Parse() -method in the NUnitAppAction.cs file on line 128.
https://github.com/Inedo/bmx-nunit/blob/master/NUnitAppAction.cs

Here is the log output for the NUnit action:

<pre> Action 3: Run NUnit Unit Tests on src\CmdParser.Tests\bin\Debug\Orchidea.CmdParser.Tests.dll Running unit tests... NUnit version 2.5.10.11092 Copyright (C) 2002-2009 Charlie Poole. Copyright (C) 2002-2004 James W. Newkirk, Michael C. Two, Alexei A. Vorontsov. Copyright (C) 2000-2002 Philip Craig. All Rights Reserved. Runtime Environment - OS Version: Microsoft Windows NT 6.1.7601 Service Pack 1 CLR Version: 2.0.50727.5477 ( Net 2.0 ) ProcessModel: Default DomainUsage: Single Execution Runtime: Default ............................ Tests run: 28, Errors: 0, Failures: 0, Inconclusive: 0, Time: 0,8421354 seconds Not run: 0, Invalid: 0, Ignored: 0, Skipped: 0 An unhandled exception occurred while executing this action: System.FormatException: Input string was not in a correct format. at System.Number.ParseDouble(String value, NumberStyles options, NumberFormatInfo numfmt) at Inedo.BuildMasterExtensions.NUnit.NUnitAppAction.RunTests() at Inedo.BuildMaster.Extensibility.Actions.Testing.UnitTestActionBase.Execute() at Inedo.BuildMaster.Extensibility.Actions.ActionBase.ExecuteInternal(IActionExecutionContext context, ExtensionConfigurerBase extensionConfigurer, Boolean resumeNextOnError, Boolean logErrorsAsWarnings) </pre>

Product: BuildMaster
Version: 4.1.5

1
replies

Is it possible to add a "show/include Prerelease" button in the Feeds on the webui?

Product: ProGet
Version: 2.2.13

1
replies

Is it possible to know and/or control the order in which SQL change scripts will execute during a promotion? I don't see any way to control the execution order. Do they always execute in the order they are listed on applications/{#}/change-scripts? If so, is that order determined by the order in which they are uploaded?

As a workaround, we are including all our SQL scripts in one big script, but we would like to be able to sequence multiple scripts arbitrarily (e.g., by drag and drop ordering in the list).

Product: BuildMaster
Version: 4.1.5

1
replies

Right now i selected version 2.2.0 just for test...
Lets see what version the post will have at the bottom ;)

Product: ProGet
Version: 2.2.13

16
replies

I have a proget feed which is configured to work only with authenticated users.

In visual studio when i setup this feed, in order to show me the package list, it asks for a username a password, which i provide. The list then is displayed correctly. But, when i hit install on a specific package, i get this:

Image Text

This error is also occurring in octopus deploy application. Same thing happens there, the package is listed, but the installation fails with 403!

So visual studio and octopus deploy both have the same behavior, this makes me think that the problem lies with proget. Can anyone reproduce this?

Thanks!!

Product: ProGet
Version: 2.2.13

1
replies

I want to have this cleared out, to avoid nasty surprises later on...

I add nuget packages (and also delete them in some cases) directly in the filesystem (inside the feed's storage folder).

When i do that, proget seems to be working ok, reporting back the existing packages correctly (Assuming caching is disabled for the feed).

So is there anything i need to be aware of? Is this process considered safe?

thanks in advance!

Product: ProGet
Version: 2.2.13

3
replies

I have an existing package on ProGet. I have created an updated package for this assembly, with a new version, and successfully pushed it to ProGet. However, the new version does not appear in ProGet. I went from version 1.0.0.0 to 1.0.1.0.

Product: ProGet
Version: 2.2.13

2
replies

We've been running great with buildmaster for a few weeks. Today I pushed out a code with a bug, so we had our 1st build failure. I fixed the code, comitted to TFS, and forced a new build.
However now we keep getting this error:

Error

Done building project "CommonClassLib.csproj" -- FAILED.

Done building project "StPlatformWebRole.csproj" -- FAILED.
An unhandled exception occurred while executing this action: System.InvalidOperationException: There are no files in the expected output directory: C:\BuildMaster_SVCTMP_A3_S7\TMP\Debug\Package\PackageTmp at Inedo.BuildMaster.Extensibility.Actions.RemoteCommandExecution.RemoteCommandExecuter.ExecuteCommand(RemoteActionBase remoteAction, String commandName, String[] commandArgs) at Inedo.BuildMaster.Extensibility.Agents.Local.LocalAgent.Inedo.BuildMaster.Extensibility.Agents.IRemoteCommandExecuter.ExecuteCommand(RemoteActionBase action, String commandName, String[] commandArgs) at Inedo.BuildMaster.Extensibility.Actions.RemoteActionBase.ExecuteRemoteCommand(String name, String[] args) at Inedo.BuildMaster.Extensibility.Actions.ActionBase.ExecuteInternal(IActionExecutionContext context, ExtensionConfigurerBase extensionConfigurer, Boolean resumeNextOnError, Boolean logErrorsAsWarnings)

Product: BuildMaster
Version: 4.1.5

1
replies

We added the "Convert Project References" step to the Deployment Plan for the referenced assemblies, but we are still getting errors on the MSBuild. There errors are like the following:

error BC30002: Type 'DataLayerException' is not defined.
warning BC40056: Namespace or type specified in the Imports 'Microsoft.Practices.EnterpriseLibrary.Data' doesn't contain any public member or cannot be found.

What else can we do to fix these errors? The .NET web application runs successfully on a local machine, but will not build successfully from within BuildMaster.

Any assistance would be greatly appreciated.

Product: BuildMaster
Version: 4.1.5

3
replies

On a vanilla install of Proget, where it should be hosted in IIS 7.5
the site fails immediately with the following error:

Handler "Wildcard64" has a bad module "IsapiModule" in its module list

Which relates to the following entry in the config:

<handlers>
      <add name="Wildcard32" path="*" verb="*" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework\v4.0.30319\aspnet_isapi.dll" resourceType="Unspecified" requireAccess="None" preCondition="classicMode,runtimeVersionv4.0,bitness32" />
      <add name="Wildcard64" path="*" verb="*" modules="IsapiModule" scriptProcessor="%windir%\Microsoft.NET\Framework64\v4.0.30319\aspnet_isapi.dll" resourceType="Unspecified" requireAccess="None" preCondition="classicMode,runtimeVersionv4.0,bitness64" />
    </handlers>

I have confirmed that the dll's defined in the handlers section does exist.
How can this issue be solved?

Product: ProGet
Version: 2.2.13

1
replies

Hi

We are trying to get some info around how we can interface with the BuildMaster Agent to monitor it's state before, during & after the deployment execution. Is the a way we can achieve this as the WS (ExecuteAgentCommand) call doesn't seem to contain any methods to check this?

Thanks

Kp

Product: BuildMaster
Version: 4.1.5

2
replies

Hi,

We had multiple Automatic builds setup that were working previously which now have stopped working. I was able to set the Automatic builds from Mercurial using the earlier version 4.0.8 and the builds were triggered once the changes were pushed. We upgraded to latest version (4.1.5) last week.
I noticed today that the Automatic builds were not happening and suspected its due to the upgrade. So I reverted to the old version but still the Automatic builds are not working. The builds are not getting triggered automatically after the Quite Period(tried with setting it to zero as well).

Thanks,
Srivatsa

Product: BuildMaster
Version: 4.1.5

7
replies

Is there a size limit on SQL change scripts? I have a SQL script that is just under 6KB, and when I try to add it to my application I get an HTTP 500 when I click "Save Change Script". Other scripts seem to be fine.

Product: BuildMaster
Version: 4.1.5

5
replies

Let's say I have two BuildMaster applications. One is the primary application, and one is enterprise service bus code (ESB). The primary application and the ESB are versioned and deployed independently, but sometimes the primary application requires an ESB deployment. This is where I want to use imported deployables. My thought is that on a given release of the primary application, I can choose whether or not to include that ESB deployable.

I imported the ESB deployable into the primary application. Now what? How do I make use of this imported deployable? Do I add a step to the primary application's deployment plan to deploy the ESB artifact? Should I create linked action groups in the primary application's deployment plan that are linked to the ones in the ESB deployment plan?

Am I on the right track?

Product: BuildMaster
Version: 4.1.5

1
replies

When we have more than 5 predicates we can no longer add another predicate test as the URL sent to the server is too long (> 2700 characters) and you get an http 401 error.

When will this bug be fixed and how can we edit the predicate by direct SQL ?

Product: BuildMaster
Version: 4.1.5

1
replies

Hi We are running BuildMaster 4.1.4 with SQL Express 11.0.2100 and every few days (after many Buildmaster jobs are run) the SQLserevr process is using > 1.2GBytes of memory and we need to restart the buildmaster service.

Do you have any info on how we can fix this issue.

Product: BuildMaster
Version: 4.1.4

3
replies

Trying to utilize the New .Net Application Wizard for a .sln file in source control that we have in place. The solution file has two projects, one of which is a dependency of the other. Our build order and dependencies are setup correctly in the solution, but when we go to the wizard to add the applications, after detecting the two applications giving us the checkboxes, selecting the class library that is the first in the build order references a relative path in source control (based on the location in the team projects) and gives us a Server 500 error. I've seen this very relative path mentioned in the Event Viewer on the server for the ASP.Net error when Buildmaster failed.

My question is thus:

Is the issue with our solution file, with the TFS extension (or Windows-SDK extension) or should we just avoid using this wizard altogether?

Any help is much appreciated.

Product: BuildMaster
Version: 4.1.4

1
replies

I noticed in the new release notes: BM-1381 - Allow users to specify an alternate connection string for upgrades.

Can this be used to migrate the Buildmaster Database to be hosted by a different Sql Server? Do you have a procedure or some documentation on migrating the database to an alternative server?

Thanks

Product: BuildMaster
Version: 4.1.4

Ask A Question
Page: 1 82 83 84 85 87 89 90 91 92 108