Otter 1.7.4 Has Been Released

We just shipped Otter 1.7.4. It's a maintenance release of Otter 1.7 which means that there is minimal risk to upgrading from an earlier 1.7. However, if you're planning to upgrade from a version prior to 1.7, make sure to read the appropriate upgrade notes.

To install or upgrade, simply download Otter and run the installer.

Here's what we changed between 1.7.3 and 1.7.4:

  • OT-186 - FIX: Hide "create raft item" buttons when browsing a read-only raft
  • OT-185 - FIX: Git raft repositories show the current time as the "last update" time for all items
  • OT-184 - FIX: Git raft repositories cannot be created from an empty repository
  • OT-183 - FIX: Git raft repositories do not update from remote changes
  • OT-182 - FIX: Create Job dialogue does not keep selections if there are multiple rafts
  • OT-181 - FIX: Security vulnerability for rafts (CVE-2017-15607)
  • OT-176 - Added more information about privilege errors to the error log.

To learn more about how we distinguish between major, minor, and maintenance releases, make sure to check out KB#1059 - When should I update?