ProGet 5.0.11 Has Been Released

We just shipped ProGet 5.0.11. It's a maintenance release of ProGet 5.0 which means that there is minimal risk to upgrading from an earlier 5.0. However, if you're planning to upgrade from a version prior to 5.0, make sure to read the appropriate upgrade notes.

To install or upgrade, simply download ProGet and run the installer.

Here's what we changed between 5.0.10 and 5.0.11:

  • PG-1253 - FIX: Integrated authentication warning is always displayed on IIS when integrated authentication is disabled
  • PG-1252 - FIX: NuGet connectors read metadata in a case-sensitive manner in some cases
  • PG-1251 - FIX: long version numbers in the sidebar overlap the main content of the package version page
  • PG-1250 - FIX: Package version page is inaccessible to administrators if the package license URL is an empty string.
  • PG-1249 - Improve NuGet error messages
  • PG-1243 - Improve pending execution message
  • PG-1242 - Improve messaging, navigation for service status page
  • PG-1228 - FIX: upack "packages" endpoint does not filter by group if no package name is given
  • PG-1226 - Add npm unpublish API endpoint
  • PG-1254 - Add Support for using api keys as npm authentication tokens
  • PG-1248 - Rename "Message Center" to "Diagnostic Center" and allow the log message verbosity to be configured on that page
  • PG-1247 - FIX: Feed endpoint 400s and 404s should be logged at debug level instead of error to prevent filling the diagnostic center
  • PG-1244 - Display SHA1 package hashes if available
  • PG-1240 - Display additional metadata on universal packages
  • PG-1238 - Use chunking for very large packages during feed sync operations
  • PG-1237 - FIX: Feed replication should not buffer entire request and response streams for packages
  • PG-1236 - FIX: Only one feed replication job per feed should be allowed to run at a time (v5 only)
  • PG-1232 - FIX: Feed replication may timeout with large packages
  • PG-1231 - FIX: Errors encountered while deleting NuGet packages from the UI are not shown
  • PG-1230 - FIX: (Linux only) Database error when creating or editing a variable
  • PG-1229 - FIX: integrated authentication warning appears when not using IIS
  • PG-1227 - FIX: Legacy LDAP User Directory Doesn't Show Default Values

To learn more about how we distinguish between major, minor, and maintenance releases, make sure to check out KB#1059 - When should I update?