Support Q & A Home

Ask A Question

Anyone can ask or answer a question here, but our support engineers actively monitor your questions; we typically answer within a day or two.

Filter
Viewing Page 1 of 128 (20 questions out of 2554)
0
replies

Hello, I am trying to copy files from a UNC path (I have access to) to a group of servers. I am copying the latest windows security quality monthly rollup patch before we can install the SCCM client. This has to be done per our security policy. I have tried copy file and transfer file, neither seem to do anything. I guess I could do a psensure and do a get-hotfix to see if they are installed and see if I can copy and install from there? I am doing this with Powershell Agentless, and the creditials used are any admin on the server and full control on the nas folder.

Product: Otter
Version: 2.1.0

3
replies

Hi,

After last updates Delete-Files stopped to work properly...
Any directory could be specified, but it looks like it waits for ServerPath on FTP server(!??).

    Unhandled exception: System.InvalidOperationException: FTP server not specified.
   at Inedo.Extensions.FTP.Operations.FtpOperationBase.CreateRequest(String path) in C:\projects\inedox-ftp\FTP\InedoExtension\Operations\FtpOperationBase.cs:line 109
   at Inedo.Extensions.FTP.Operations.FtpDeleteOperation.<ExecuteAsync>d__7.MoveNext() in C:\projects\inedox-ftp\FTP\InedoExtension\Operations\FtpDeleteOperation.cs:line 34
--- End of stack trace from previous location where exception was thrown ---
   at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
   at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
   at Inedo.BuildMaster.Windows.ServiceApplication.Executions.PlanExecuter.DeploymentPlanExecuter.<Inedo-ExecutionEngine-Executer-IExecutionHostEnvironment-ExecuteActionAsync>d__25.MoveNext()

Could you clarify?

Product: BuildMaster
Version: 6.0.11

2
replies

I'm currently running otter 2.0.7, and trying to set up my git raft, however, I don't have git under raft type, do I need to install a newer version

Product: Otter
Version: 2.0.7

0
replies

Hello,

We are seeing performance issues when loading the dashboard page in ProGet. Specifically loading the "DashboardFeeds" view in the database is taking anywhere from 15 to 30+ seconds to run. Sometimes the application will timeout waiting for this to happen.

We have ProGet configured with domain authentication and are only giving permissions (including read) to specific users / groups. To minimize what information unauthenticated users see we have the advanced option "Web.HideHomePageFromAnonymousUser" enabled. Despite this, hitting the root of the application without credentials seems to build the dashboard in the background before redirecting to /log-in. If multiple people (authenticated or not) try and load the dashboard at the same time then the likelihood of the application timing out requests increases.

Is there any way to prevent the application from doing the expensive dashboard build operation until after the credentials have been checked?

Would upgrading to the latest version likely help the performance at all? (Noticing a closed issue around SQL locking in the release notes..) .. or do we need likely need to throw more resources at the database server to make the page render in a reasonable amount of time?

Thanks,

Martin

Product: ProGet
Version: 5.1.8

0
replies

Hello,

when trying to install the current version of proget (custom MSql Server) I experience the following error during installation: "Cannot add the principal 'NT AUTHORITY\NETWORK SERVICE', because it does not exist or you do not have permission." This happens after the successful creation of the database but stop the installation process. What can I do?

Best regards,
Peter

Product: ProGet
Version: 5.1.16

0
replies

After upgrading to version 5.1.15, the docker disappeared from the main page. On the feeds it is there, however, the number of downloads is 0. The connection to https to the site has disappeared. Proget uses iis. Please tell me what's the problem?

Product: ProGet
Version: 5.1.15

0
replies

0、操作系统:win10, 64位
1、ps命令: dbupdater.exe . "Data Source=localhost; Initial Catalog=P
roGet; Integrated Security=true;"
2、错误:
dbupdater.exe : 无法将“dbupdater.exe”项识别为 cmdlet、函数、脚本文件或可运行程序的名称。请检查名称的拼写,如果包括路
径,请确保路径正确,然后再试一次。
所在位置 行:1 字符: 1

  • dbupdater.exe . "Data Source=localhost; Initial Catalog=ProGet; Integ ...
  •   + CategoryInfo          : ObjectNotFound: (dbupdater.exe:String) [], CommandNotFoundException
      + FullyQualifiedErrorId : CommandNotFoundException
    
    
    

Suggestion [3,General]: 找不到命令 dbupdater.exe,但它确实存在于当前位置。默认情况下,Windows PowerShell 不会从当前位置 加载命令。如果信任此命令,请改为键入“.\dbupdater.exe”。有关详细信息,请参阅 "get-help about_Command_Precedence"。

Product: BuildMaster
Version: 6.0.11

1
replies

Hello,

I am using ProGet 5.1.15 and the Inedo Core Extension 1.0.9. I'd like to define privileges on a group basis.

When I use custom created AD groups, everything works fine. But somehow the groups "Domain Users" and "Users" does not work, although my user is member of those groups. As soon as I add another ad-hoc-created group, my user is also member of, it works. Only the groups I mentioned earlier do not work.

I have also tried to test using "Test get user" in the user directory settings, but the test claims that I am not part of "Domain Users", but I am.

Product: ProGet
Version: 5.1.15

4
replies

I'm not sure when this stopped working as I didn't hit until I went back to an older app that uses it but it used to work.
However, I also am working on a new project which is using multi-branch building on Jenkins which also uses folders that represent the branch names as the job names and the Jenkins extension for BuildMaster cannot find the jobs.

In jenkins the path to the job taking the URL is "https://buildserver/job/project/job/jobname/" so in BuildMaster this was set as project/job/jobname which used to work but now does not.
I've tried using just the project and also tried how Jenkins has it in the JOB_NAME variable in Jenkins, project\jobname , but those do not work either.

Just wanted to check if this is indeed a bug or just a format change? If a format change could you please let me know what that new format should be.

Additional info:
Jenkins - 2.138.2
BuildMaster Jenkins extension - 1.0.1

Product: BuildMaster
Version: 6.0.10

1
replies

Hi,
we push new nuget packages via nuget.exe to proget.
when I go to the nuget feed on the server the package is there as it should be.
When I want to build (via bamboo) or upgrade packages via visual studio the nuget cache of the proget server is requested, but the newest version of the nuget package is not found.
When I clear the nuget cache via command line on the nuget server "nuget locals all -clear" the build is working and the newest nuget packages are downloaded.

If a new nuget package is pushed afterwards it doesnt appear in the cache again.
How to overcome this problem

Product: BuildMaster
Version: 5.7.0

1
replies

What is the best way to verify that the variable exists? I.e. if variable can't be resolved the execution fails, but most of the time we don't want to fail it, we just need to continue with some default value provided in that plan.
So far the only workaround I found is to run the check in try-catch block and assign the default this way, but it still produces a warning in the plan execution. Ideally we just need to assign the default value if the variable can't be resolved, without any errors or warnings.

set $BuildTestsFlag = "";
    try
    {
        set $BuildTestsFlag = $BuildTests;
        Log-Information BuildTests variable is set to $BuildTestsFlag;
    }
    catch
    {
        Log-Information BuildTests variable is not defined so we will not build tests;
    }

Product: BuildMaster
Version: 5.8.2

2
replies

Hi,
Is it possible to get an error (or something else than OK) response from ProGet when package is being pushed to the feed with a version that already exists?

I have read Improve NuGet error messages and could not get any response mentioned there.

This is especially needed when updated packages are being published from Azure DevOps (VSTS) builds to the feed.

Product: BuildMaster
Version: 6.0.11

2
replies

I'm attempting to resolve services not being present by running installers so I put "Start-Service" in Try/Catch block but Otter seems to treat Service not existing as Info warning and doesn't execute the catch block. How can I force Otter that Service not existing is error that needs to be resolved by running catch block?

Product: Otter
Version: 2.0.13

1
replies

Hi there,

Is it possible to set up a connector pointing to an NPM registry hosted on VSTS / Azure DevOps?

There is no way in the ProGet user interface to provide an authorisation token as you would in an .npmrc file so I have entered my Microsoft account credentials that I can use to log in to the server.

I have entered the following connector URL:-

https://<server-address>/_packaging/<feed-name>/npm/registry/

Is this scenario supported?

Product: ProGet
Version: 5.1.7

2
replies

Following is the excerpt from any standard Assembly info file.

// Version information for an Solution consists of the following four values:
//
//      Major Version
//      Minor Version 
//      Build Number
//      Revision
//
// You can specify all the values or you can default the Revision and Build Numbers 
// by using the '*' as shown below:

[assembly: AssemblyVersion("2.14.6878.*")]

If we specify value for version parameter on 'Write Assembly Version' task with revision (e.g. above "2.14.6878.*" so that the revision number is generated automatically by Ms build), the task results in error 'The Specified version is 2.14.6878.* not a valid'

We can successfully build our source code outside build master with this value in AssmeblyInfo.cs.

Build master would be fine with version parameter value '2.14.6878' and the resultant assemblies would have version '2.14.6878.0'. Thus the revision part of the Assembly version would be always 0.

Is there way to get around this?

Product: BuildMaster
Version: 6.0.11

4
replies

After evaluating several 5.1.x versions of ProGet, we've found that none are populating with the installation instructions to download via PackageManagement when browsing a module hosted in a PowerShell feed.

Interestingly enough, other feed types, such as NPM do show instructions for installation via PackageManagement.

Thanks,

Alex

Product: ProGet
Version: 5.1.15

1
replies

I can successfully push and pull images from Proget, but when I try and view them, I get an error and the following detail in the Diagnostic Center

System.UriFormatException: Invalid URI: The format of the URI could not be determined.
at System.Uri.CreateThis(String uri, Boolean dontEscape, UriKind uriKind)
at Inedo.ProGet.WebApplication.UnifiedFeedBrowsing.Feeds.DockerFeedDataFactory.<GetPackageAsync>d__8.MoveNext()
--- End of stack trace from previous location where exception was thrown ---
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)
at Inedo.ProGet.WebApplication.Pages.Packages.PackageVersionPage.<GetPackageAsync>d__21.MoveNext()

Product: ProGet
Version: 5.0.11

3
replies

Hello,

We have tried ProGet as an alternative for our current maven server. In order to migrate we have created a feed with a proxy against our old maven server, thinking that the dependencies should be pulled to and cached at the ProGet server when we use them. No package is cached however even though caching is enabled:

"Caching: Enabled (connector packages will be cached when they are first requested)"

Should it work at all for maven feeds? Does it need additional configuration?

/ Love

Product: ProGet
Version: 5.1.15

1
replies

I have downloaded and installed OtterSetup2.0.13 on a server. According to this link I should get a link to the Agent Download when I click on Create Server. This doesn't happen. I get a dialog that prompts for the server attributes, I choose Windows Agent, but there is no link and after the server is created the status shows "error".

Futhermore the same link states that I should be able to download the agent from all Otter downloads. It also says that you should make sure to get the version that corresponds to the version of Otter that was installed.

Can you post a link to the Otter Agent for Otter 2.0.13?

Product: Otter
Version: 2.0.13

1
replies

Hello,

I am trying to find out the end of life for the product ProGet 3 Enterprise.

Thanks.

Product: ProGet
Version: 3.0.0

Ask A Question
Page: 1 3 4 5 6 128