Ask A Question

View Question

Hello

I am trying to call a module from an orchestration or from a plan unsuccessfully.
What is the syntax ?

Best regards

Philippe

Product: Otter
Version: 2.1.1

Hello

I think there is a deeper problem with the module - or I really did not understand how it is working.

Here is what I did:

  1. Create an Asset TestAsset
  2. In the Default Asset, create a module ModuleFromDefaultAsset (put in whatever you want)
  3. In TestAsset, create a module ModuleFromTestAsset
  4. Create a role TestRole and assign it to Default asset
  5. In TestRole, create a configuration and
  • Drag'n drop Call ModuleFromDefaultAsset in the Visual Gui mode
  • Drag'n drop Call TestAsset::ModuleFromDefaultAsset in the Visual Gui mode

You get :

Call template ModuleFromDefaultAsset
Call template ModuleFromTestAsset
Template Error: template **ModuleFromTestAsset** could not be found.

The Raft TestAsset has been removed.

If you add it by in Edit mode, it working fine

If you go back to Visual mode it dissappears :(

Hope this help

Regards

Hello Philippe,

The visual editor losing module namespaces is OT-273, which is fixed in Otter 2.1.2.

Hi Ben

Thank you
I have seen you released OTTER and BUILDMASTER.

Cdt

Hello Ben

There is still a bug.
The Module define in a pipelineraft is not seen as available.

Test case:

Make one raft RAFT
Make one pipeline raft PipelineRaft (2 steps TEST (assign to env TEST and TEST2 assign to env TEST2)
Make a module TESTMODULE in Default, Raft PipelineRaft (Log-information TEST)
Make a Role and assign it TEST environnement.

In the Gui mode, you can see only:
Call TESTMODULE
Call RAFT::TESTMODULE

whereas Call PipelineRaft::TESTMODULE is also expected.

Regards

Philippe

Hello Philippe,

I've filed this as OT-283.

Hello Ben
Thank you

Answer Question